summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:03:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:40 +0200
commit90e990c20924114b078b57c7dba1c3f629255dd2 (patch)
treedaf36f712fcff745178a1e1d65729e689d3514be /gnu/packages/tex.scm
parentb2a3ad832bc8a3bd7caf116133ef27b2d5b5bae8 (diff)
gnu: Add texlive-crefthe.
* gnu/packages/tex.scm (texlive-crefthe): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 93b2384e70..eee87ce2f1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10245,6 +10245,28 @@ bearing the ability to support bachelor, master, doctor dissertations with
grace and speed.")
(license license:lppl1.3+)))
+(define-public texlive-crefthe
+ (package
+ (name "texlive-crefthe")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/crefthe/" "tex/latex/crefthe/")
+ (base32
+ "0gmyg9m4rma0qfg50d6i1lpdl4g71cx61517xl09vzy08r988i5j")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/crefthe")
+ (synopsis "Cross referencing with proper definite articles")
+ (description
+ "By default, when using @code{cleveref}'s @code{\\cref} to reference
+@code{theorem}-like environments, the names do not contain definite articles.
+In languages such as French, Italian, Portuguese, Spanish, etc., this results
+in incorrect grammar. For this purpose, the current package offers
+@code{\\crefthe}, which handles the definite articles properly (especially for
+the article contractions in many European languages).")
+ (license license:lppl1.3c)))
+
(define-public texlive-crimson
(package
(name "texlive-crimson")