summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:16:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:49 +0200
commit95a0bcc82da8930f30f6bb18f349f38aefbc3e21 (patch)
tree4bb6bc9eda45d126093467bfaaed639c052247e5 /gnu/packages/tex.scm
parent57b89f7a07d96206dc00b747e7168ae4bfdbb295 (diff)
gnu: Add texlive-msu-thesis.
* gnu/packages/tex.scm (texlive-msu-thesis): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e913fb43c9..abadf8f534 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -22248,6 +22248,29 @@ example is extracting single-instrument parts from a multi-instrument score.
source file. This should be used before using @code{\\TransformNotes}.")
(license license:gpl2)))
+(define-public texlive-msu-thesis
+ (package
+ (name "texlive-msu-thesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/msu-thesis/"
+ "tex/latex/msu-thesis/")
+ (base32
+ "0fsnrq8fvy8wgqfj5ccyw582142vd2haqlmgaxilvp7pybg9m100")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/msu-thesis")
+ (synopsis "Class for Michigan State University Master's and PhD theses")
+ (description
+ "This is a class file for producing dissertations and theses according to
+the Michigan State University Graduate School Guidelines for Electronic
+Submission of master's theses and dissertations. The class should meet all
+current requirements and is updated whenever the university guidelines change.
+The class is based on the @code{memoir} document class, and inherits the
+functionality of that class.")
+ (license license:lppl1.3+)))
+
(define-public texlive-mwcls
(package
(name "texlive-mwcls")