summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-07 09:56:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 09:57:13 +0300
commit211ea54122f3f72220dbe39dfbb86e506be925b9 (patch)
treedabd44763bee4272dfc868e93960e877b72fc625 /gnu/packages/web.scm
parent7612610c44f16fc8f2ff395d9a2d58101a7356aa (diff)
gnu: esbuild: Fix test-suite on riscv64-linux.
* gnu/packages/web.scm (esbuild)[arguments]: Adjust custom 'check phase to enable running the tests on riscv64-linux.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 26a059ddd4..95180ac316 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2023 Clément Lassieur <clement@lassieur.org>
@@ -1784,8 +1784,12 @@ UTS#46.")
(when tests?
;; The "Go Race Detector" is only supported on 64-bit
;; platforms, this variable disables it.
- (unless ,(target-64bit?)
- (setenv "ESBUILD_RACE" ""))
+ ;; TODO: Causes too many rebuilds, rewrite to limit to x86_64,
+ ;; aarch64 and ppc64le.
+ ,(if (target-riscv64?)
+ `(setenv "ESBUILD_RACE" "")
+ `(unless ,(target-64bit?)
+ (setenv "ESBUILD_RACE" "")))
(with-directory-excursion (string-append "src/" unpack-path)
(invoke "make" "test-go")))
#t)))))