summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-26 15:34:29 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-26 15:34:29 +0200
commit4028fd395e6d7f80f7bbeb4ff616b6b89b0bf654 (patch)
tree17bac0c3211a872d3a0292cae20347718ecdd5f7 /gnu/packages/web.scm
parent9d1cc6bc69d53bf8ad45ac94bc3c268125f86359 (diff)
parent72e2815d18ad688b0a16ce3b3efba1172423cec4 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm472
1 files changed, 411 insertions, 61 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8029903546..64d6874001 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -54,6 +54,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages apr)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cran)
#:use-module (gnu packages documentation)
#:use-module (gnu packages docbook)
#:use-module (gnu packages autotools)
@@ -72,9 +73,11 @@
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
- #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages java)
+ #:use-module (gnu packages javascript)
#:use-module (gnu packages image)
#:use-module (gnu packages libidn)
+ #:use-module (gnu packages libunistring)
#:use-module (gnu packages lua)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages base)
@@ -304,6 +307,42 @@ such as high performance, preforking, signal support, superdaemon awareness,
and UNIX socket support.")
(license l:perl-license)))
+(define-public icedtea-web
+ (package
+ (name "icedtea-web")
+ (version "1.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://icedtea.wildebeest.org/download/source/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "004kwrngyxxlrlzby4vzxjr0xcyngcdc9dfgnvi61ffnjr006ryf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-plugin" ;NPAPI plugins are obsolete nowadays.
+ (string-append "BIN_BASH=" (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--with-jdk-home=" (assoc-ref %build-inputs "jdk")))))
+ (outputs '("out" "doc"))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("zip" ,zip)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("jdk" ,icedtea "jdk")))
+ (home-page "http://icedtea.classpath.org/wiki/IcedTea-Web")
+ (synopsis "Java Web Start")
+ (description
+ "IcedTea-Web is an implementation of the @dfn{Java Network Launching
+Protocol}, also known as Java Web Start. This package provides tools and
+libraries for working with JNLP applets.")
+ ;; The program is mainly GPL2+, with some individual files under LGPL2.1+
+ ;; or dual licenses.
+ (license l:gpl2+)))
+
(define-public jansson
(package
(name "jansson")
@@ -449,7 +488,7 @@ current version of any major web browser.")
(define-public rapidjson
(package
(name "rapidjson")
- (version "1.0.2")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -458,13 +497,7 @@ current version of any major web browser.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0rl6s0vg5y1dhh9vfl1lqay3sxf69sxjh0czxrjmasn7ng91wwf3"))
- (modules '((guix build utils)))
- (snippet
- ;; Building with GCC 4.8 with -Werror was fine, but 4.9.3
- ;; complains in new ways, so turn of -Werror.
- '(substitute* (find-files "." "^CMakeLists\\.txt$")
- (("-Werror") "")))))
+ "13nrpvw8f1wx0ga7svbzld7pgrv8l172nangpipnj7jaf0lysz5z"))))
(build-system cmake-build-system)
(arguments
`(,@(if (string-prefix? "aarch64" (or (%current-target-system)
@@ -543,7 +576,7 @@ for efficient socket-like bidirectional reliable communication channels.")
(define-public libpsl
(package
(name "libpsl")
- (version "0.17.0")
+ (version "0.18.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/rockdaboot/libpsl/"
@@ -551,10 +584,13 @@ for efficient socket-like bidirectional reliable communication channels.")
"/libpsl-" version ".tar.gz"))
(sha256
(base32
- "0jyxwc6bcvkcahkwcq237a0x209cysb63n5lak5m7zbglbb2jmq2"))))
+ "00iids8ldsqnnndmcfjp6kc00lv7fawf5l24mpbdbkh98yazgc4i"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(inputs
- `(("icu4c" ,icu4c)
+ `(("libidn2" ,libidn2)
+ ("libunistring" ,libunistring)
("python-2" ,python-2)))
(home-page "https://github.com/rockdaboot/libpsl")
(synopsis "C library for the Publix Suffix List")
@@ -934,7 +970,7 @@ minimum to provide high performance operation.")
(define-public sassc
;; libsass must be statically linked and it isn't included in the sassc
;; release tarballs, hence this odd package recipe.
- (let* ((version "3.2.5")
+ (let* ((version "3.4.5")
(libsass
(origin
(method url-fetch)
@@ -944,7 +980,7 @@ minimum to provide high performance operation.")
(file-name (string-append "libsass-" version ".tar.gz"))
(sha256
(base32
- "1x25k6p1s1yzsdpzb7bzh8japilmi1mk3z96q66pycbinj9z9is4")))))
+ "1j22138l5ymqjfj5zan9d2hipa3ahjmifgpjahqy1smlg5sb837x")))))
(package
(name "sassc")
(version version)
@@ -955,11 +991,16 @@ minimum to provide high performance operation.")
(file-name (string-append "sassc-" version ".tar.gz"))
(sha256
(base32
- "1xf3w75w840rj0nx375rxi7mcv1ngqqq8p3zrzjlyx8jfpnldmv5"))))
+ "1xk4kmmvziz9sal3swpqa10q0s289xjpcz8aggmly8mvxvmngsi9"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags '("CC=gcc")
+ `(#:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
#:test-target "test"
+ ;; FIXME: "make test" rebuilds the application and gets lost in a
+ ;; non-existing directory.
+ #:tests? #f
#:phases
(modify-phases %standard-phases
(delete 'configure)
@@ -969,13 +1010,7 @@ minimum to provide high performance operation.")
(begin
(setenv "SASS_LIBSASS_PATH"
(string-append (getcwd) "/libsass-" ,version))
- #t))))
- (replace 'install ; no install target
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
- (mkdir-p bin)
- (copy-file "bin/sassc" (string-append bin "/sassc"))
- #t))))))
+ #t)))))))
(inputs
`(("libsass" ,libsass)))
(synopsis "CSS pre-processor")
@@ -1026,6 +1061,13 @@ to perl-code, for faster generation of access_log lines.")
(base32
"02afhlrdq5hh5g8b32fa79fqq5i76qzwfqqvfi9zi57h31szl536"))))
(build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-env
+ ;; Fix the build with Perl 5.26.0. Try removing this phase for later
+ ;; versions of perl-authen-sasl.
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
(propagated-inputs
`(("perl-digest-hmac" ,perl-digest-hmac)
("perl-gssapi" ,perl-gssapi)))
@@ -1049,7 +1091,8 @@ to perl-code, for faster generation of access_log lines.")
"0j1rrld13cjk7ks92b5hv3xw4rfm2lvmksb4rlzd8mx0a0wj0rc5"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-http-request-ascgi" ,perl-http-request-ascgi)))
+ `(("perl-http-request-ascgi" ,perl-http-request-ascgi)
+ ("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
("perl-data-visitor" ,perl-data-visitor)
@@ -1073,7 +1116,8 @@ action, which will forward to the first available view.")
"1mpa64p61f3dp24xnhdraswch4sqj5vyv1iivcvvh5h0xi0haiy0"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-test-requires" ,perl-test-requires)))
+ `(("perl-test-requires" ,perl-test-requires)
+ ("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
("perl-class-inspector" ,perl-class-inspector)
@@ -1115,6 +1159,7 @@ regular method.")
("perl-catalyst-plugin-session-state-cookie"
,perl-catalyst-plugin-session-state-cookie)
("perl-dbd-sqlite" ,perl-dbd-sqlite)
+ ("perl-module-install" ,perl-module-install)
("perl-test-www-mechanize-catalyst" ,perl-test-www-mechanize-catalyst)))
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
@@ -1144,6 +1189,8 @@ DBIx::Class.")
(base32
"0wfj4vnn2cvk6jh62amwlg050p37fcwdgrn9amcz24z6w4qgjqvz"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
("perl-moose" ,perl-moose)))
@@ -1242,6 +1289,7 @@ when the dispatch type is first seen in your application.")
(build-system perl-build-system)
(native-inputs
`(("perl-dbd-sqlite" ,perl-dbd-sqlite)
+ ("perl-module-install" ,perl-module-install)
("perl-test-exception" ,perl-test-exception)
("perl-test-requires" ,perl-test-requires)))
(propagated-inputs
@@ -1310,6 +1358,8 @@ for you. It will work even with Catalyst debug logging turned off.")
(base32
"0v6hb4r1wv3djrnqvnjcn3xx1scgqzx8nyjdg9lfc1ybvamrl0rn"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-catalyst-plugin-session" ,perl-catalyst-plugin-session)
("perl-catalyst-runtime" ,perl-catalyst-runtime)
@@ -1345,7 +1395,8 @@ system authorises them to do).")
"0l83lkwmq0lngwh8b1rv3r719pn8w1gdbyhjqm74rnd0wbjl8h7f"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-test-exception" ,perl-test-exception)))
+ `(("perl-module-install" ,perl-module-install)
+ ("perl-test-exception" ,perl-test-exception)))
(propagated-inputs
`(("perl-catalyst-plugin-authentication"
,perl-catalyst-plugin-authentication)
@@ -1398,7 +1449,8 @@ Catalyst.")
"19j7p4v7mbx6wrmpvmrnd974apx7hdl2s095ga3b9zcbdrl77h5q"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-path-class" ,perl-path-class)))
+ `(("perl-path-class" ,perl-path-class)
+ ("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
("perl-config-any" ,perl-config-any)
@@ -1425,7 +1477,8 @@ formats.")
"171vi9xcl775scjaw4fcfdmqvz0rb1nr0xxg2gb3ng6bjzpslhgv"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-test-deep" ,perl-test-deep)
+ `(("perl-module-install" ,perl-module-install)
+ ("perl-test-deep" ,perl-test-deep)
("perl-test-exception" ,perl-test-exception)))
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
@@ -1456,6 +1509,8 @@ management in web applications together: the state, and the store.")
(base32
"1rvxbfnpf9x2pc2zgpazlcgdlr2dijmxgmcs0m5nazs0w6xikssb"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-catalyst-plugin-session" ,perl-catalyst-plugin-session)
("perl-catalyst-runtime" ,perl-catalyst-runtime)
@@ -1514,6 +1569,8 @@ memory interprocess cache. It is based on Cache::FastMmap.")
(base32
"1b2ksz74cpigxqzf63rddar3vfmnbpwpdcbs11v0ml89pb8ar79j"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
("perl-devel-stacktrace" ,perl-devel-stacktrace)
@@ -1539,6 +1596,8 @@ number, file name, and code context surrounding the line number.")
(base32
"1h8f12bhzh0ssq9gs8r9g3hqn8zn2k0q944vc1vm8j81bns16msy"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
("perl-mime-types" ,perl-mime-types)
@@ -1559,7 +1618,7 @@ MIME type directly to the browser, without being processed through Catalyst.")
(define-public perl-catalyst-runtime
(package
(name "perl-catalyst-runtime")
- (version "5.90082")
+ (version "5.90115")
(source
(origin
(method url-fetch)
@@ -1567,10 +1626,11 @@ MIME type directly to the browser, without being processed through Catalyst.")
"Catalyst-Runtime-" version ".tar.gz"))
(sha256
(base32
- "1gs70nq4rikpq6siwds9disb1z03vwjzf979xi9kf7saa1drfncs"))))
+ "0kh3ng6pjpxmndq9vrn515f70x7h44ish5bsgjwj4pjvchcyivzm"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-test-fatal" ,perl-test-fatal)))
+ `(("perl-module-install" ,perl-module-install)
+ ("perl-test-fatal" ,perl-test-fatal)))
(propagated-inputs
`(("perl-cgi-simple" ,perl-cgi-simple)
("perl-cgi-struct" ,perl-cgi-struct)
@@ -1638,7 +1698,8 @@ run an application on the web, either by doing them itself, or by letting you
(native-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
("perl-catalystx-roleapplicator" ,perl-catalystx-roleapplicator)
- ("perl-http-message" ,perl-http-message)))
+ ("perl-http-message" ,perl-http-message)
+ ("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-moose" ,perl-moose)
("perl-namespace-autoclean" ,perl-namespace-autoclean)
@@ -1667,6 +1728,7 @@ replaced with the contents of the X-Request-Base header.")
(build-system perl-build-system)
(native-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
+ ("perl-module-install" ,perl-module-install)
("perl-test-simple" ,perl-test-simple)
("perl-test-www-mechanize-catalyst" ,perl-test-www-mechanize-catalyst)
("perl-text-csv" ,perl-text-csv)
@@ -1692,7 +1754,8 @@ table based report in a variety of formats (CSV, HTML, etc.).")
"0x943j1n2r0zqanyzdrs1xsnn8ayn2wqskn7h144xcqa6v6gcisl"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-yaml" ,perl-yaml)))
+ `(("perl-module-install" ,perl-module-install)
+ ("perl-yaml" ,perl-yaml)))
(inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
("perl-json-maybexs" ,perl-json-maybexs)
@@ -1801,7 +1864,8 @@ application classes.")
"0h02mpkc4cmi3jpvcd7iw7xyzx55bqvvl1qkf967gqkvpklm0qx5"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-test-www-mechanize-catalyst" ,perl-test-www-mechanize-catalyst)))
+ `(("perl-module-install" ,perl-module-install)
+ ("perl-test-www-mechanize-catalyst" ,perl-test-www-mechanize-catalyst)))
(propagated-inputs
`(("perl-catalyst-runtime" ,perl-catalyst-runtime)
("perl-moose" ,perl-moose)
@@ -1970,7 +2034,11 @@ with Encode::decode(locale => $string).")
(build-system perl-build-system)
(arguments
;; Tests expect to query files at http://stupidfool.org/perl/feeds/
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-env
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1"))))))
(inputs
`(("perl-class-errorhandler" ,perl-class-errorhandler)
("perl-html-parser" ,perl-html-parser)
@@ -2158,15 +2226,15 @@ in tables within an HTML document, either as text or encoded element trees.")
(define-public perl-html-tree
(package
(name "perl-html-tree")
- (version "5.03")
+ (version "5.06")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/C/CJ/CJM/"
+ (uri (string-append "mirror://cpan/authors/id/K/KE/KENTNL/"
"HTML-Tree-" version ".tar.gz"))
(sha256
(base32
- "13qlqbpixw470gnck0xgny8hyjj576m8y24bba2p9ai2lvy76vbx"))))
+ "0vjk4xrybjqs511qrh9cymhpbg9m3jjqr52qr035k6nzrccyndlw"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)
@@ -2229,14 +2297,14 @@ kinds of HTML parsing operations.")
(define-public perl-html-template
(package
(name "perl-html-template")
- (version "2.95")
+ (version "2.97")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/W/WO/WONKO/"
+ (uri (string-append "mirror://cpan/authors/id/S/SA/SAMTREGAR/"
"HTML-Template-" version ".tar.gz"))
(sha256
(base32
- "07ahpfgidxsw2yb7y8i7bbr8s64aq6qgq832h9jswmksxbd0l43q"))))
+ "17qjw8swj2q4b1ic285pndgrkmvpsqw0j68nhqzpk1daydhsyiv5"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-cgi" ,perl-cgi)))
@@ -2459,6 +2527,8 @@ supported.")
(base32
"02d84xq1mm53c7jl33qyb7v5w4372vydp74z6qj0vc96wcrnhkkr"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
(home-page "http://search.cpan.org/dist/HTTP-Parser-XS")
(synopsis "Fast HTTP request parser")
(description "HTTP::Parser::XS is a fast, primitive HTTP request/response
@@ -2505,7 +2575,16 @@ environment from an HTTP::Request.")
(arguments
;; See the discussion of a related tests issue at
;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00346.html
- `(#:tests? #f))
+ `(#:tests? #f
+
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) ":"
+ (getenv "PERL5LIB")))
+ #t)))))
(home-page "http://search.cpan.org/dist/HTTP-Server-Simple")
(synopsis "Lightweight HTTP server")
(description "HTTP::Server::Simple is a simple standalone HTTP daemon with
@@ -2785,7 +2864,7 @@ HTTP/1.1.")
(define-public perl-net-server
(package
(name "perl-net-server")
- (version "2.008")
+ (version "2.009")
(source
(origin
(method url-fetch)
@@ -2793,7 +2872,7 @@ HTTP/1.1.")
"Net-Server-" version ".tar.gz"))
(sha256
(base32
- "182gfikn7r40kmm3d35m2qc6r8g0y1j8gxbn9ffaawf8xmm0a889"))))
+ "0gw1k9gcw7habbkxvsfa2gz34brlbwcidk6khgsf1qjm0dbccrw2"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/Net-Server")
(synopsis "Extensible Perl server engine")
@@ -2955,6 +3034,8 @@ required.")
(base32
"1zmsccdy6wr5hxzj07r1nsmaymyibk87p95z0wzknjw10lwmqs9f"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-plack" ,perl-plack)))
(home-page "http://search.cpan.org/dist/Plack-Middleware-ReverseProxy")
@@ -3022,6 +3103,8 @@ either mocked HTTP or a locally spawned server.")
(build-system perl-build-system)
(native-inputs
`(("perl-test-exception" ,perl-test-exception)))
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
(propagated-inputs
`(("perl-carp-assert-more" ,perl-carp-assert-more)
("perl-html-form" ,perl-html-form)
@@ -3054,6 +3137,7 @@ WWW::Mechanize that incorporates features for web application testing.")
`(("perl-catalyst-plugin-session" ,perl-catalyst-plugin-session)
("perl-catalyst-plugin-session-state-cookie"
,perl-catalyst-plugin-session-state-cookie)
+ ("perl-module-install" ,perl-module-install)
("perl-test-exception" ,perl-test-exception)
("perl-test-pod" ,perl-test-pod)
("perl-test-utf8" ,perl-test-utf8)))
@@ -3207,6 +3291,7 @@ methods for WebSocket URIs as it does for HTTP URIs.")
(native-inputs
`(("perl-test-pod-coverage" ,perl-test-pod-coverage)
("perl-test-pod" ,perl-test-pod)
+ ("perl-module-install" ,perl-module-install)
("perl-json" ,perl-json)))
(home-page "http://search.cpan.org/dist/URI-Template")
(synopsis "Object for handling URI templates")
@@ -3229,7 +3314,18 @@ RFC 6570.")
"1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))
(build-system perl-build-system)
(arguments
- '(#:tests? #f)) ;XXX: tests require network access
+ '(#:tests? #f ;XXX: tests require network access
+
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) ":"
+ (getenv "PERL5LIB")))
+ #t)))))
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
(inputs `(("curl" ,curl)))
(synopsis "Perl extension interface for libcurl")
(description
@@ -3241,21 +3337,26 @@ library.")
(define-public perl-www-mechanize
(package
(name "perl-www-mechanize")
- (version "1.73")
+ (version "1.86")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+ (uri (string-append "mirror://cpan/authors/id/O/OA/OALDERS/"
"WWW-Mechanize-" version ".tar.gz"))
(sha256
(base32
- "1zrw8aadhwy48q51x2z2rqlkwf17bya4j4h3hy89mw783j96rmg9"))))
+ "0sfl6b7mx8nannnh3ys5jk44d1s1b2d1mffrnrphkzzykaw6hm0f"))))
(build-system perl-build-system)
(native-inputs ;only for tests
- `(("perl-cgi" ,perl-cgi)))
+ `(("perl-cgi" ,perl-cgi)
+ ("perl-test-deep" ,perl-test-deep)
+ ("perl-test-fatal" ,perl-test-fatal)
+ ("perl-test-output" ,perl-test-output)
+ ("perl-test-warnings" ,perl-test-warnings)))
(propagated-inputs
`(("perl-html-form" ,perl-html-form)
("perl-html-parser" ,perl-html-parser)
+ ("perl-html-tree" ,perl-html-tree)
("perl-http-message" ,perl-http-message)
("perl-http-server-simple" ,perl-http-server-simple)
("perl-libwww" ,perl-libwww)
@@ -3349,13 +3450,13 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(define-public r-httpuv
(package
(name "r-httpuv")
- (version "1.3.3")
+ (version "1.3.5")
(source (origin
(method url-fetch)
(uri (cran-uri "httpuv" version))
(sha256
(base32
- "0aibs0hf38n8f6xxx4g2i2lzd6l5h92m5pscx2z834sdvhnladxv"))))
+ "1sg4f223zfyd265b28rlhsn3b6mqflcpnmya98cjmjncmy9vjdj3"))))
(build-system r-build-system)
(native-inputs `(("r-rcpp" ,r-rcpp)))
(home-page "https://github.com/rstudio/httpuv")
@@ -3373,13 +3474,13 @@ particularly easy to create complete web applications using httpuv alone.")
(define-public r-jsonlite
(package
(name "r-jsonlite")
- (version "1.4")
+ (version "1.5")
(source (origin
(method url-fetch)
(uri (cran-uri "jsonlite" version))
(sha256
(base32
- "11rgkjp5qir79niad0aizjxvjzyvkl6l9nsrv3ikv446vllmrasn"))))
+ "00lfg464jhf7k01bal9pcjvbdf5cxk6xi2h46hccp1x3h883g434"))))
(build-system r-build-system)
(home-page "http://arxiv.org/abs/1403.2805")
(synopsis "Robust, high performance JSON parser and generator for R")
@@ -3397,13 +3498,13 @@ in systems and applications.")
(define-public r-servr
(package
(name "r-servr")
- (version "0.5")
+ (version "0.6")
(source (origin
(method url-fetch)
(uri (cran-uri "servr" version))
(sha256
(base32
- "1ixcl9xjc1k9zvl6v6bsw4kpramr1h53b4s46qg8kahkqy6kqd8a"))))
+ "0sqz3wssxa19g9mpmf9s4gx2a5rvzl8nrd11qkgpz5v3iqsc6ysr"))))
(build-system r-build-system)
(propagated-inputs
`(("r-httpuv" ,r-httpuv)
@@ -3422,13 +3523,13 @@ directory.")
(define-public r-htmltools
(package
(name "r-htmltools")
- (version "0.3.5")
+ (version "0.3.6")
(source (origin
(method url-fetch)
(uri (cran-uri "htmltools" version))
(sha256
(base32
- "0j9bf80grd6gwh7116m575pycv87c0wcwkxsz3gzzfs4aw3pxyr9"))))
+ "18k8r1s8sz1jy7dkz35n69wj20xhmllr53xmwb4pdzf2z61gpbs4"))))
(build-system r-build-system)
(arguments
`(#:phases
@@ -3456,13 +3557,13 @@ directory.")
(define-public r-htmlwidgets
(package
(name "r-htmlwidgets")
- (version "0.8")
+ (version "0.9")
(source (origin
(method url-fetch)
(uri (cran-uri "htmlwidgets" version))
(sha256
(base32
- "1df3pwl34rvdbr9sgr5h27q9bmqpckvpwq4frl3d1v614y3vfclj"))))
+ "0plqkfqys1ca3ki7sb7yc6gwjpi7yy4g3mzh7hfy8s6qri0vam0i"))))
(build-system r-build-system)
(propagated-inputs
`(("r-htmltools" ,r-htmltools)
@@ -3510,13 +3611,13 @@ LaTeX.")
(define-public r-curl
(package
(name "r-curl")
- (version "2.5")
+ (version "2.8.1")
(source (origin
(method url-fetch)
(uri (cran-uri "curl" version))
(sha256
(base32
- "09p86i5f88gx1i7cidm1ka56g0jjkghqfam96p1jhwlh2fv6nrks"))))
+ "0dgfl7wn4r8inv55xnk4ybf1y2x4qmi4cbr6phr3lfi1dnjm4hsm"))))
(build-system r-build-system)
(arguments
`(#:phases
@@ -4695,3 +4796,252 @@ arrays. It creates a JSON string on stdout from words provided as
command-line arguments or read from stdin.")
(license (list l:gpl2+
l:expat)))) ; json.c, json.h
+
+(define-public python-internetarchive
+ (package
+ (name "python-internetarchive")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/jjjake/internetarchive/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lj4r0y67mwjns2gcjvw0y7m5x0vqir2iv7s4q2y93492azli1qh"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; 11 tests of 105 fail to mock "requests".
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs target (tests? (not target)) #:allow-other-keys)
+ (if tests?
+ (begin
+ (add-installed-pythonpath inputs outputs)
+ (setenv "PATH" (string-append (assoc-ref outputs "out") "/bin"
+ ":" (getenv "PATH")))
+ (zero? (system* "py.test")))
+ (begin
+ (format #t "test suite not run~%")
+ #t)))))))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)
+ ("python-jsonpatch" ,python-jsonpatch-0.4)
+ ("python-docopt" ,python-docopt)
+ ("python-clint" ,python-clint)
+ ("python-six" ,python-six)
+ ("python-schema" ,python-schema-0.5)
+ ("python-backports-csv" ,python-backports-csv)))
+ (native-inputs
+ `(("python-pytest-3.0" ,python-pytest-3.0)
+ ("python-pytest-capturelog" ,python-pytest-capturelog)
+ ("python-responses" ,python-responses)))
+ (home-page "https://github.com/jjjake/internetarchive")
+ (synopsis "Command-line interface to archive.org")
+ (description "@code{ia} is a command-line tool for using
+@url{archive.org} from the command-line. It also emplements the
+internetarchive python module for programatic access to archive.org.")
+ (properties
+ `((python2-variant . ,(delay python2-internetarchive))))
+ (license l:agpl3+)))
+
+(define-public python2-internetarchive
+ (package-with-python2
+ (strip-python2-variant python-internetarchive)))
+
+(define-public r-shiny
+ (package
+ (name "r-shiny")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rstudio/shiny/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0z2v2s4hd44mvzjn7r70549kdzkrrch9nxhp27r6x2cy6micizm3"))))
+ (build-system r-build-system)
+ (arguments
+ `(#:modules ((guix build r-build-system)
+ (guix build minify-build-system)
+ (guix build utils)
+ (ice-9 match))
+ #:imported-modules (,@%r-build-system-modules
+ (guix build minify-build-system))
+ #:phases
+ (modify-phases (@ (guix build r-build-system) %standard-phases)
+ (add-after 'unpack 'replace-bundled-minified-JavaScript
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((replace-file (lambda (old new)
+ (format #t "replacing ~a with ~a\n" old new)
+ (delete-file old)
+ (symlink new old))))
+ ;; NOTE: Files in ./inst/www/shared/datepicker/js/locales/
+ ;; contain just data. They are not minified code, so we don't
+ ;; replace them.
+ (with-directory-excursion "inst/www/shared"
+ (replace-file "bootstrap/shim/respond.min.js"
+ (string-append (assoc-ref inputs "js-respond")
+ "/share/javascript/respond.min.js"))
+ (replace-file "bootstrap/shim/html5shiv.min.js"
+ (string-append (assoc-ref inputs "js-html5shiv")
+ "/share/javascript/html5shiv.min.js"))
+ (replace-file "json2-min.js"
+ (string-append (assoc-ref inputs "js-json2")
+ "/share/javascript/json2.min.js"))
+ (replace-file "strftime/strftime-min.js"
+ (string-append (assoc-ref inputs "js-strftime")
+ "/share/javascript/strftime.min.js"))
+ (replace-file "highlight/highlight.pack.js"
+ (string-append (assoc-ref inputs "js-highlight")
+ "/share/javascript/highlight.min.js"))
+ (replace-file "datatables/js/jquery.dataTables.min.js"
+ (string-append (assoc-ref inputs "js-datatables")
+ "/share/javascript/jquery.dataTables.min.js"))
+ (replace-file "selectize/js/selectize.min.js"
+ (string-append (assoc-ref inputs "js-selectize")
+ "/share/javascript/selectize.min.js"))
+ (replace-file "selectize/js/es5-shim.min.js"
+ (string-append (assoc-ref inputs "js-es5-shim")
+ "/share/javascript/es5-shim.min.js"))
+ (for-each (match-lambda
+ ((source . target)
+ (delete-file target)
+ (minify source #:target target)))
+ '(("jqueryui/jquery-ui.js" .
+ "jqueryui/jquery-ui.min.js")
+ ("showdown/src/showdown.js" .
+ "showdown/compressed/showdown.js")
+ ("datepicker/js/bootstrap-datepicker.js" .
+ "datepicker/js/bootstrap-datepicker.min.js")
+ ("ionrangeslider/js/ion.rangeSlider.js" .
+ "ionrangeslider/js/ion.rangeSlider.min.js")
+ ("bootstrap/js/bootstrap.js" .
+ "bootstrap/js/bootstrap.min.js")
+ ("shiny.js" .
+ "shiny.min.js")
+ ("jquery.js" .
+ "jquery.min.js")))))
+ #t)))))
+ (propagated-inputs
+ `(("r-httpuv" ,r-httpuv)
+ ("r-mime" ,r-mime)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-xtable" ,r-xtable)
+ ("r-digest" ,r-digest)
+ ("r-htmltools" ,r-htmltools)
+ ("r-r6" ,r-r6)
+ ("r-sourcetools" ,r-sourcetools)))
+ (inputs
+ `(("js-datatables" ,js-datatables)
+ ("js-html5shiv" ,js-html5shiv)
+ ("js-json2" ,js-json2)
+ ("js-respond" ,js-respond)
+ ("js-selectize" ,js-selectize)
+ ("js-strftime" ,js-strftime)
+ ("js-highlight" ,js-highlight)
+ ("js-es5-shim" ,js-es5-shim)))
+ (home-page "http://shiny.rstudio.com")
+ (synopsis "Easy interactive web applications with R")
+ (description
+ "Makes it incredibly easy to build interactive web applications
+with R. Automatic \"reactive\" binding between inputs and outputs and
+extensive prebuilt widgets make it possible to build beautiful,
+responsive, and powerful applications with minimal effort.")
+ (license l:artistic2.0)))
+
+(define-public r-crosstalk
+ (package
+ (name "r-crosstalk")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "crosstalk" version))
+ (sha256
+ (base32
+ "0lfa89vhrzi7a1rghmygcjr8gzddw35sinb3jx6g49mc9jias7mk"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-htmltools" ,r-htmltools)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-lazyeval" ,r-lazyeval)
+ ("r-r6" ,r-r6)
+ ("r-shiny" ,r-shiny)))
+ (home-page "https://rstudio.github.io/crosstalk/")
+ (synopsis "Inter-widget interactivity for HTML widgets")
+ (description
+ "This package provides building blocks for allowing HTML widgets to
+communicate with each other, with Shiny or without (i.e. static @code{.html}
+files). It currently supports linked brushing and filtering.")
+ (license l:expat)))
+
+(define-public r-rook
+ (package
+ (name "r-rook")
+ (version "1.1-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Rook" version))
+ (sha256
+ (base32
+ "00s9a0kr9rwxvlq433daxjk4ji8m0w60hjdprf502msw9kxfrx00"))))
+ (properties `((upstream-name . "Rook")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-brew" ,r-brew)))
+ (home-page "http://cran.r-project.org/web/packages/Rook")
+ (synopsis "Web server interface for R")
+ (description
+ "This package contains the Rook specification and convenience software
+for building and running Rook applications. A Rook application is an R
+reference class object that implements a @code{call} method or an R closure
+that takes exactly one argument, an environment, and returns a list with three
+named elements: the @code{status}, the @code{headers}, and the @code{body}.")
+ (license l:gpl2)))
+
+(define-public rss-bridge
+ (package
+ (name "rss-bridge")
+ (version "2017-08-03")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/RSS-Bridge/rss-bridge/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05s16y552hbyj91s7bnlkx1bi64s6aw0fjy29az8via3i3b21yhl"))))
+ (build-system trivial-build-system)
+ (native-inputs
+ `(("gzip" ,gzip)
+ ("tar" ,tar)))
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils)
+ (ice-9 match))
+ (let* ((out (assoc-ref %outputs "out"))
+ (share-rss-bridge (string-append out "/share/rss-bridge")))
+ (set-path-environment-variable
+ "PATH" '("bin") (map (match-lambda ((_ . input) input))
+ %build-inputs))
+ (mkdir-p share-rss-bridge)
+ (system* "tar" "xvf" (assoc-ref %build-inputs "source")
+ "--strip-components" "1" "-C" share-rss-bridge)
+ #t))))
+ (home-page "https://github.com/RSS-Bridge/rss-bridge")
+ (synopsis "Generate Atom feeds for social networking websites")
+ (description "rss-bridge generates Atom feeds for social networking
+websites lacking feeds. Supported websites include Facebook, Twitter,
+Instagram and YouTube.")
+ (license (list l:public-domain
+ l:expat)))) ;; vendor/simplehtmldom/simple_html_dom.php