summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-10-09 21:42:09 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-09 22:32:14 +0200
commit27a3a5d193c9c2660c51aa389f642fd08d956dd1 (patch)
tree4a360ae87a4f95816e221e8a50a1662d405b062c /gnu/packages
parente3362e249a48489d51fe6a5a92f3ce0073af30cf (diff)
gnu: svt-hevc: Mark as supported on x86_64-linux only.
This package fails to build on i686-linux: it makes use of SSE2 and related intrinsics not supported on i686. * gnu/packages/video.scm (svt-hevc)[supported-systems]: Remove "i686-linux". * gnu/packages/gstreamer.scm (gst-plugins-bad)[inputs]: Adjust condition accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gstreamer.scm6
-rw-r--r--gnu/packages/video.scm2
2 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 5017da1091..6e2902d76a 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -889,9 +889,9 @@ model to base your own plug-in on, here it is.")
("soundtouch" ,soundtouch)
("spandsp" ,spandsp)
("srt" ,srt)
- ,@(if (target-x86?)
- `(("svthevcenc" ,svt-hevc))
- '())
+ ,@(if (target-x86-64?)
+ `(("svthevcenc" ,svt-hevc))
+ '())
("tinyalsa" ,tinyalsa)
("transcode" ,transcode)
("usrsctp" ,usrsctp)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e6da6ce04f..876f0c66cb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -335,7 +335,7 @@ the SVT-HEVC encoder, it is possible to spread video encoding processing across
multiple Intel's Xeon processors to achieve a real advantage of processing
efficiency.")
(home-page "https://01.org/svt")
- (supported-systems '("x86_64-linux" "i686-linux"))
+ (supported-systems '("x86_64-linux"))
(license (license:non-copyleft "file:///LICENSE.md"))))
(define-public mediasdk