summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:22:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:56 +0200
commit2f0c63426c21992650ccbe2fd1819c03559bb46f (patch)
tree3fd675954a6fefeff3f125bc91531a22a1cfa603 /gnu/packages
parent03557bd256f301317b4011e58b0f178c53553419 (diff)
gnu: Add texlive-opteng.
* gnu/packages/tex.scm (texlive-opteng): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 746af02bb7..c47e48f8bf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23914,6 +23914,27 @@ easily available. Especially, these symbols are used in scientific plots, but
the potential user is allowed to use them in other ways.")
(license license:lppl1.3+)))
+(define-public texlive-opteng
+ (package
+ (name "texlive-opteng")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/opteng/" "tex/latex/opteng/")
+ (base32
+ "1svis9n0ssrc6pnvlshwprfjimdfrbisb0jjnlhhys343dv95jqs")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/opteng")
+ (synopsis "SPIE Optical Engineering and OE Letters manuscript template")
+ (description
+ "With this template, and associated style and LaTeX packages, it is
+possible to estimate the page length of manuscripts for submission to the SPIE
+journals @emph{Optical Engineering} and @emph{Optical Engineering Letters}.
+With a strict three-page limit, this is particularly important for the latter.
+The template gives simple instructions on how to prepare the manuscript.")
+ (license license:lppl)))
+
(define-public texlive-ordinalpt
(package
(name "texlive-ordinalpt")