summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:41:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:08 +0200
commit5f68114d358454c9d7b2db41381fc86787cc980a (patch)
treee89a1f1c20cf217392395838db86ea7e307d4a47 /gnu/packages
parent2e012f6a5a8b1c7a3ab97b014966552f49267e2c (diff)
gnu: Add texlive-suftesi.
* gnu/packages/tex.scm (texlive-suftesi): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 25f22d788e..bda7cd20c1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -28638,6 +28638,72 @@ of parameters that the user sets via macros.
The bundle comes with a set of ready-prepared puzzle files.")
(license license:lppl)))
+(define-public texlive-suftesi
+ (package
+ (name "texlive-suftesi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/suftesi/" "source/latex/suftesi/"
+ "tex/latex/suftesi/")
+ (base32
+ "1m1gsnfcnw9ylz2aik20rqs6jk0p647wlkfm813spl0hbjnpzkpc")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:tex-format "lualatex"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'support-greek-input
+ (lambda _
+ (substitute* "source/latex/suftesi/suftesi.dtx"
+ (("\\\\usepackage\\[T1\\]\\{fontenc\\}")
+ "\\usepackage[LGR, T1]{fontenc}")))))))
+ (native-inputs
+ (list (texlive-updmap.cfg
+ (list texlive-babel-greek
+ texlive-biblatex
+ texlive-biblatex-philosophy
+ texlive-booktabs
+ texlive-cbfonts
+ texlive-cbfonts-fd
+ texlive-cochineal
+ texlive-csquotes
+ texlive-etoolbox
+ texlive-fontaxes
+ texlive-fontsize
+ texlive-fontspec
+ texlive-greek-fontenc
+ texlive-guitlogo
+ texlive-hologo
+ texlive-hypdoc
+ texlive-inconsolata
+ texlive-libertine
+ texlive-listings
+ texlive-ltxdockit
+ texlive-manfnt
+ texlive-mathalpha
+ texlive-mdframed
+ texlive-microtype
+ texlive-multirow
+ texlive-needspace
+ texlive-newtx
+ texlive-parskip
+ texlive-pgf
+ texlive-sectsty
+ texlive-siunitx
+ texlive-txfonts
+ texlive-upquote
+ texlive-xcolor
+ texlive-xkeyval
+ texlive-xstring
+ texlive-zref))))
+ (home-page "https://ctan.org/pkg/suftesi")
+ (synopsis "Document class for typesetting theses, books and articles")
+ (description
+ "The class can be used to typeset any kind of book (originally designed
+for use in the humanities).")
+ (license license:lppl1.3+)))
+
(define-public texlive-superiors
(package
(name "texlive-superiors")