summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-03 16:04:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:15 +0300
commit806042ae9e831c16e27e18725bfb2d3709af5f5f (patch)
treee53b351cd25970baf1b6d0f607f7c08747756e18 /gnu/packages
parentfd75e263ee1d2cc2eac623b3d8e0cc00802449cd (diff)
gnu: rust-tempfile-3: Update to 3.8.0.
* gnu/packages/crates-io.scm (rust-tempfile-3): Update to 3.8.0. [cargo-inputs]: Replace rust-fastrand-1 with 2, rust-rustix-0.37 with 0.38, rust-windows-sys-0.45 with 0.48.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8bbd766b08..5aa384df4a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -70016,22 +70016,22 @@ deleting all contents when it's dropped.")
(define-public rust-tempfile-3
(package
(name "rust-tempfile")
- (version "3.5.0")
+ (version "3.8.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "tempfile" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "163rp254r3x7i5hisagrpxid2166pq94jvk511dpkmc1yf2fryxr"))))
+ (base32 "1vsl2193w3gpx3mwj36fwx3v6q2qyvmzrdn6m8fgfsjkrkrx556b"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-cfg-if" ,rust-cfg-if-1)
- ("rust-fastrand" ,rust-fastrand-1)
+ ("rust-fastrand" ,rust-fastrand-2)
("rust-redox-syscall" ,rust-redox-syscall-0.3)
- ("rust-rustix" ,rust-rustix-0.37)
- ("rust-windows-sys" ,rust-windows-sys-0.45))
+ ("rust-rustix" ,rust-rustix-0.38)
+ ("rust-windows-sys" ,rust-windows-sys-0.48))
#:cargo-development-inputs
(("rust-doc-comment" ,rust-doc-comment-0.3))))
(home-page "https://stebalien.com/projects/tempfile-rs")