summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:34:43 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:14 +0200
commit82cf8883156214920a13ada180927e7cbb1e0047 (patch)
tree4e2187081dc4c95f1e28b101767276ed5f66a28a /gnu/packages
parentc8ab5320e561125cc677cb428f064f844a0079a2 (diff)
gnu: emacs-pass: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-pass)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cb98bc8251..39bc7c8e0f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8856,15 +8856,15 @@ standard Unix password manager\").")
(package
(name "emacs-pass")
(version "1.8")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/NicolasPetton/pass/archive/"
- version ".tar.gz"))
- (sha256
- (base32
- "0aiz90gklk0cb8n4v1s3l0mx6pp2b7f4k2c0fjpihwmga13yklwn"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NicolasPetton/pass.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05h4hacv3yygyjcjj004qbyqjpkl4pyhwgp25gsz8mw5c66l70cx"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-password-store" ,emacs-password-store)