summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 22:37:56 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:17 +0300
commit8dd626ee14f108cd7f57babec568455586dbddaf (patch)
tree12db37cbda6072c11c9782f243eb28453b5b7955 /gnu/packages
parent38713d5a8f30847af32bde8d76f454d0408e77f9 (diff)
gnu: Add go-github-com-masterminds-semver.
* gnu/packages/golang.scm (go-github-com-masterminds-semver): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c48867ed47..fd8bf69322 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4286,4 +4286,32 @@ suffix comparison, rather than the string-based or tree-based approaches.")
various ways. It is a Go implementation of some string manipulation libraries
of Java Apache Commons.")
(license license:asl2.0)))
+
+(define-public go-github-com-masterminds-semver
+ (package
+ (name "go-github-com-masterminds-semver")
+ (version "3.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Masterminds/semver")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g1wizfdy29d02l9dh8gsb029yr4m4swp13swf0pnh9ryh5f1msz"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/Masterminds/semver"))
+ (home-page "https://github.com/Masterminds/semver/")
+ (synopsis "@code{semver} helps to work with semantic versions")
+ (description "The semver package provides the ability to work with
+semantic versions. Specifically it provides the ability to:
+@itemize
+@item Parse semantic versions
+@item Sort semantic versions
+@item Check if a semantic version fits within a set of constraints
+@item Optionally work with a @code{v} prefix
+@end itemize\n")
+ (license license:expat)))
(license license:expat)))