summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:01:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:15 +0200
commit93e0bc967b6a18a572b8e921edd110099314e690 (patch)
tree8c53a6aec807295fb3079dc8af16eb6cf4ddaee7 /gnu/packages
parentd504f6b2c57441f181292b43a2f506510fce80ce (diff)
gnu: Add texlive-uaclasses.
* gnu/packages/tex.scm (texlive-uaclasses): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e5d834d1e4..1bc07f447d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -30426,6 +30426,30 @@ A scaled option is provided to allow arbitrary scaling.")
included Typicons font, designed by Stephen Hutchings.")
(license license:lppl1.3+)))
+(define-public texlive-uaclasses
+ (package
+ (name "texlive-uaclasses")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/uaclasses/"
+ "source/latex/uaclasses/"
+ "tex/latex/uaclasses/")
+ (base32
+ "0n0bz3cq9zgl5ppwq02izjgiw6gpza05ymc6x0gsc8v13wfcgvz0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/uaclasses")
+ (synopsis "University of Arizona thesis and dissertation format")
+ (description
+ "This package provides a LaTeX2e document class named @code{ua-thesis}
+for typesetting theses and dissertations in the official format required by
+the University of Arizona. Moreover, there is a fully compatible alternative
+document class @code{my-thesis} for private nice copies of the dissertation,
+and the respective title pages are available as separate packages to work with
+any document class.")
+ (license license:public-domain)))
+
(define-public texlive-ulqda
(package
(name "texlive-ulqda")