summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 20:58:17 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitacd881a49ca1b90fd53754e485961c6b4fdf20d9 (patch)
tree5f593101d006b4b51c3d259c8a043cff601c612c /gnu/packages
parent5257c341506c4d277b98e580a82857daafe073c7 (diff)
gnu: Add ghc-silently.
* gnu/packages/haskell.scm (ghc-silently): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8dd09ba642..32a8663b90 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -989,6 +989,30 @@ that you can use them without linking against Cabal or depending on it being
installed.")
(license bsd-3)))
+(define-public ghc-silently
+ (package
+ (name "ghc-silently")
+ (version "1.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/silently/silently-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0f9qm3f7y0hpxn6mddhhg51mm1r134qkvd2kr8r6192ka1ijbxnf"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ;; circular dependency with nanospec
+ ;; (inputs
+ ;; `(("ghc-temporary" ,ghc-temporary)))
+ (home-page "https://github.com/hspec/silently")
+ (synopsis "Prevent writing to stdout")
+ (description "This package provides functions to prevent or capture
+writing to stdout and other handles.")
+ (license bsd-3)))
+
(define-public ghc-quickcheck-io
(package
(name "ghc-quickcheck-io")