summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 23:52:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:31 +0200
commitd39ec7c61e84d1af2dd99b16e1c8e7c3953e15bc (patch)
tree53b19b74b980e7e03588148d93ea21cb254889c7 /gnu/packages
parent215f41cc3477d9a5f12b5eca841690d7a9907e0a (diff)
gnu: Add texlive-biblatex2bibitem.
* gnu/packages/tex.scm (texlive-biblatex2bibitem): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9a75749cc5..29e16ff983 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4657,6 +4657,30 @@ Unified Stylesheet for Linguistics Journals.")
based on the @code{numeric} style and requires Biber.")
(license license:gpl3+)))
+(define-public texlive-biblatex2bibitem
+ (package
+ (name "texlive-biblatex2bibitem")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/biblatex2bibitem/"
+ "tex/latex/biblatex2bibitem/")
+ (base32
+ "1cd9b7vhmlx2clqr2gpwqs4hjga9mjqlxj7m74kq555rn5ppkyyn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/biblatex2bibitem")
+ (synopsis "Convert BibLaTeX-generated bibliography to bibitems")
+ (description
+ "Some journals accept the reference list only as @code{\\bibitems}. If
+you use BibTeX, there is no problem: just paste the content of the @file{.bbl}
+file into your document. However, there was no out-of-the-box way to do the
+same for BibLaTeX, and you had to struggle with searching appropriate
+@file{.bst} files, or formatting your reference list by hand, or something
+like that. Using the workaround provided by this package solves the
+problem.")
+ (license license:lppl1.3c)))
+
(define-public texlive-bibleref
(package
(name "texlive-bibleref")