summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-12 11:04:56 +0100
committerMarius Bakke <marius@gnu.org>2022-12-12 11:04:56 +0100
commitd47b3d9e4b156930023803926a6592478c5de67c (patch)
treed72ad8f2dd5a1249103df5e7beca90594b961749 /gnu/packages
parent403d06e7e73a5756fd8374dd2f0a13ddc51230b8 (diff)
gnu: python-chardet: Update to 5.1.0.
* gnu/packages/python-xyz.scm (python-chardet): Update to 5.1.0. [build-system]: Change to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove custom check phase in favor of #:test-flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 40c3f9c99c..d01a4adc45 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14130,26 +14130,24 @@ simulation, statistical modeling, machine learning and much more.")
(define-public python-chardet
(package
(name "python-chardet")
- (version "5.0.0")
+ (version "5.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "chardet" version))
(sha256
(base32
- "1amqmz8731ly6f9rkbk09w4jqgmmgyxykd1bawhgrdbqzlmxys03"))))
+ "1r9ixxnish9j3dq4h0z0cwlkr4f5lgi6d8mhbzw59hbbjlmp2qhd"))))
(native-inputs
(list python-pytest))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- (list #:phases
+ (list #:test-flags
+ ;; Disable test that fails sporadically:
+ ;; https://github.com/chardet/chardet/issues/256
+ #~'("-k" "not test_detect_all_and_detect_one_should_agree")
+ #:phases
#~(modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv" "-k"
- ;; Disable test that fails sporadically:
- ;; https://github.com/chardet/chardet/issues/256
- "not test_detect_all_and_detect_one_should_agree")))
;; This package provides a 'chardetect' executable that only
;; depends on Python, so customize the wrap phase to avoid
;; adding pytest and friends in order to save size.