summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:29:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:58 +0200
commit0850db0a337d4965f057dbcdde2d4b4301819617 (patch)
treeeacf4734f53526ceb1b88f3269c29f52aaa8de6a /gnu
parentc62820c1a4c1ffd6bd8298bf9596ab23e2ec1bdf (diff)
gnu: Add texlive-proposal.
* gnu/packages/tex.scm (texlive-proposal): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 90112dcbd0..d89ea48e11 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25497,6 +25497,41 @@ A cross-referencing system is provided for trees which cite line numbers in
justifications for proof lines or branch closures.")
(license license:lppl1.3+)))
+(define-public texlive-proposal
+ (package
+ (name "texlive-proposal")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/proposal/base/"
+ "doc/latex/proposal/dfg/"
+ "doc/latex/proposal/eu/"
+ "source/latex/proposal/base/"
+ "source/latex/proposal/bin/"
+ "source/latex/proposal/dfg/"
+ "source/latex/proposal/eu/"
+ "source/latex/proposal/lib/"
+ "tex/latex/proposal/base/"
+ "tex/latex/proposal/dfg/"
+ "tex/latex/proposal/eu/")
+ (base32
+ "0km6i418hdcbl457dfwh1hl3q8qshp1gvqc1frqc84f9a6cr0kzc")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/proposal")
+ (synopsis
+ "Set of LaTeX classes preparing proposals for collaborative projects")
+ (description
+ "The process of preparing a collaborative proposal, to a major funding body,
+involves integration of contributions of a many people at many sites. It is
+therefore an ideal application for a text-based document preparation system
+such as LaTeX, in concert with a distributed version control system such as
+SVN. The @code{proposal} class itself provides a basis for such an
+enterprise. The @code{dfgproposal} and @code{dfgproposal} classes provide two
+specialisations of the base class for (respectively) German and European
+research proposals.")
+ (license license:lppl)))
+
(define-public texlive-pseudo
(package
(name "texlive-pseudo")