summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-09 22:54:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:50 -0400
commit0e60bdf0dcc684d4593a074bc0814c6c5ff77ec5 (patch)
tree18f0154ed153d7e5b55b50f54f5a1f61f23855e1 /gnu
parentc67cef48e00d10dc44541e6dbd0132a4b6019c10 (diff)
gnu: tracker: Patch a /bin/bash reference.
* gnu/packages/gnome.scm (tracker)[phases]{patch-paths}: New phase. [native-inputs]: Add glibc-utf8-locales. [inputs]: Add bash-minimal.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 06803c7442..bc43e191f8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9222,6 +9222,11 @@ easy, safe, and automatic.")
"-Dsystemd_user_services=false")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "utils/trackertestutils/__main__.py"
+ (("/bin/bash")
+ (search-input-file inputs "bin/bash")))))
(add-before 'configure 'set-shell
(lambda _
(setenv "SHELL" (which "bash"))))
@@ -9242,6 +9247,7 @@ easy, safe, and automatic.")
(native-inputs
(list gettext-minimal
`(,glib "bin")
+ glibc-utf8-locales
gobject-introspection
docbook-xsl
docbook-xml
@@ -9256,7 +9262,8 @@ easy, safe, and automatic.")
python
vala))
(inputs
- (list dbus
+ (list bash-minimal
+ dbus
libsoup))
(propagated-inputs
;; These are in Requires or Requires.private of tracker-sparql-3.0.pc.