summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-09 17:47:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 22:03:27 +0100
commit14caba7eeb55310794c13ffe0da8a9691354b587 (patch)
tree144d2f1ef2816b66b90d26f17345346134435336 /gnu
parentfeb7c4f6cabc270b34894c54fbdbaffc782e3c60 (diff)
gnu: Add r-hdrcde.
* gnu/packages/cran.scm (r-hdrcde): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ddf34ea439..e3451d9a56 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19355,6 +19355,35 @@ actigraphy-measured activity counts data.")
R.")
(license license:gpl2+)))
+(define-public r-hdrcde
+ (package
+ (name "r-hdrcde")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "hdrcde" version))
+ (sha256
+ (base32
+ "0c2qbw4c3mq1cb068kjs72rxlbibz8svwcrx853jyr8ybs23z7ab"))))
+ (properties `((upstream-name . "hdrcde")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ash" ,r-ash)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-kernsmooth" ,r-kernsmooth)
+ ("r-ks" ,r-ks)
+ ("r-locfit" ,r-locfit)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "http://pkg.robjhyndman.com/hdrcde")
+ (synopsis "Highest density regions and conditional density estimation")
+ (description
+ "This is a package for the computation of highest density regions in one
+and two dimensions, kernel estimation of univariate density functions
+conditional on one covariate, and multimodal regression.")
+ (license license:gpl3)))
+
(define-public r-fda
(package
(name "r-fda")