summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2022-09-29 13:34:21 -0700
committerLudovic Courtès <ludo@gnu.org>2022-10-20 22:43:48 +0200
commit236b41a95899aa701ab71a1784e5c839dc2dce53 (patch)
tree69f1b970936f259a7369d063eb74a0ca41380c97 /gnu
parent685110045c04a60bf18163aab1c230f944c871c9 (diff)
gnu: linux-pam: Update to 1.5.2.
* gnu/packages/linux.scm (linux-pam): Update to 1.5.2. Add explicit libdir for pkgconfig files. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a97b84d657..a81b8c7641 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1566,7 +1566,7 @@ which need to be installed separately.")
(define-public linux-pam
(package
(name "linux-pam")
- (version "1.5.1")
+ (version "1.5.2")
(source
(origin
(method url-fetch)
@@ -1575,7 +1575,7 @@ which need to be installed separately.")
version "/Linux-PAM-" version ".tar.xz"))
(sha256
(base32
- "1z4jayf69qyyxln1gl6ch4qxfd66ib1g42garnrv2d8i1drl0790"))
+ "0kgrsj2scv5mx6w925h9hxf11jnqqs9z8s22aw94b90xm4qp3v74"))
(patches (search-patches "linux-pam-unix_chkpwd.patch"
"linux-pam-no-setfsuid.patch"))))
@@ -1592,6 +1592,12 @@ which need to be installed separately.")
#:configure-flags (list (string-append "--includedir="
(assoc-ref %outputs "out")
"/include/security")
+ ;; explicit libdir for pkgconfig files
+ ;; drop with 1.5.3, which fixes
+ ;; https://github.com/linux-pam/linux-pam/issues/466
+ (string-append "--libdir="
+ (assoc-ref %outputs "out")
+ "/lib")
;; XXX: <rpc/rpc.h> is missing from glibc when
;; cross-compiling, so we have to disable NIS