summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 13:07:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:52 +0200
commit2efb6281eba319a1117dc22136e2b4c07879d3bc (patch)
treece5344f2e6df5d270adae35e22e49a1c6956a459 /gnu
parenta9d6331d460b43af24c3f9b66fb3864e4e752b3b (diff)
gnu: Add texlive-uppunctlm.
* gnu/packages/tex.scm (texlive-uppunctlm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8b35857d21..5e6ff374e9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25553,6 +25553,31 @@ is suitable as an alternative to fonts such as Adrian Frutiger's Univers and
Frutiger.")
(license (list license:gpl2+ license:lppl))))
+(define-public texlive-uppunctlm
+ (package
+ (name "texlive-uppunctlm")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/uppunctlm/"
+ "fonts/tfm/public/uppunctlm/"
+ "fonts/vf/public/uppunctlm/"
+ "tex/latex/uppunctlm/")
+ (base32
+ "0d9x56rlxjavamx361582khj5idhy692hxm5wwwcc5y5i3xsc4pp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/uppunctlm")
+ (synopsis
+ "Always keep upright shape for some punctuation marks and Arabic numerals")
+ (description
+ "The package provides a mechanism to keep punctuation always in upright
+shape even if italic was specified. It is directed to Latin Modern fonts, and
+provides @file{.tfm}, @file{.vf}, @file{.fd}, and @file{.sty} files. Here
+a list of punctuation characters always presented in upright shapes: comma,
+period, semicolon, colon, parentheses, square brackets, and Arabic numerals.")
+ (license license:gfl1.0)))
+
(define-public texlive-urlbst
(package
(name "texlive-urlbst")