summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 13:32:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:45 +0100
commit3088b3fc5b271c23face4cf82b0938f6aa872462 (patch)
tree41f4398d4b9600da597680121bf77a066ab4d026 /gnu
parent804b9b18ac9188ffb6c6891cbb9241c6a80ed7c8 (diff)
gnu: Add r-rspectra.
* gnu/packages/cran.scm (r-rspectra): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 847e3ccacb..3e2e9298d6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8874,3 +8874,30 @@ Furthermore, functions are available for fast singular value decomposition,
for computing the pseudoinverse, and for checking the rank and positive
definiteness of a matrix.")
(license license:gpl3+)))
+
+(define-public r-rspectra
+ (package
+ (name "r-rspectra")
+ (version "0.13-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RSpectra" version))
+ (sha256
+ (base32
+ "1sw80chwyyjzf5px278l6xmp94yhwrlj5xh8d3wlw3dnvdkycca7"))))
+ (properties `((upstream-name . "RSpectra")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcppeigen" ,r-rcppeigen)))
+ (home-page "https://github.com/yixuan/RSpectra")
+ (synopsis "Solvers for large-scale Eigenvalue and SVD problems")
+ (description
+ "This package provides an R interface to the Spectra library for
+large-scale eigenvalue and SVD problems. It is typically used to compute a
+few eigenvalues/vectors of an n by n matrix, e.g., the k largest eigenvalues,
+which is usually more efficient than @code{eigen()} if k << n.")
+ ;; MPL 2 or later.
+ (license license:mpl2.0)))