summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-18 08:14:31 +0100
committerMarius Bakke <marius@gnu.org>2022-11-20 07:47:16 +0100
commit372b037540395b688a0406c89709fdc3af880e4a (patch)
treefa0a5dffb173b2bceb94b1184b04ab76e8d8eae5 /gnu
parentf8e1c9c003999cf20db2d7e5c1aa2c64c787056d (diff)
gnu: VLC: Fix build with dav1d 1.0.
* gnu/packages/video.scm (vlc)[source](patches): New field. * gnu/packages/patches/vlc-dav1d-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/vlc-dav1d-compat.patch70
-rw-r--r--gnu/packages/video.scm1
3 files changed, 72 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b154caaaaa..8f59fb5faf 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1979,6 +1979,7 @@ dist_patch_DATA = \
%D%/packages/patches/vinagre-newer-rdp-parameters.patch \
%D%/packages/patches/virglrenderer-CVE-2017-6386.patch \
%D%/packages/patches/virtuoso-ose-remove-pre-built-jar-files.patch \
+ %D%/packages/patches/vlc-dav1d-compat.patch \
%D%/packages/patches/vsearch-unbundle-cityhash.patch \
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
diff --git a/gnu/packages/patches/vlc-dav1d-compat.patch b/gnu/packages/patches/vlc-dav1d-compat.patch
new file mode 100644
index 0000000000..3cb737faba
--- /dev/null
+++ b/gnu/packages/patches/vlc-dav1d-compat.patch
@@ -0,0 +1,70 @@
+Fix build against dav1d 1.0.
+
+ https://code.videolan.org/videolan/vlc/-/merge_requests/1618
+
+Patch adjusted for VLC 3.0 taken from Gentoo:
+
+ https://gitweb.gentoo.org/repo/gentoo.git/tree/media-video/vlc/files/vlc-3.0.17.3-dav1d-1.0.0.patch
+
+--- a/modules/codec/dav1d.c
++++ b/modules/codec/dav1d.c
+@@ -63,10 +63,16 @@ vlc_module_begin ()
+ set_category(CAT_INPUT)
+ set_subcategory(SUBCAT_INPUT_VCODEC)
+
++#if DAV1D_API_VERSION_MAJOR >= 6
++ add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_THREADS,
++ THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
++ add_obsolete_string("dav1d-thread-tiles") // unused with dav1d 1.0
++#else
+ add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_FRAME_THREADS,
+ THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
+ add_integer_with_range("dav1d-thread-tiles", 0, 0, DAV1D_MAX_TILE_THREADS,
+ THREAD_TILES_TEXT, THREAD_TILES_LONGTEXT, false)
++#endif
+ vlc_module_end ()
+
+ /*****************************************************************************
+@@ -294,6 +300,11 @@ static int OpenDecoder(vlc_object_t *p_this)
+ return VLC_ENOMEM;
+
+ dav1d_default_settings(&p_sys->s);
++#if DAV1D_API_VERSION_MAJOR >= 6
++ p_sys->s.n_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
++ if (p_sys->s.n_threads == 0)
++ p_sys->s.n_threads = (i_core_count < 16) ? i_core_count : 16;
++#else
+ p_sys->s.n_tile_threads = var_InheritInteger(p_this, "dav1d-thread-tiles");
+ if (p_sys->s.n_tile_threads == 0)
+ p_sys->s.n_tile_threads =
+@@ -303,6 +314,7 @@ static int OpenDecoder(vlc_object_t *p_this)
+ p_sys->s.n_frame_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
+ if (p_sys->s.n_frame_threads == 0)
+ p_sys->s.n_frame_threads = (i_core_count < 16) ? i_core_count : 16;
++#endif
+ p_sys->s.allocator.cookie = dec;
+ p_sys->s.allocator.alloc_picture_callback = NewPicture;
+ p_sys->s.allocator.release_picture_callback = FreePicture;
+@@ -313,12 +325,20 @@ static int OpenDecoder(vlc_object_t *p_this)
+ return VLC_EGENERIC;
+ }
+
++#if DAV1D_API_VERSION_MAJOR >= 6
++ msg_Dbg(p_this, "Using dav1d version %s with %d threads",
++ dav1d_version(), p_sys->s.n_threads);
++
++ dec->i_extra_picture_buffers = (p_sys->s.n_threads - 1);
++#else
+ msg_Dbg(p_this, "Using dav1d version %s with %d/%d frame/tile threads",
+ dav1d_version(), p_sys->s.n_frame_threads, p_sys->s.n_tile_threads);
+
++ dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
++#endif
++
+ dec->pf_decode = Decode;
+ dec->pf_flush = FlushDecoder;
+- dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
+
+ dec->fmt_out.video.i_width = dec->fmt_in.video.i_width;
+ dec->fmt_out.video.i_height = dec->fmt_in.video.i_height;
+GitLab
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f54ced4e2e..7f2112de0d 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1943,6 +1943,7 @@ videoformats depend on the configuration flags of ffmpeg.")
"https://download.videolan.org/pub/videolan/vlc/"
(car (string-split version #\-))
"/vlc-" version ".tar.xz"))
+ (patches (search-patches "vlc-dav1d-compat.patch"))
(sha256
(base32
"0cs1vnv91mg7p6253v6wms3zlz91xzphpwaw14dmrd2gibc64nlc"))))