summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:22:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:06 +0200
commit3abaae5708da768cb8ce8fee0bc3d3851da9b886 (patch)
treef5e15bf0d3cfd882b031e6ee64803ccc5db5dc8b /gnu
parentfb2f89b6d3502ee3611fff8ad56c0064fccb9198 (diff)
gnu: emacs-helm-swoop: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-helm-swoop)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 43a5ae1cac..6378099125 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5327,16 +5327,15 @@ not tied in the trap of backward compatibility.")
(package
(name "emacs-helm-swoop")
(version "1.7.4")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/ShingoFukuyama/helm-swoop/archive/"
- version
- ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1ssivsjzlnkg049cg993l8fp09l5nhpz6asj7w5c91zp5kpc6fh7"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ShingoFukuyama/helm-swoop.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b23j1bkpg4pm310hqdhgnl4mxsj05gpl08b6kb2ja4fzrg6adsk"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-helm" ,emacs-helm)))