summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:20:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:54 +0200
commit459251d0a52a0f06a307ec1c0f109942dc2ce17d (patch)
tree49ebf0cc07e1bacc8f77178a3c8010a001697595 /gnu
parent50eca57cf7c61c17be786c865584846914121d09 (diff)
gnu: Add texlive-njuthesis.
* gnu/packages/tex.scm (texlive-njuthesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index adeda943a0..9dd3ba411c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23240,6 +23240,28 @@ format is required for applications submitted for due dates on or after May
Technology.")
(license license:gpl3+)))
+(define-public texlive-njuthesis
+ (package
+ (name "texlive-njuthesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/njuthesis/"
+ "source/latex/njuthesis/"
+ "tex/latex/njuthesis/")
+ (base32
+ "0vzm6iwc025vahbng9nirf1iljrdgqd2w0kz30wczaiy70p1lm5q")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/njuthesis")
+ (synopsis "LaTeX thesis template for Nanjing University")
+ (description
+ "The @code{njuthesis} class is intended for typesetting Nanjing
+University dissertations with LaTeX, providing support for bachelor, master,
+and doctoral theses as well as postdoctoral reports. Compilation of this
+class requires either XeLaTeX or LuaLaTeX.")
+ (license license:lppl1.3c)))
+
(define-public texlive-nucleardata
(package
(name "texlive-nucleardata")