summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-12-28 00:33:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-01 14:35:13 +0100
commit4ea4101d6606dfd098f6bf4dfce5d5a09756fb8f (patch)
treed0e2fa7b06a533e1473881edbd93edee41c38f4b /gnu
parent2b08c05bffbbd71106b76eec32cc016d5f9eee33 (diff)
gnu: r-ggvenndiagram: Update to 1.4.9.
* gnu/packages/cran.scm (r-ggvenndiagram): Update to 1.4.9. [propagated-inputs]: Add r-aplot, r-forcats, and r-tidyr; remove r-magrittr, r-plotly, r-purrr, r-rvenn, r-sf, and r-yulab-utils. Change-Id: I7e1f701e893aff8d75fa9de46d4f451cfa98f820
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 75a8fb49e3..a20be1159b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2390,26 +2390,23 @@ scale-sensitive information.")
(define-public r-ggvenndiagram
(package
(name "r-ggvenndiagram")
- (version "1.2.3")
+ (version "1.4.9")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggVennDiagram" version))
(sha256
(base32
- "083qr0qd3333qmr42v9k0r0sq5842cca83p87h5gikk8v1vljv7j"))))
+ "1nf4prkpciy1q1ix7chy0ymk5d3dlxxb53c29pg6yjp3py0hiw2h"))))
(properties `((upstream-name . "ggVennDiagram")))
(build-system r-build-system)
(propagated-inputs
- (list r-dplyr
+ (list r-aplot
+ r-dplyr
+ r-forcats
r-ggplot2
- r-magrittr
- r-plotly
- r-purrr
- r-rvenn
- r-sf
r-tibble
- r-yulab-utils))
+ r-tidyr))
(native-inputs (list r-knitr))
(home-page "https://github.com/gaospecial/ggVennDiagram")
(synopsis "Implementention of the Venn diagram using ggplot2")