summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:20:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:53 +0200
commit50eca57cf7c61c17be786c865584846914121d09 (patch)
tree7b027a35814ceab5fc0f208e30e59743cc2fb38a /gnu
parentbc40da5e5b90546927877412db877b35e1b01837 (diff)
gnu: Add texlive-njustthesis.
* gnu/packages/tex.scm (texlive-njustthesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6445394ae4..adeda943a0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23219,6 +23219,27 @@ format is required for applications submitted for due dates on or after May
25, 2015.")
(license license:lppl1.3+)))
+(define-public texlive-njustthesis
+ (package
+ (name "texlive-njustthesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/njustthesis/"
+ "source/latex/njustthesis/"
+ "tex/latex/njustthesis/")
+ (base32
+ "11xbxz3vvq15v5nr32ww6llq08v7r0x52zmq13dp90nmh0xyj7y6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/njustthesis")
+ (synopsis
+ "Thesis template for the Nanjing University of Science and Technology")
+ (description
+ "This is a thesis template for the Nanjing University of Science and
+Technology.")
+ (license license:gpl3+)))
+
(define-public texlive-nucleardata
(package
(name "texlive-nucleardata")