summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 10:16:21 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 11:02:59 +0100
commit5e9018b3890edd7621b72e32333e164412b0198a (patch)
treec9f7ffe86a6bdc76ff4aa7487390c20e39b93fc6 /gnu
parentc2777bb64fabde4aef0adfcdd4db0d56faf081e4 (diff)
gnu: texlive-generic-atbegshi: Rename to texlive-atbegshi.
* gnu/packages/tex.scm (texlive-atbegshi): New variable. (texlive-generic-atbegshi): Define deprecated alias. (texlive-hyperref): Use new variable name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm54
1 files changed, 39 insertions, 15 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c33f6f607f..0da2e8550b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3456,7 +3456,7 @@ XML, using UTF-8 or a suitable 8-bit encoding.")
(lambda _ (chdir "source/latex/hyperref") #t))))))
(propagated-inputs
(list texlive-atveryend
- texlive-generic-atbegshi
+ texlive-atbegshi
texlive-generic-bitset
texlive-generic-etexcmds
texlive-generic-gettitlestring
@@ -8040,23 +8040,47 @@ refers to the version of scrbook, scrreprt, scrartcl, scrlttr2 and
typearea (which are the main parts of the bundle).")
(license license:lppl1.3+)))
-(define-public texlive-generic-atbegshi
- (package
- (inherit (simple-texlive-package
- "texlive-generic-atbegshi"
- '("/doc/latex/atbegshi/"
- "/tex/generic/atbegshi/")
- (base32
- "184fr5kd3wl44ix63lwb3ll7dhiikkyw1czbnzrl4am4rx0zh4d8")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/atbegshi")
- (synopsis "Execute commands at @code{\\shipout} time")
- (description
- "This package is a modern reimplementation of package @code{everyshi},
+(define-public texlive-atbegshi
+ (let ((template (simple-texlive-package
+ "texlive-atbegshi"
+ (list "doc/latex/atbegshi/"
+ "source/latex/atbegshi/"
+ "tex/generic/atbegshi/")
+ (base32
+ "0vd90wdjwj5w4g4xka4nms3rgixjw63iwf0hj0v1akcfflwvgn69"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "generic/atbegshi")
+ ((#:build-targets _ '())
+ #~(list "atbegshi.dtx"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/latex/atbegshi")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (home-page "https://www.ctan.org/pkg/atbegshi")
+ (synopsis "Execute commands at @code{\\shipout} time")
+ (description
+ "This package is a modern reimplementation of package @code{everyshi},
providing various commands to be executed before a @code{\\shipout} command.
It makes use of e-TeX’s facilities if they are available. The package may
be used either with LaTeX or with plain TeX.")
- (license license:lppl1.3c+)))
+ (license license:lppl1.3c+))))
+
+(define-deprecated-package texlive-generic-atbegshi texlive-atbegshi)
(define-public texlive-generic-bigintcalc
(package