summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:09:00 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit78c5b39d0877eca8fa0c18e239f1bcf966b7a01a (patch)
tree5f2a6d8ca80b6f9cf6d50f4c95fe009058ee82c3 /gnu
parent76ae28f16beac4df3aea7557d0487ea00fd7f30d (diff)
gnu: Add ghc-safe.
* gnu/packages/haskell.scm (ghc-safe): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0f075be00a..c6dea86d64 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -984,6 +984,28 @@ regex-posix, regex-pcre, regex-parsec, regex-tdfa, regex-dfa.")
style.")
(license bsd-3)))
+(define-public ghc-safe
+ (package
+ (name "ghc-safe")
+ (version "0.3.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/safe/safe-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1jdnp5zhvalf1xy8i872n29nljfjz6lnl9ghj80ffisrnnkrwcfh"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/ndmitchell/safe#readme")
+ (synopsis "Library of safe (exception free) functions")
+ (description "This library provides wrappers around @code{Prelude} and
+@code{Data.List} functions, such as @code{head} and @code{!!}, that can throw
+exceptions.")
+ (license bsd-3)))
+
(define-public ghc-exceptions
(package
(name "ghc-exceptions")