summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-09 17:46:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 22:03:27 +0100
commit9c3f5b2fa0e57d21c68bda70b5f7b57cd2982ced (patch)
treee867d7e3a827a399b00ebf2238d522113be9e7fe /gnu
parent71a732c35d18cf627c50209c9615ed886f59de66 (diff)
gnu: Add r-gitcreds.
* gnu/packages/cran.scm (r-gitcreds): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 526eba0e5d..13e3de2b84 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -96,6 +96,7 @@
#:use-module (gnu packages statistics)
#:use-module (gnu packages tcl)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
@@ -9707,6 +9708,30 @@ files to an structured list. Users can manipulate this resulting list with
back to file after modifications.")
(license license:gpl3)))
+(define-public r-gitcreds
+ (package
+ (name "r-gitcreds")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gitcreds" version))
+ (sha256
+ (base32
+ "1snzn7nxy0rwz0bzjsg6k04c0n811dgn8gn9cmn2v78aj57ayjmi"))))
+ (properties `((upstream-name . "gitcreds")))
+ (build-system r-build-system)
+ (inputs `(("git" ,git-minimal)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/r-lib/gitcreds")
+ (synopsis "Query git credentials from R")
+ (description
+ "Query, set, and delete credentials from the git credential store.
+Manage GitHub tokens and other git credentials. This package is to be used by
+other packages that need to authenticate to GitHub and/or other git
+repositories.")
+ (license license:expat)))
+
(define-public r-gh
(package
(name "r-gh")