summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:23:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:56 +0200
commita9c4be8adfe9e19f28aebf97a4d215d389617238 (patch)
treeccb200ea766984bfabcd2e6937d4bcfbfd971f2b /gnu
parent2f0c63426c21992650ccbe2fd1819c03559bb46f (diff)
gnu: Add texlive-oup-authoring-template.
* gnu/packages/tex.scm (texlive-oup-authoring-template): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c47e48f8bf..edd5d38a42 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -24142,6 +24142,29 @@ also supported.")
;; condition for use are retained".
(license (license:fsf-free "file://tex/latex/oubraces/oubraces.sty"))))
+(define-public texlive-oup-authoring-template
+ (package
+ (name "texlive-oup-authoring-template")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/oup-authoring-template/"
+ "tex/latex/oup-authoring-template/")
+ (base32
+ "1fbkrka650pv2k5n0fcdcgmzlfpj2kzlg9d72d145b24zza79qh0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/oup-authoring-template")
+ (synopsis
+ "General template for journals published by Oxford University
+Press (OUP)")
+ (description
+ "This package provides a general LaTeX template for journals published by
+@acronym{OUP, Oxford University Press}. The template outputs to the three
+official page designs (traditional, contemporary, modern) used by many
+journals published by OUP, with large, medium and small page options.")
+ (license license:lppl1.2+)))
+
(define-public texlive-overarrows
(package
(name "texlive-overarrows")