summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 14:42:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:49 +0100
commitcb03d6c6f39145c85350bd93d46941a2c178f4d3 (patch)
treeeb16427289a6c99947d891a5cd6dc751b25602cc /gnu
parent6e09f506130cc63b58bf7890d1a71b6f75c7610e (diff)
gnu: Add r-ore.
* gnu/packages/cran.scm (r-ore): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index da05dd4615..5fc0ee1a47 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9092,3 +9092,24 @@ used by other packages.")
"This package provides functions for easily manipulating colors,
creating color scales and calculating color distances.")
(license license:bsd-3)))
+
+(define-public r-ore
+ (package
+ (name "r-ore")
+ (version "1.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ore" version))
+ (sha256
+ (base32
+ "1l1ziljgm5gwjhvjq42wi5vcwbxlaj5dl9w8bhz0wh8vx4ajj07m"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/jonclayden/ore")
+ (synopsis "R interface to the Onigmo regular expression library")
+ (description
+ "This package provides an alternative to R's built-in functionality for
+handling regular expressions, based on the Onigmo library. It offers
+first-class compiled regex objects, partial matching and function-based
+substitutions, amongst other features.")
+ (license license:bsd-3)))