summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0e03a52185..2a2b1614f9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -696,6 +696,10 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
("CONFIG_PROC_PID_CPUSET" . #t)
;; Allow disk encryption by default
("CONFIG_DM_CRYPT" . m)
+ ;; Support zram on all kernel configs
+ ("CONFIG_ZSWAP" . #t)
+ ("CONFIG_ZSMALLOC" . #t)
+ ("CONFIG_ZRAM" . m)
;; Modules required for initrd:
("CONFIG_NET_9P" . m)
("CONFIG_NET_9P_VIRTIO" . m)