summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm40
1 files changed, 32 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f549ff6dd4..54f1f50894 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31728,8 +31728,39 @@ the revision graph.")
trust model.")
(license (list license:expat license:asl2.0))))
+(define-public rust-gix-tempfile-10
+ (package
+ (name "rust-gix-tempfile")
+ (version "10.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gix-tempfile" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0kdc21s0dnqnbzfdazpsw8fclnw1gi3w4np71qlmgp0i7s7rgq2s"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-dashmap" ,rust-dashmap-5)
+ ("rust-document-features" ,rust-document-features-0.2)
+ ("rust-gix-fs" ,rust-gix-fs-0.7)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-parking-lot" ,rust-parking-lot-0.12)
+ ("rust-signal-hook" ,rust-signal-hook-0.3)
+ ("rust-signal-hook-registry" ,rust-signal-hook-registry-1)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (home-page "https://github.com/Byron/gitoxide")
+ (synopsis
+ "Rust tempfile implementation with assured clean-up")
+ (description
+ "Part of Gitoxide a Rust implementation of Git. This package provides a
+tempfile capability with a global registry to assure clean-up.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-gix-tempfile-6
(package
+ (inherit rust-gix-tempfile-10)
(name "rust-gix-tempfile")
(version "6.0.0")
(source
@@ -31739,7 +31770,6 @@ trust model.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "047baclw78xkzjg04z5290x7vhcz270jpw7vdm25rp7922q5qy5k"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-dashmap" ,rust-dashmap-5)
@@ -31750,13 +31780,7 @@ trust model.")
("rust-parking-lot" ,rust-parking-lot-0.12)
("rust-signal-hook" ,rust-signal-hook-0.3)
("rust-signal-hook-registry" ,rust-signal-hook-registry-1)
- ("rust-tempfile" ,rust-tempfile-3))))
- (home-page "https://github.com/Byron/gitoxide")
- (synopsis "Tempfile implementation with a global registry to assure cleanup")
- (description
- "This package provides a tempfile implementation with a global registry to
-assure cleanup.")
- (license (list license:expat license:asl2.0))))
+ ("rust-tempfile" ,rust-tempfile-3))))))
(define-public rust-gix-trace-0.1
(package