summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-plasma.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 853a3cce07..20ebd9f3a9 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1194,3 +1194,38 @@ PulseAudio.")
(description "Provides Plasma applet and services for creating encrypted
vaults.")
(license (list license:gpl2 license:gpl3))))
+
+(define-public plasma-systemmonitor
+ (package
+ (name "plasma-systemmonitor")
+ (version "5.25.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0rs3avhpmfapzha8dkir9ny60ba2m92bbfv4avsd85vz5kggg29h"))))
+ (build-system qt-build-system)
+ (native-inputs (list extra-cmake-modules))
+ (inputs (list ki18n
+ kconfig
+ kdeclarative
+ kservice
+ kiconthemes
+ kglobalaccel
+ kio
+ kdbusaddons
+ kirigami
+ knewstuff
+ ksystemstats
+ kitemmodels
+ libksysguard
+ qtdeclarative-5
+ qtquickcontrols2-5))
+ (synopsis "System sensors, process information and other system resources
+monitor")
+ (description "This package provides an interface for monitoring system
+sensors, process information and other system resources.")
+ (home-page "https://invent.kde.org/plasma/plasma-systemmonitor")
+ (license (list license:gpl2 license:gpl3))))