summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/fonts.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a381f061af..5ffebb35eb 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
+;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2709,3 +2710,22 @@ This package contains the following outputs:
icon is designed on a 24x24 grid with an emphasis on simplicity, consistency,
and readability. This package bundles those icons into a font.")
(license license:expat))))
+
+(define-public font-lxgw-wenkai
+ (package
+ (name "font-lxgw-wenkai")
+ (version "1.235.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lxgw/LxgwWenKai/releases/download/v"
+ version "/lxgw-wenkai-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "17li3xry4j4ccdnwz2pcnf0gv7c5mwq0h5fwvl7ar28brn2qgdbk"))))
+ (build-system font-build-system)
+ (home-page "https://lxgw.github.io/2021/01/28/Klee-Simpchin/")
+ (synopsis "LXGW Wenkai / 霞鹜文楷")
+ (description
+ "An open-source Chinese font derived from Fontworks' Klee One.")
+ (license license:silofl1.1)))