summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm115
1 files changed, 79 insertions, 36 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 24833a04d5..1ea6f975ff 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1494,7 +1494,7 @@ commands and their arguments.")
(define-public opendoas
(package
(name "opendoas")
- (version "6.6.1")
+ (version "6.8")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1503,7 +1503,7 @@ commands and their arguments.")
(file-name (git-file-name name version))
(sha256
(base32
- "07kkc5729p654jrgfsc8zyhiwicgmq38yacmwfvay2b3gmy728zn"))))
+ "1dlwnvy8r6slxcy260gfkximp1ms510wdslpfq9y6xvd2qi5izcb"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1511,19 +1511,17 @@ commands and their arguments.")
(replace 'configure
;; The configure script doesn't accept most of the default flags.
(lambda* (#:key configure-flags #:allow-other-keys)
- ;; The configure script can only be told which compiler to use
+ ;; The configure script can be told which compiler to use only
;; through environment variables.
(setenv "CC" ,(cc-for-target))
(apply invoke "./configure" configure-flags)))
(add-before 'install 'fix-makefile
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "bsd.prog.mk"
+ (substitute* "GNUmakefile"
(("^\tchown.*$") ""))
#t)))
#:configure-flags
(list (string-append "--prefix=" (assoc-ref %outputs "out"))
- ;; Nothing is done with this value (yet?) but it's supported.
- ;; (string-append "--target=" (or ,(%current-target-system) ""))
"--with-timestamp")
;; Compiler choice is not carried over from the configure script.
#:make-flags
@@ -1561,10 +1559,10 @@ features of sudo with a fraction of the codebase.")
#t))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda _
(chdir "wpa_supplicant")
(copy-file "defconfig" ".config")
(let ((port (open-file ".config" "al")))
@@ -1578,6 +1576,15 @@ features of sudo with a fraction of the codebase.")
CONFIG_LIBNL32=y
CONFIG_READLINE=y\n" port)
(close-port port))
+ ;; Make sure we have a pkg-config when cross compiling
+ (substitute* '(".config"
+ "Android.mk"
+ "Makefile"
+ "dbus/Makefile")
+ (("pkg-config")
+ (or (which "pkg-config")
+ (which (string-append ,(%current-target-system)
+ "-pkg-config")))))
#t))
(add-after 'install 'install-documentation
(lambda* (#:key outputs #:allow-other-keys)
@@ -1606,7 +1613,7 @@ features of sudo with a fraction of the codebase.")
"wpa_supplicant.conf"))
#t))))
- #:make-flags (list "CC=gcc"
+ #:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "BINDIR=" (assoc-ref %outputs "out")
"/sbin")
(string-append "LIBDIR=" (assoc-ref %outputs "out")
@@ -1716,10 +1723,10 @@ command.")
"1mrbvg4v7vm7mknf0n29mf88k3s4a4qj6r4d51wq8hmjj1m7s7c8"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda _
;; This is mostly copied from 'wpa-supplicant' above.
(chdir "hostapd")
(copy-file "defconfig" ".config")
@@ -1731,6 +1738,14 @@ command.")
CONFIG_IEEE80211AC=y\n" port)
(close-port port))
#t))
+ (add-after 'unpack 'patch-pkg-config
+ (lambda _
+ (substitute* "src/drivers/drivers.mak"
+ (("pkg-config")
+ (or (which "pkg-config")
+ (string-append ,(%current-target-system)
+ "-pkg-config"))))
+ #t))
(add-after 'install 'install-man-pages
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1747,7 +1762,7 @@ command.")
(find-files "." "\\.8"))
#t))))
- #:make-flags (list "CC=gcc"
+ #:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "BINDIR=" (assoc-ref %outputs "out")
"/sbin")
(string-append "LIBDIR=" (assoc-ref %outputs "out")
@@ -1842,7 +1857,7 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
(define-public acpica
(package
(name "acpica")
- (version "20200717")
+ (version "20201113")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1850,13 +1865,13 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
version ".tar.gz"))
(sha256
(base32
- "0jyy71szjr40c8v40qqw6yh3gfk8d6sl3nay69zrn5d88i3r0jca"))))
+ "0fmck3zklc328c8nzvfzm2xyh2i8zszzrd4k8kk8q30y4avnc6z1"))))
(build-system gnu-build-system)
(native-inputs `(("flex" ,flex)
("bison" ,bison)))
(arguments
- '(#:make-flags (list (string-append "PREFIX=" %output)
- "CC=gcc"
+ `(#:make-flags (list (string-append "PREFIX=" %output)
+ (string-append "CC=" ,(cc-for-target))
"HOST=_LINUX"
"OPT_CFLAGS=-Wall -fno-strict-aliasing")
#:tests? #f ; no 'check' target
@@ -2376,17 +2391,20 @@ lookup to YAML Mode. You could enable the mode with @code{(add-hook
`(#:phases (modify-phases %standard-phases
(delete 'configure)
(replace 'build
- (lambda _
- (invoke "make" "CC=gcc" "-Csrc")))
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "-Csrc" make-flags)))
(replace 'check
- (lambda _
- (invoke "make" "CC=gcc" "-Ctests")))
+ (lambda* (#:key tests? make-flags #:allow-other-keys)
+ (when tests?
+ (apply invoke "make" "-Ctests" make-flags))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
(install-file "src/cpulimit" bin))
- #t)))))
+ #t)))
+ #:make-flags (list (string-append "CC=" ,(cc-for-target)))))
(home-page "https://github.com/opsengine/cpulimit")
(synopsis "Limit CPU usage")
(description
@@ -3357,14 +3375,14 @@ information tool.")
(define-public nnn
(package
(name "nnn")
- (version "3.4")
+ (version "3.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/jarun/nnn/releases/download/v"
version "/nnn-v" version ".tar.gz"))
(sha256
- (base32 "189h950m1jjrnhvgcvzk6nj89l58rkxim7bxa0441ssajxpaw0vq"))))
+ (base32 "1ww18vvfjkvi36rcamw8kpix4bhk71w5bw9kmnh158crah1x8dp6"))))
(build-system gnu-build-system)
(inputs
`(("ncurses" ,ncurses)
@@ -3372,15 +3390,23 @@ information tool.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- '(#:tests? #f ; no tests
+ `(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
- (delete 'configure)) ; no configure script
+ (delete 'configure) ; no configure script
+ (add-after 'unpack 'patch-pkg-config
+ (lambda _
+ (substitute* "Makefile"
+ (("pkg-config")
+ (or (which "pkg-config")
+ (string-append ,(%current-target-system)
+ "-pkg-config"))))
+ #t)))
#:make-flags
(list
(string-append "PREFIX="
(assoc-ref %outputs "out"))
- "CC=gcc")))
+ (string-append "CC=" ,(cc-for-target)))))
(home-page "https://github.com/jarun/nnn")
(synopsis "Terminal file browser")
(description "@command{nnn} is a fork of @command{noice}, a blazing-fast
@@ -3393,7 +3419,7 @@ make it a perfect utility on modern distros.")
(define-public thermald
(package
(name "thermald")
- (version "2.2")
+ (version "2.3")
(source
(origin
(method git-fetch)
@@ -3402,30 +3428,47 @@ make it a perfect utility on modern distros.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1nrhv3bypyc48h9smj5cpq63rawm6vqyg3cwkhpz69rgjnf1283m"))))
+ (base32 "0cisaca2c2z1x9xvxc4lr6nl6yqx5bww6brh73m0p1n643jgq1dl"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
(let ((out (assoc-ref %outputs "out")))
(list (string-append "--with-dbus-sys-dir="
out "/etc/dbus-1/system.d")
- "--localstatedir=/var"))))
+ "--localstatedir=/var"))
+ #:make-flags
+ (list "V=1") ; log build commands
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'bootstrap 'no-early-./configure
+ (lambda _
+ (setenv "NO_CONFIGURE" "yet")
+ ;; XXX thd_trip_point.h redefines "__STDC_LIMIT_MACROS" after
+ ;; <xz>/include/lzma.h. ./configure forcibly appends -Werror
+ ;; to CXXFLAGS, overriding any -Wno-error we'd add.
+ (substitute* "configure.ac"
+ (("-Werror") ""))
+ #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("autoconf-archive" ,autoconf-archive)
("automake" ,automake)
("glib" ,glib "bin") ; for glib-genmarshal, etc.
+ ("gtk-doc" ,gtk-doc)
("pkg-config" ,pkg-config)))
(inputs
`(("dbus-glib" ,dbus-glib)
- ("libxml2" ,libxml2)))
+ ("libevdev" ,libevdev)
+ ("libxml2" ,libxml2)
+ ("upower" ,upower)
+ ("xz" ,xz)))
(home-page "https://01.org/linux-thermal-daemon/")
(synopsis "CPU scaling for thermal management")
(description "The Linux Thermal Daemon helps monitor and control temperature
on systems running the Linux kernel.")
;; arm and aarch64 don't have cpuid.h.
(supported-systems '("i686-linux" "x86_64-linux"))
- (license license:gpl2+)))
+ (license license:gpl2)))
(define-public masscan
(package
@@ -3444,9 +3487,9 @@ on systems running the Linux kernel.")
(inputs
`(("libpcap" ,libpcap)))
(arguments
- '(#:test-target "regress"
+ `(#:test-target "regress"
#:make-flags
- (list "CC=gcc"
+ (list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
@@ -3574,7 +3617,7 @@ Python loading in HPC environments.")
(let ((real-name "inxi"))
(package
(name "inxi-minimal")
- (version "3.1.08-1")
+ (version "3.1.09-1")
(source
(origin
(method git-fetch)
@@ -3583,7 +3626,7 @@ Python loading in HPC environments.")
(commit version)))
(file-name (git-file-name real-name version))
(sha256
- (base32 "15b0fn8kv09k7kzyzix1pr1wmjw5yinzgw01v8pf9p547m4a899a"))))
+ (base32 "0m6s8kxjppy3jm39is5i1lbrah29cw86rq0vamvx46izbdyf84y5"))))
(build-system trivial-build-system)
(inputs
`(("bash" ,bash-minimal)
@@ -4088,7 +4131,7 @@ entries, providing commands to add, remove, comment, and search.")
(method git-fetch)
(uri
(git-reference
- (url "https://github.com/jclehner/nmrpflash.git")
+ (url "https://github.com/jclehner/nmrpflash")
(commit (string-append "v" version))))
(sha256
(base32 "1fdjrxhjs96rdclbkld57xarf592slhkp79h46z833npxpn12ck1"))