summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm47
1 files changed, 24 insertions, 23 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 668d710739..9714e8b8b0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -319,12 +319,9 @@ interface and is based on GNU Guile.")
(license license:gpl3+)
(home-page "https://www.gnu.org/software/shepherd/")))
-;; Update on the next rebuild cycle.
-(define-public shepherd shepherd-0.8)
-
(define-public shepherd-0.9
(package
- (inherit shepherd)
+ (inherit shepherd-0.8)
(version "0.9.2")
(source (origin
(method url-fetch)
@@ -367,6 +364,8 @@ interface and is based on GNU Guile.")
guile-fibers-1.1)) ;for cross-compilation
(inputs (list guile-3.0 guile-fibers-1.1))))
+(define-public shepherd shepherd-0.9)
+
(define-public guile2.2-shepherd
(package
(inherit shepherd-0.9)
@@ -826,14 +825,14 @@ re-executing them as necessary.")
(define-public inetutils
(package
(name "inetutils")
- (version "2.0")
+ (version "2.3")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/inetutils/inetutils-"
- version ".tar.gz"))
- (sha256
- (base32
- "0j1nb69bhg29cm4xkqqjh2ln1zqcj2lnpm92v638lpwrs11dypxl"))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/inetutils/inetutils-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1dj4ilxy1wrfxhxc85iya3x28h1mhjpqc5nv862xcq3ww2gqkv8w"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--localstatedir=/var"
@@ -857,19 +856,21 @@ re-executing them as necessary.")
;; Make sure that canonical "coreutils" package is not referred.
#:make-flags
(list (string-append "CPPFLAGS=-DPATHDEF_CP=\\\""
- (assoc-ref %build-inputs "coreutils*")
- "/bin/cp\\\""))
+ (search-input-file %build-inputs "bin/cp")
+ "\\\""))
;; On some systems, 'libls.sh' may fail with an error such as:
;; "Failed to tell switch -a apart from -A".
#:parallel-tests? #f))
- (inputs `(("coreutils*" ,coreutils)
- ("shadow" ,shadow) ;for login (used in telnetd and rlogind)
- ("ncurses" ,ncurses)
- ("readline" ,readline))) ;for 'ftp'
- (native-inputs (if (member (%current-system)
- (package-supported-systems net-tools))
- `(("netstat" ,net-tools)) ;for tests
- '()))
+ (inputs
+ (list coreutils
+ shadow ;for login (used in telnetd and rlogind)
+ ncurses
+ readline)) ;for 'ftp'
+ (native-inputs
+ (if (member (%current-system)
+ (package-supported-systems net-tools))
+ (list net-tools) ;for tests
+ '()))
(home-page "https://www.gnu.org/software/inetutils/")
(synopsis "Basic networking utilities")
(description
@@ -1464,7 +1465,7 @@ connection alive.")
(list config perl file))
(inputs `(("inetutils" ,inetutils)
- ("bash" ,(canonical-package bash-minimal)) ;for wrap-program
+ ("bash" ,bash-minimal)
,@(if (hurd-target?) '()
`(("net-tools" ,net-tools)
("iproute" ,iproute)))
@@ -2832,7 +2833,7 @@ provides the following commands:
;; variable in the tests/cpan.scm test.
(list (search-path-specification
(variable "GUIX_PYTHONPATH")
- (files (list "lib/python3.9/site-packages")))))
+ (files (list "lib/python3.10/site-packages")))))
(home-page "https://www.ansible.com/")
(synopsis "Radically simple IT automation")
(description "Ansible aims to be a radically simple IT automation system.