summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..1d1aae322c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6010,6 +6010,33 @@ reduction (between group analysis) and joint dimension reduction of two
datasets (coinertia analysis).")
(license license:artistic2.0)))
+(define-public r-makecdfenv
+ (package
+ (name "r-makecdfenv")
+ (version "1.74.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "makecdfenv" version))
+ (sha256
+ (base32
+ "0bvj5dg6yfjnhga1z8788zmb98d8shyz8pzz0ggnml87c1p2gy25"))))
+ (properties `((upstream-name . "makecdfenv")))
+ (build-system r-build-system)
+ (inputs (list zlib))
+ (propagated-inputs
+ (list r-affy
+ r-affyio
+ r-biobase
+ r-zlibbioc))
+ (home-page "https://bioconductor.org/packages/makecdfenv")
+ (synopsis "Chip description file environment maker")
+ (description
+ "This package implements two functions. One of them reads an Affymetrix
+@acronym{CDF, chip description file} and creates a hash table environment
+containing the location/probe set membership mapping. The other one creates a
+package that automatically loads that environment.")
+ (license license:gpl2+)))
+
(define-public r-metaneighbor
(package
(name "r-metaneighbor")