summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4cf6900498..8a49e1e350 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8290,6 +8290,9 @@ secondary structure and comparative analysis in R.")
"13fv78sk5g0gqfl3ks3rps3zc1k66a4lzxvgn36r7ix43yxk7hnr"))))
(properties `((upstream-name . "Rhtslib")))
(build-system r-build-system)
+ ;; Without this a temporary directory ends up in the Rhtslib.so binary,
+ ;; which makes R abort the build.
+ (arguments '(#:configure-flags '("--no-staged-install")))
(propagated-inputs
`(("r-zlibbioc" ,r-zlibbioc)))
(inputs
@@ -9953,6 +9956,16 @@ effort and encourages consistency.")
(base32
"0wq49qqzkcn8s19xgaxf2s1j1a563d7pbhhvris6fhxfdjsz4934"))))
(build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/tengfei/ggbio/issues/117
+ ;; This fix will be included in the next release.
+ (add-after 'unpack 'fix-typo
+ (lambda _
+ (substitute* "R/GGbio-class.R"
+ (("fechable") "fetchable"))
+ #t)))))
(propagated-inputs
`(("r-annotationdbi" ,r-annotationdbi)
("r-annotationfilter" ,r-annotationfilter)
@@ -14739,3 +14752,38 @@ tools for identifying genome bins that are likely candidates for merging based
on marker set compatibility, similarity in genomic characteristics, and
proximity within a reference genome.")
(license license:gpl3+)))
+
+(define-public umi-tools
+ (package
+ (name "umi-tools")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "umi_tools" version))
+ (sha256
+ (base32
+ "08y3vz1vcx09whmbsn722lcs6jl9wyrh9i4p3k8j4cb1i32bij4a"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-pandas" ,python-pandas)
+ ("python-future" ,python-future)
+ ("python-scipy" ,python-scipy)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-regex" ,python-regex)
+ ("python-pysam" ,python-pysam)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-cython" ,python-cython)))
+ (home-page "https://github.com/CGATOxford/UMI-tools")
+ (synopsis "Tools for analyzing unique modular identifiers")
+ (description "This package provides tools for dealing with @dfn{Unique
+Molecular Identifiers} (UMIs) and @dfn{Random Molecular Tags} (RMTs) in
+genetic sequences. There are six tools: the @code{extract} and
+@code{whitelist} commands are used to prepare a fastq containg UMIs @code{+/-}
+cell barcodes for alignment. The remaining commands, @code{group},
+@code{dedup}, and @{count}/@code{count_tab}, are used to identify PCR
+duplicates using the UMIs and perform different levels of analysis depending
+on the needs of the user.")
+ (license license:expat)))