summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 8a83c88a04..6653326c18 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1331,9 +1331,8 @@ same arguments.")
(when tests?
(invoke "pytest" "-vv"
"-n" (number->string (parallel-job-count)))))))))
- (native-inputs (list python-setuptools-scm))
- (propagated-inputs (list python-execnet python-pytest python-py
- python-pytest-forked))
+ (native-inputs (list python-setuptools-scm python-filelock python-pytest))
+ (propagated-inputs (list python-execnet python-pytest-forked))
(home-page "https://github.com/pytest-dev/pytest-xdist")
(synopsis
"Plugin for py.test with distributed testing and loop-on-failing modes")