summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm39
1 files changed, 9 insertions, 30 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 382fe348a0..88c6979464 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Ahmad Jarara <git@ajarara.io>
+;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -233,43 +234,28 @@ adding and extracting files to/from a tar archive.")
(define-public gzip
(package
(name "gzip")
- (version "1.10")
+ (version "1.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gzip/gzip-"
version ".tar.xz"))
(sha256
(base32
- "1h6p374d3j8d4cdfydzls021xa2yby8myc0h8d6m8bc7k6ncq9c4"))))
+ "0mhrx5wk9gazmxdw7vmbpg036yzqqhsww6h12kwf2dzn37jh6pnf"))))
(build-system gnu-build-system)
(synopsis "General file (de)compression (using lzw)")
(arguments
;; FIXME: The test suite wants `less', and optionally Perl.
'(#:tests? #f
+ #:configure-flags '("ac_cv_prog_LESS=\"less\"")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-for-glibc-2.28
- (lambda _
- ;; Adjust the bundled gnulib to work with glibc 2.28. See e.g.
- ;; "m4-gnulib-libio.patch". This is a phase rather than patch
- ;; or snippet to work around <https://bugs.gnu.org/32347>.
- (substitute* (find-files "lib" "\\.c$")
- (("#if defined _IO_ftrylockfile")
- "#if defined _IO_EOF_SEEN"))
- (substitute* "lib/stdio-impl.h"
- (("^/\\* BSD stdio derived implementations")
- (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
- "# define _IO_IN_BACKUP 0x100\n"
- "#endif\n\n"
- "/* BSD stdio derived implementations")))
- #t))
(add-after 'unpack 'use-absolute-name-of-gzip
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "gunzip.in"
- (("exec gzip")
+ (("exec 'gzip'")
(string-append "exec " (assoc-ref outputs "out")
- "/bin/gzip")))
- #t)))))
+ "/bin/gzip"))))))))
(description
"GNU Gzip provides data compression and decompression utilities; the
typical extension is \".gz\". Unlike the \"zip\" format, it compresses a single
@@ -1579,28 +1565,21 @@ or junctions, and always follows hard links.")
(define-public zstd
(package
(name "zstd")
- (version "1.5.0")
+ (version "1.5.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/facebook/zstd/releases/download/"
"v" version "/zstd-" version ".tar.gz"))
(sha256
- (base32 "150y541303vnvfhd8wkbih00lfvvm98rd12yijwlbkqzg3xgp52i"))))
+ (base32 "1l1zm1imcc2ixayykyh4y421shdj3pzp7g2xm2k2js8jmipxahkw"))))
(build-system gnu-build-system)
- (outputs '("out" ;1.2MiB executables and documentation
+ (outputs '("out" ;1.5MiB executables and documentation
"lib" ;1.2MiB shared library and headers
"static")) ;1.2MiB static library
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'remove-bogus-check
- (lambda _
- ;; lib/Makefile falsely claims that no .pc file can be created.
- (substitute* "lib/Makefile"
- (("error configured .*dir ")
- "true "))
- #t))
(add-after 'unpack 'patch-command-file-names
;; Don't require hard requirements to be in $PATH.
(lambda* (#:key outputs #:allow-other-keys)