summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm170
1 files changed, 170 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7fa47aee1c..0a502a6063 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -72,6 +72,7 @@
#:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages networking)
+ #:use-module (gnu packages node)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -103,6 +104,76 @@ The package provides functions for point generation, arc length estimation,
degree elevation and curve fitting.")
(license license:gpl2+)))
+(define-public r-v8
+ (package
+ (name "r-v8")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "V8" version))
+ (sha256
+ (base32
+ "0xdljralgwyivdhx2a7kqf3yv4ijl4rdrz2p7p59lj2x5d2qyanf"))))
+ (properties `((upstream-name . "V8")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'find-v8
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "configure"
+ (("^PKG_LIBS=.*")
+ (string-append "PKG_LIBS="
+ (assoc-ref inputs "node")
+ "/lib/libnode.so.64\n")))
+ (setenv "INCLUDE_DIR"
+ (string-append
+ (assoc-ref inputs "node")
+ "/include/node"))
+ (setenv "LIB_DIR"
+ (string-append
+ (assoc-ref inputs "node") "/lib"))
+ #t)))))
+ (inputs
+ `(("node" ,libnode)))
+ (propagated-inputs
+ `(("r-curl" ,r-curl)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-rcpp" ,r-rcpp)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://jeroen.cran.dev/V8")
+ (synopsis "Embedded JavaScript and WebAssembly engine for R")
+ (description
+ "This package provides an R interface to V8: Google's JavaScript and
+WebAssembly engine.")
+ (license license:expat)))
+
+(define-public r-dot
+ (package
+ (name "r-dot")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "DOT" version))
+ (sha256
+ (base32
+ "0qh5n57cp9c2n5yn59q4wggz82943pwfanp3kx869aba2x3sj30i"))))
+ (properties `((upstream-name . "DOT")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-v8" ,r-v8)))
+ (home-page "http://haghish.com/dot")
+ (synopsis "Render and Export DOT Graphs in R")
+ (description
+ "This package provides tools to render DOT diagram markup language in R
+and also provides the possibility to export the graphs in PostScript and
+SVG (Scalable Vector Graphics) formats. In addition, it supports literate
+programming packages such as @code{knitr} and @code{rmarkdown}.")
+ (license license:expat)))
+
(define-public r-clipr
(package
(name "r-clipr")
@@ -158,6 +229,77 @@ the system clipboards.")
respecting the grammar of its graphics paradigm.")
(license license:gpl2+)))
+(define-public r-gprofiler
+ (package
+ (name "r-gprofiler")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gProfileR" version))
+ (sha256
+ (base32
+ "1h1v0kgpsn04ald2izznh7fr2riwisj5hcgz4k7h3qc931rf0r4k"))))
+ (properties `((upstream-name . "gProfileR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-plyr" ,r-plyr)
+ ("r-rcurl" ,r-rcurl)))
+ (home-page "https://cran.r-project.org/web/packages/gProfileR/")
+ (synopsis "Interface to the g:Profiler toolkit")
+ (description
+ "This package provides tools for functional enrichment analysis,
+gene identifier conversion and mapping homologous genes across related
+organisms via the @code{g:Profiler} toolkit.")
+ (license license:gpl2+)))
+
+(define-public r-gprofiler2
+ (package
+ (name "r-gprofiler2")
+ (version "0.1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gprofiler2" version))
+ (sha256
+ (base32
+ "112hmmvdwg8xz90w1bsbzc55y4xi9jj4dqy0q4bsgp49x58r92rb"))))
+ (properties `((upstream-name . "gprofiler2")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-crosstalk" ,r-crosstalk)
+ ("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-plotly" ,r-plotly)
+ ("r-rcurl" ,r-rcurl)
+ ("r-tidyr" ,r-tidyr)
+ ("r-viridislite" ,r-viridislite)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://cran.r-project.org/web/packages/gprofiler2/")
+ (synopsis "Interface to the g:Profiler toolset")
+ (description
+ "This package provides a toolset for functional enrichment analysis and
+visualization, gene/protein/SNP identifier conversion and mapping orthologous
+genes across species via @url{https://biit.cs.ut.ee/gprofiler,g:Profiler}.
+The main tools are:
+
+@enumerate
+@item @code{g:GOSt}, functional enrichment analysis and visualization of gene
+ lists;
+@item @code{g:Convert}, gene/protein/transcript identifier conversion across
+ various namespaces;
+@item @code{g:Orth}, orthology search across species;
+@item @code{g:SNPense}, mapping SNP rs identifiers to chromosome positions,
+ genes and variant effects.
+@end enumerate
+
+This package is an R interface corresponding to the 2019 update of
+@code{g:Profiler} and provides access to versions @code{e94_eg41_p11} and
+higher.")
+ (license license:gpl2+)))
+
(define-public r-oenb
(package
(name "r-oenb")
@@ -21853,3 +21995,31 @@ with posterior predictive checks and leave-one-out cross-validation.")
and prediction with Aalen-Johansen or simulation in competing risks and
multi-state models.")
(license license:gpl2+)))
+
+(define-public r-scatterpie
+ (package
+ (name "r-scatterpie")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "scatterpie" version))
+ (sha256
+ (base32
+ "0g5sn0iv6c1q7y51j4gbbbnil5089dgk1w4q94c7h5y3x7wfrzqb"))))
+ (properties `((upstream-name . "scatterpie")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggforce" ,r-ggforce)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-rlang" ,r-rlang)
+ ("r-rvcheck" ,r-rvcheck)
+ ("r-tidyr" ,r-tidyr)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://cran.r-project.org/web/packages/scatterpie/")
+ (synopsis "Scatter pie plot")
+ (description
+ "This package creates scatterpie plots, especially useful for plotting
+pies on a map.")
+ (license license:artistic2.0)))