summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm133
1 files changed, 105 insertions, 28 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 742bc5f663..d282ee8ad3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -119,14 +119,14 @@ are not used.")
(define-public r-sys
(package
(name "r-sys")
- (version "3.1")
+ (version "3.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "sys" version))
(sha256
(base32
- "0aj3wcyah3r7c9s3rbs0c8nifd4vqmkzg9fqkrb7f838ww0qw24q"))))
+ "1k5vk5q9wa5sin0n226i05nymg469s24f6lx64yyhb7yc624j698"))))
(build-system r-build-system)
(home-page "https://github.com/jeroen/sys")
(synopsis "Powerful and reliable tools for running system commands in R")
@@ -2867,14 +2867,14 @@ with the package @code{optim}.")
(define-public r-ordinal
(package
(name "r-ordinal")
- (version "2019.3-9")
+ (version "2019.4-25")
(source
(origin
(method url-fetch)
(uri (cran-uri "ordinal" version))
(sha256
(base32
- "0xsr2715ghh1q5hjnx7d8lyavzfvpi370blm1xdljn3p4kar8ldi"))))
+ "1pvrkly4x12w32n7w1qljdwzqnlkv7rfa7rx0nz5vbiw29xas4i8"))))
(build-system r-build-system)
(propagated-inputs
`(("r-mass" ,r-mass)
@@ -7193,6 +7193,26 @@ replicating the evaluation as many times as specified, and returning the results
conveniently wrapped into a data frame.")
(license license:gpl2+)))
+(define-public r-mitools
+ (package
+ (name "r-mitools")
+ (version "2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mitools" version))
+ (sha256
+ (base32
+ "0c2x2n1p53lcw0vx4vmy5j7m2f95i7g2iwbryl89imr99rvz617j"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-dbi" ,r-dbi)))
+ (home-page "https://cran.r-project.org/web/packages/mitools/")
+ (synopsis "Tools for multiple imputation of missing data")
+ (description
+ "This package provides tools to perform analyses and combine results from
+multiple-imputation datasets.")
+ (license license:gpl2)))
+
(define-public r-magick
(package
(name "r-magick")
@@ -7229,19 +7249,20 @@ console, resulting in an interactive editing environment.")
(define-public r-survey
(package
(name "r-survey")
- (version "3.35-1")
+ (version "3.36")
(source
(origin
(method url-fetch)
(uri (cran-uri "survey" version))
(sha256
(base32
- "1nv4sdfmidvyjgvp3zvn5iw35bb8w0v7095is2pdy8cckkgdvr8i"))))
+ "0xclsy4ram4k48vzh5m5bpmknnpwxnss85v73s4czsjj5ffjxwwh"))))
(build-system r-build-system)
(propagated-inputs
`(("r-lattice" ,r-lattice)
("r-matrix" ,r-matrix)
("r-minqa" ,r-minqa)
+ ("r-mitools" ,r-mitools)
("r-numderiv" ,r-numderiv)
("r-survival" ,r-survival)))
(home-page "http://r-survey.r-forge.r-project.org/survey/")
@@ -7584,14 +7605,14 @@ Hothorn, Westfall, 2010, CRC Press).")
(define-public r-emmeans
(package
(name "r-emmeans")
- (version "1.3.3")
+ (version "1.3.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "emmeans" version))
(sha256
(base32
- "1hpal1vq6gryzvgfvv9f328idg0mgjvlfnhaj069dhb7zqfwhzlk"))))
+ "09gxphan34c615y4lhjdqkg5cz4ih9b1r3bb4chs3mwmiav1rxqn"))))
(build-system r-build-system)
(propagated-inputs
`(("r-estimability" ,r-estimability)
@@ -7809,6 +7830,58 @@ Laplace approximation. Gradients are calculated using automatic
differentiation.")
(license license:agpl3+)))
+(define-public r-bayestestr
+ (package
+ (name "r-bayestestr")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "bayestestR" version))
+ (sha256
+ (base32
+ "1m6gj55z3shm3m3mgqj8nk73wij67y617sl04rbj400wz9qrhfva"))))
+ (properties `((upstream-name . "bayestestR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-insight" ,r-insight)))
+ (home-page "https://github.com/easystats/bayestestR")
+ (synopsis "Describe Bayesian models and posterior distributions")
+ (description
+ "This package provides utilities to understand and describe posterior
+distributions and Bayesian models. It includes point-estimates such as
+@dfn{Maximum A Posteriori} (MAP), measures of dispersion such as @dfn{Highest
+Density Interval} (HDI), and indices used for null-hypothesis testing (such as
+ROPE percentage and pd).")
+ (license license:gpl3)))
+
+(define-public r-performance
+ (package
+ (name "r-performance")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "performance" version))
+ (sha256
+ (base32
+ "19lfx25hkavzbycrh6hq4v24a0dz4s60ryq6jyihjlxgrb9g7cnw"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bayestestr" ,r-bayestestr)
+ ("r-insight" ,r-insight)))
+ (home-page "https://easystats.github.io/performance/")
+ (synopsis "Assessment of regression models performance")
+ (description
+ "This package provides utilities for computing measures to assess model
+quality, which are not directly provided by R's @code{base} or @code{stats}
+packages. These include e.g. measures like r-squared, intraclass correlation
+coefficient, root mean squared error or functions to check models for
+overdispersion, singularity or zero-inflation and more. Functions apply to a
+large variety of regression models, including generalized linear models, mixed
+effects models and Bayesian models.")
+ (license license:gpl3)))
+
(define-public r-ggeffects
(package
(name "r-ggeffects")
@@ -7846,29 +7919,32 @@ results using @code{ggplot2}.")
(define-public r-sjplot
(package
(name "r-sjplot")
- (version "2.6.2")
+ (version "2.6.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "sjPlot" version))
(sha256
(base32
- "0x9pbchmz4qf4c9bi52dhhgv1phfj03q1hnxic8vndl6xwib63cy"))))
+ "0h1mkmp5mrkbf7y3zh6m4cnm737cpg1m5si0lrmal7j2ixqicwjy"))))
(properties `((upstream-name . "sjPlot")))
(build-system r-build-system)
(propagated-inputs
- `(("r-broom" ,r-broom)
+ `(("r-bayestestr" ,r-bayestestr)
+ ("r-broom" ,r-broom)
("r-dplyr" ,r-dplyr)
("r-forcats" ,r-forcats)
("r-ggeffects" ,r-ggeffects)
("r-ggplot2" ,r-ggplot2)
("r-glmmtmb" ,r-glmmtmb)
+ ("r-insight" ,r-insight)
("r-knitr" ,r-knitr)
("r-lme4" ,r-lme4)
("r-magrittr" ,r-magrittr)
("r-mass" ,r-mass)
("r-modelr" ,r-modelr)
("r-nlme" ,r-nlme)
+ ("r-performance" ,r-performance)
("r-psych" ,r-psych)
("r-purrr" ,r-purrr)
("r-rlang" ,r-rlang)
@@ -9311,14 +9387,14 @@ the first time as the statistic.")
(define-public r-splitstackshape
(package
(name "r-splitstackshape")
- (version "1.4.6")
+ (version "1.4.8")
(source
(origin
(method url-fetch)
(uri (cran-uri "splitstackshape" version))
(sha256
(base32
- "03w6h64ga4zqilffdway4l38l5cbman4yrspkzhbigds12aqz25r"))))
+ "0mpyf2kkfdl69pdc6brl1r6101vyc6pgr7z17s55ppg3y71k4q35"))))
(build-system r-build-system)
(propagated-inputs
`(("r-data-table" ,r-data-table)))
@@ -10267,14 +10343,14 @@ Differences with other sparse matrix packages are:
(define-public r-fields
(package
(name "r-fields")
- (version "9.6")
+ (version "9.7")
(source
(origin
(method url-fetch)
(uri (cran-uri "fields" version))
(sha256
(base32
- "1v7z48a8jmdcil28rj8c3455k6rssr5v9qi6dyhhpbb193bj8121"))))
+ "0hsr6r0zyv8zqkfyd9fmjk6v901m2r8pmswvsmps6w5zvpi0p5kw"))))
(build-system r-build-system)
(propagated-inputs
`(("r-maps" ,r-maps)
@@ -12109,19 +12185,20 @@ classes.")
(define-public r-classint
(package
(name "r-classint")
- (version "0.3-1")
+ (version "0.3-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "classInt" version))
(sha256
(base32
- "1fcjrb593bzvx1z57hq1sjs2gp6g7sm4d4xrhasfrps4nmbzirp2"))))
+ "0c2z6shlxa928xa20yl956r06lx20mji3mwipdvmj3f4z5g6hgm9"))))
(properties `((upstream-name . "classInt")))
(build-system r-build-system)
(propagated-inputs
`(("r-class" ,r-class)
- ("r-e1071" ,r-e1071)))
+ ("r-e1071" ,r-e1071)
+ ("r-kernsmooth" ,r-kernsmooth)))
(native-inputs `(("gfortran" ,gfortran)))
(home-page "https://github.com/r-spatial/classInt/")
(synopsis "Choose univariate class intervals")
@@ -12207,14 +12284,14 @@ tessellation.")
(define-public r-sf
(package
(name "r-sf")
- (version "0.7-3")
+ (version "0.7-4")
(source
(origin
(method url-fetch)
(uri (cran-uri "sf" version))
(sha256
(base32
- "1b9lbid0hmmz8m5vhg8mi2mi2rclia6qwzd1jr8s81i2l0md828d"))))
+ "0vnyr7xyfcl928kbrb1k8l4fkd0cjrfq486g6gxpvy5j0cc2h4i1"))))
(build-system r-build-system)
(inputs
`(("gdal" ,gdal)
@@ -12368,14 +12445,14 @@ genetics of complex population dynamics.")
(define-public r-genetics
(package
(name "r-genetics")
- (version "1.3.8.1.1")
+ (version "1.3.8.1.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "genetics" version))
(sha256
(base32
- "0p59r4vxhy68d7cv2s2k4vbgnkxji21naz9jmdry9wxclrg7fw28"))))
+ "1v0ylnia6c44v356dsmnkx6054vcxazpzsrdh3yph5ch5vg6gjrh"))))
(build-system r-build-system)
(propagated-inputs
`(("r-combinat" ,r-combinat)
@@ -12444,14 +12521,14 @@ lspec, polyclass, and polymars.")
(define-public r-rms
(package
(name "r-rms")
- (version "5.1-3")
+ (version "5.1-3.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "rms" version))
(sha256
(base32
- "1sw9a0iqiips580jpbk7yiqgyiswihvaqbnq4ybsmd4ki86i5isz"))))
+ "0drbr3g0x5pbxyzy50wnf92rbal8izizrcqslqhg0gsfg9adjih9"))))
(build-system r-build-system)
(propagated-inputs
`(("r-ggplot2" ,r-ggplot2)
@@ -13279,14 +13356,14 @@ sets of URLs.")
(define-public r-ggforce
(package
(name "r-ggforce")
- (version "0.2.1")
+ (version "0.2.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggforce" version))
(sha256
(base32
- "04rh9z58q288lbi933472lgl26wwbw58rfhpgfyijmw9ccz7i93m"))))
+ "0snxx9zhcccxa7pz9pf3bjqmcmv9mz4m47v81hklnhm25jj40xg2"))))
(build-system r-build-system)
(propagated-inputs
`(("r-ggplot2" ,r-ggplot2)
@@ -13407,14 +13484,14 @@ proteomics applications).")
(define-public r-pamr
(package
(name "r-pamr")
- (version "1.56")
+ (version "1.56.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "pamr" version))
(sha256
(base32
- "03h1m5fkw76jjln1psdb7x913a499ghf7n48rcd8damr5vdyf961"))))
+ "0ycpgkk23y3zzkb42n2skcyl35ps1n7jmyzfj7pbxr3f6gr2grfh"))))
(build-system r-build-system)
(propagated-inputs
`(("r-cluster" ,r-cluster)