summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm192
1 files changed, 151 insertions, 41 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6caf50858a..328a3f3f6f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -84,6 +84,7 @@
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
+;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -963,6 +964,33 @@ using the Buffers User Interface library. You can view, copy, and edit secrets
from within Emacs.")
(license license:gpl3+)))
+(define-public emacs-solidity
+ ;; This commit fixes a spacing issue and adds new keywords.
+ (let ((commit "d166a86b83907e0cfd64c191e9dfce4b44a9843e")
+ (revision "0"))
+ (package
+ (name "emacs-solidity")
+ (version (git-version "0.1.10" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ethereum/emacs-solidity")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19hgvsrqch2vp49ag6m76bi5qxd20v95z0ib838rib9as15b17wq"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)
+ ("emacs-flycheck" ,emacs-flycheck)))
+ (home-page "https://github.com/ethereum/emacs-solidity")
+ (synopsis "Major mode for writing Solidity code")
+ (description
+ "This is a simple language mode for the Solidity language. It is
+a constant work in progress as the language itself also progresses.")
+ (license license:gpl3+))))
+
(define-public emacs-unpackaged-el
(let ((commit "746801a677ada6cd6fa076e423aa0953779f3fad")
(revision "3"))
@@ -1587,14 +1615,14 @@ incrementally confined in Isearch manner.")
(define emacs-emms-print-metadata
(package
(name "emacs-emms-print-metadata")
- (version "6.0")
+ (version "6.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"emms-" version ".tar"))
(sha256
- (base32 "1zxiic91zhgdkxyfgyh1vkv4lzg90vq362y9k739n28ci6z4xzwm"))))
+ (base32 "0d95sjrh9vpl41vz26y8clgji987z15lj4ky2kr9yrl0zpa8yv35"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("emms-print-metadata")
@@ -8754,25 +8782,24 @@ that uses the standard completion function completing-read.")
(define-public emacs-yaml-mode
(package
(name "emacs-yaml-mode")
- (version "0.0.14")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/yoshiki/yaml-mode")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "18g064ardqi1f3xz7j6rs1x9fvv9sn0iq9vgid8c6qvxq7gwj00r"))))
+ (version "0.0.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yoshiki/yaml-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gsa153yp8lmwrvcc3nzpw5lj037y7q2nm23k5k404r5as4k355l"))))
(build-system emacs-build-system)
(home-page "https://github.com/yoshiki/yaml-mode")
(synopsis "Major mode for editing YAML files")
(description
- "Yaml-mode is an Emacs major mode for editing files in the YAML data
-serialization format. It was initially developed by Yoshiki Kurihara and many
-features were added by Marshall Vandegrift. As YAML and Python share the fact
-that indentation determines structure, this mode provides indentation and
-indentation command behavior very similar to that of python-mode.")
+ "Yaml mode is an Emacs major mode for editing files in the YAML data
+serialization format. As YAML and Python share the fact that indentation
+determines structure, this mode provides indentation and indentation command
+behavior very similar to that of Python mode.")
(license license:gpl3+)))
(define-public emacs-gitlab-ci-mode
@@ -11104,7 +11131,7 @@ abbreviation of the mode line displays (lighters) of minor modes.")
(define-public emacs-use-package
(package
(name "emacs-use-package")
- (version "2.4")
+ (version "2.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -11113,7 +11140,7 @@ abbreviation of the mode line displays (lighters) of minor modes.")
(file-name (git-file-name name version))
(sha256
(base32
- "1b7mjjh0d6fmkkd9vyj64vca27xqhga0nvyrrcqxpqjn62zq046y"))))
+ "088kl3bml0rs5bkfymgzr15ram9qvy66h1kaisrbkynh0yxvf8g9"))))
(build-system emacs-build-system)
(native-inputs
`(("texinfo" ,texinfo)))
@@ -11147,14 +11174,14 @@ performance-oriented and tidy.")
(define-public emacs-leaf
(package
(name "emacs-leaf")
- (version "4.2.5")
+ (version "4.3.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"leaf-" version ".tar"))
(sha256
- (base32 "0y78mp4c2gcwp7dc87wlx3r4hfmap14vvx8gkjc9nkf99qavpnkw"))))
+ (base32 "190sfnnii9jnj8amjkdabd8w9k2xyalhg4h488a5gzjxdzz2s6zi"))))
(build-system emacs-build-system)
(home-page "https://github.com/conao3/leaf.el")
(synopsis "Simplify your init.el configuration, extended use-package")
@@ -11343,6 +11370,30 @@ constructs.")
configuration of Chinese fonts.")
(license license:gpl2+)))
+(define-public emacs-csharp-mode
+ (package
+ (name "emacs-csharp-mode")
+ (version "0.10.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/josteink/csharp-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vwkbla2gkfa9dzxfvrvr7hd2z16769iwbycl7k6l701dnwli1fw"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/josteink/csharp-mode")
+ (synopsis "Major mode for C# code")
+ (description
+ "This is a C# editing mode for Emacs, based on CC mode. It handles
+syntax coloring, indentation, insertion of matched pairs of curly braces and
+documentation generation. In addition, it provides menu-based navigation
+using Imenu, and Compilation mode support for MSBuild, devenv and xbuild.")
+ ;; XXX: Project switched to GPL3+ after 0.10.0 release.
+ (license license:gpl2+)))
+
(define-public emacs-php-mode
(package
(name "emacs-php-mode")
@@ -18537,6 +18588,16 @@ files. It focuses on highlighting the document to improve readability.")
(lambda _
(substitute* "Makefile"
(("\\$\\{CASK\\} exec ") ""))
+ #t))
+ ;; Two tests are failing with Emacs 27, as reported here:
+ ;; <https://github.com/racer-rust/emacs-racer/issues/136>. Disable
+ ;; them.
+ (add-before 'check 'fix-failing-tests
+ (lambda _
+ (substitute* "test/racer-test.el"
+ (("`Write`") "Write")
+ (("^\\\\\\[`str\\]:.*") "")
+ ((" \\[`str`\\]") " str"))
#t)))))
(native-inputs
`(("emacs-ert-runner" ,emacs-ert-runner)
@@ -20465,20 +20526,20 @@ processes for Emacs")
"0m083g3pg0n4ymi1w0jx34awr7cqbm4r561adij9kklblxsz7sc2"))))
(build-system emacs-build-system)
(propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-s" ,emacs-s)
- ("emacs-f" ,emacs-f)
- ("emacs-ace-window" ,emacs-ace-window)
- ("emacs-pfuture" ,emacs-pfuture)
- ("emacs-hydra" ,emacs-hydra)
- ("emacs-ht" ,emacs-ht)))
+ `(("emacs-ace-window" ,emacs-ace-window)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-ht" ,emacs-ht)
+ ("emacs-hydra" ,emacs-hydra)
+ ("emacs-pfuture" ,emacs-pfuture)
+ ("emacs-s" ,emacs-s)))
(native-inputs
`(("emacs-buttercup" ,emacs-buttercup)
("emacs-el-mock" ,emacs-el-mock)))
(inputs
`(("python" ,python)))
(arguments
- `(#:tests? #t ;TODO: Investigate ‘treemacs--parse-collapsed-dirs’ test failure.
+ `(#:tests? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-makefile
@@ -20493,12 +20554,14 @@ processes for Emacs")
(lambda _
(chdir "src/elisp")))
(replace 'check
+ ;; FIXME: Work around ‘treemacs--parse-collapsed-dirs’ and
+ ;; `treemacs-collect-child-nodes' test failures.
(lambda _
(with-directory-excursion "../.." ;treemacs root
(chmod "test/test-treemacs.el" #o644)
(emacs-substitute-sexps "test/test-treemacs.el"
- ("(describe \"treemacs--parse-collapsed-dirs\""
- ""))
+ ("(describe \"treemacs--parse-collapsed-dirs\"" "")
+ ("\"Finds only direct childre\"" ""))
(invoke "make" "test"))))
(add-before 'install 'patch-paths
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -20530,7 +20593,12 @@ processes for Emacs")
#t)))))))
(home-page "https://github.com/Alexander-Miller/treemacs")
(synopsis "Emacs tree style file explorer")
- (description "Powerful and flexible file tree project explorer.")
+ (description
+ "Treemacs is a file and project explorer similar to NeoTree or Vim's
+NerdTree, but largely inspired by the Project Explorer in Eclipse. It shows
+the file system outlines of your projects in a simple tree layout allowing
+quick navigation and exploration, while also possessing basic file management
+utilities.")
(license license:gpl3+)))
(define-public emacs-treemacs-extra
@@ -21593,8 +21661,8 @@ and searching through @code{Ctags} files.")
(license license:expat))))
(define-public emacs-org-download
- (let ((commit "10c9d7c8eed928c88a896310c882e3af4d8d0f61")
- (revision "2"))
+ (let ((commit "42ac361ef5502017e6fc1bceb00333eba90402f4")
+ (revision "3"))
(package
(name "emacs-org-download")
(version (git-version "0.1.0" revision commit))
@@ -21603,10 +21671,9 @@ and searching through @code{Ctags} files.")
(uri (git-reference
(url "https://github.com/abo-abo/org-download")
(commit commit)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0i8wlx1i7y1vn5lqwjifvymvszg28a07vwqcm4jslf1v2ajs1lsl"))
- (file-name (git-file-name name version))))
+ (base32 "0cg4y7hy7xbq4vrbdicfzgvyaf3cjbx2zkqd4yl0y2garz71j99l"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-org" ,emacs-org)
@@ -22025,7 +22092,7 @@ and article extracts for Wikipedia.")
(define-public emacs-webfeeder
(package
(name "emacs-webfeeder")
- (version "1.0.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -22035,7 +22102,7 @@ and article extracts for Wikipedia.")
".tar"))
(sha256
(base32
- "06y5vxw9m6pmbrzb8v2i3w9dnhgqxz06vyx1knmgi9cczlrj4a64"))))
+ "09wz6v58xc86hdnz6g54ckaxkm6844yyk2ffbxh4s5sdvgqrzdd8"))))
(build-system emacs-build-system)
(home-page "https://gitlab.com/Ambrevar/emacs-webfeeder")
(synopsis "Build RSS and Atom webfeeds from HTML files")
@@ -24290,7 +24357,7 @@ launching other commands/applications from within Emacs, similar to the
(define-public emacs-no-littering
(package
(name "emacs-no-littering")
- (version "1.0.3")
+ (version "1.2.0")
(source
(origin
(method git-fetch)
@@ -24299,7 +24366,7 @@ launching other commands/applications from within Emacs, similar to the
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "17is06l0w6glppabv2kaclrnqi3dqb6p6alpslpg7lrjd8vd45ir"))))
+ (base32 "1hma9var0nmrmjlh16s49hbfc1s4jvfd2prqxf14lxfd51404niw"))))
(build-system emacs-build-system)
(home-page "https://github.com/emacscollective/no-littering")
(synopsis "Help keep ~/.emacs.d/ clean")
@@ -25281,3 +25348,46 @@ the TypeScript implementation.")
(description "This package provides an Emacs client for the Rocket.chat
service.")
(license license:expat))))
+
+(define-public emacs-monokai-theme
+ (package
+ (name "emacs-monokai-theme")
+ (version "3.5.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oneKelvinSmith/monokai-emacs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dy8c3349j7fmp8052hbgvk0b7ldlv5jqpg0paq1i0hlypivd30i"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/oneKelvinSmith/monokai-emacs")
+ (synopsis "High contrast color theme for Emacs")
+ (description
+ "Monokai theme is a port of the popular TextMate Monokai theme for
+Emacs.")
+ (license license:gpl3+)))
+
+(define-public emacs-nord-theme
+ (package
+ (name "emacs-nord-theme")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arcticicestudio/nord-emacs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "096f8cik4jz89bvkifwp3gm9iraqrd75ljy2q9js724v7yj88711"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.nordtheme.com/")
+ (synopsis "Low contrast arctic color theme for Emacs")
+ (description
+ "Nord is an arctic, north-bluish color scheme created for a clean and
+uncluttered design pattern to achieve optimal focus and readability for code
+syntax highlighting and UI components.")
+ (license license:expat)))