summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm610
1 files changed, 430 insertions, 180 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6caf50858a..ad8657df41 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -84,6 +84,7 @@
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
+;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -963,6 +964,33 @@ using the Buffers User Interface library. You can view, copy, and edit secrets
from within Emacs.")
(license license:gpl3+)))
+(define-public emacs-solidity
+ ;; This commit fixes a spacing issue and adds new keywords.
+ (let ((commit "d166a86b83907e0cfd64c191e9dfce4b44a9843e")
+ (revision "0"))
+ (package
+ (name "emacs-solidity")
+ (version (git-version "0.1.10" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ethereum/emacs-solidity")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19hgvsrqch2vp49ag6m76bi5qxd20v95z0ib838rib9as15b17wq"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)
+ ("emacs-flycheck" ,emacs-flycheck)))
+ (home-page "https://github.com/ethereum/emacs-solidity")
+ (synopsis "Major mode for writing Solidity code")
+ (description
+ "This is a simple language mode for the Solidity language. It is
+a constant work in progress as the language itself also progresses.")
+ (license license:gpl3+))))
+
(define-public emacs-unpackaged-el
(let ((commit "746801a677ada6cd6fa076e423aa0953779f3fad")
(revision "3"))
@@ -1587,14 +1615,14 @@ incrementally confined in Isearch manner.")
(define emacs-emms-print-metadata
(package
(name "emacs-emms-print-metadata")
- (version "6.0")
+ (version "6.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"emms-" version ".tar"))
(sha256
- (base32 "1zxiic91zhgdkxyfgyh1vkv4lzg90vq362y9k739n28ci6z4xzwm"))))
+ (base32 "0d95sjrh9vpl41vz26y8clgji987z15lj4ky2kr9yrl0zpa8yv35"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("emms-print-metadata")
@@ -1843,12 +1871,12 @@ than @code{electric-indent-mode}.")
(license license:gpl2+)))
(define-public emacs-gcmh
- ;; No tagged release upstream.
- (let ((commit "84c43a4c0b41a595ac6e299fa317d2831813e580")
- (revision "0"))
+ ;; No tagged release upstream, but the commit below correspond to the 0.2.1
+ ;; release.
+ (let ((commit "0089f9c3a6d4e9a310d0791cf6fa8f35642ecfd9"))
(package
(name "emacs-gcmh")
- (version (git-version "0.1" revision commit))
+ (version "0.2.1")
(source
(origin
(method git-fetch)
@@ -1856,7 +1884,7 @@ than @code{electric-indent-mode}.")
(url "https://gitlab.com/koral/gcmh")
(commit commit)))
(sha256
- (base32 "1r3wiqhrzh7wvqy484nl031fd4bn4cpvkv9646s4cjgvnnnv7jz3"))
+ (base32 "0yh1ap8phv3x44rp0yr6z884xqw2apanbx4c0acqglvj0gaaqx25"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(home-page "https://gitlab.com/koral/gcmh")
@@ -2210,7 +2238,7 @@ Lock key.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/contrapunctus-1/chronometrist.git")
+ (url "https://github.com/contrapunctus-1/chronometrist")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2576,14 +2604,14 @@ filters, new key bindings and faces. It can be enabled by
(define-public emacs-djvu
(package
(name "emacs-djvu")
- (version "1.1")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"djvu-" version ".el"))
(sha256
- (base32 "0njgyx09q225hliacsnjk8wallg5i6xkz6bj501pb05nwqfbvfk7"))))
+ (base32 "0z2qk1v4qkvcwl27ycqfb8vyszq5v6b8ci29b4la00yaki16p04i"))))
(build-system emacs-build-system)
(inputs `(("djview" ,djview)
("djvulibre" ,djvulibre)))
@@ -4536,7 +4564,7 @@ compile}.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/purcell/flycheck-ledger.git")
+ (url "https://github.com/purcell/flycheck-ledger")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -7016,29 +7044,33 @@ parallel.")
(license license:gpl3+)))
(define-public emacs-request
- (package
- (name "emacs-request")
- (version "0.3.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tkf/emacs-request")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1djywhvvb6kwdj0nd3axjvb7k2g06dzkc6hsf29w9rsk96vr8ryl"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #f)) ; requires network access.
- (propagated-inputs
- `(("emacs-deferred" ,emacs-deferred)))
- (home-page "https://github.com/tkf/emacs-request")
- (synopsis "Package for speaking HTTP in Emacs Lisp")
- (description "This package provides a HTTP request library with multiple
+ ;; We prefer a more recent commit that has support for auth-source,
+ ;; which makes authentication more convenient for users and maintainers.
+ (let ((commit "d02d1347ffdf138cffd380cbeac62ac8732036ef")
+ (revision "0"))
+ (package
+ (name "emacs-request")
+ (version (git-version "0.3.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tkf/emacs-request")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rkpakzish2d470ca15yq3k0m1j7a2lrkvvddcyvc2rx0sncsdjs"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #f)) ; requires network access.
+ (propagated-inputs
+ `(("emacs-deferred" ,emacs-deferred)))
+ (home-page "https://github.com/tkf/emacs-request")
+ (synopsis "Package for speaking HTTP in Emacs Lisp")
+ (description "This package provides a HTTP request library with multiple
backends. It supports url.el which is shipped with Emacs and the curl command
line program.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-rudel
(package
@@ -7441,63 +7473,68 @@ navigate code in a tree-like fashion.")
(license license:gpl3+)))
(define-public emacs-lispy
- (package
- (name "emacs-lispy")
- (version "0.27.0")
- (home-page "https://github.com/abo-abo/lispy")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/abo-abo/lispy")
- (commit version)))
- (sha256
- (base32
- "1cm7f4pyl73f3vhkb7ah6bbbrj2sa7n0p31g09k7dy4zgx04bgw6"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-ace-window" ,emacs-ace-window)
- ("emacs-hydra" ,emacs-hydra)
- ("emacs-iedit" ,emacs-iedit)
- ("emacs-swiper" ,emacs-swiper)
- ("emacs-zoutline" ,emacs-zoutline)))
- (native-inputs
- `(("emacs-clojure-mode" ,emacs-clojure-mode)
- ("emacs-undercover" ,emacs-undercover)))
- (arguments
- `(#:include (cons* "^lispy-clojure\\.clj$"
- "^lispy-python\\.py$"
- %default-include)
- #:phases
- ;; XXX: one failing test involving python evaluation
- (modify-phases %standard-phases
- (add-before 'check 'make-test-writable
- (lambda _
- (make-file-writable "lispy-test.el")
- #t))
- (add-before 'check 'remove-python-eval-test
- (lambda _
- (emacs-batch-edit-file "lispy-test.el"
- `(progn
- (progn
- (goto-char (point-min))
- (re-search-forward
- "ert-deftest lispy-eval-python-str")
- (beginning-of-line)
- (kill-sexp))
- (basic-save-buffer)))
- #t)))
- #:tests? #t
- #:test-command '("make" "test")))
- (synopsis "Modal S-expression editing")
- (description
- "Due to the structure of Lisp syntax it's very rare for the programmer
+ ;; No release since May 2019 and tons of fixes have landed on master.
+ ;; https://github.com/abo-abo/lispy/issues/513
+ (let ((commit "5c8a59ae7dd3dd342e7c86a8c0acdbd13e2989f3"))
+ (package
+ (name "emacs-lispy")
+ (version (git-version "0.27.0" "1" commit))
+ (home-page "https://github.com/abo-abo/lispy")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abo-abo/lispy")
+ (commit commit)))
+ (sha256
+ (base32
+ "0738v9bp4dlxbwsnykvc35yh4dl4pvw25jl8srb7r3744ydvgyii"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ace-window" ,emacs-ace-window)
+ ("emacs-hydra" ,emacs-hydra)
+ ("emacs-iedit" ,emacs-iedit)
+ ("emacs-swiper" ,emacs-swiper)
+ ("emacs-zoutline" ,emacs-zoutline)))
+ (native-inputs
+ `(("which" ,which)
+ ("emacs-clojure-mode" ,emacs-clojure-mode)
+ ("emacs-undercover" ,emacs-undercover)))
+ (arguments
+ `(#:include (cons* "^lispy-clojure\\.clj$"
+ "^lispy-python\\.py$"
+ %default-include)
+ #:phases
+ ;; XXX: Some failing tests
+ (modify-phases %standard-phases
+ (add-before 'check 'make-test-writable
+ (lambda _
+ (make-file-writable "lispy-test.el")
+ #t))
+ (add-before 'check 'remove-failing-test
+ (lambda _
+ (emacs-batch-edit-file "lispy-test.el"
+ `(progn
+ (dolist (test '("lispy-eval-python-str" "lispy--clojure-dot-object"))
+ (goto-char (point-min))
+ (re-search-forward
+ (concat "ert-deftest " test))
+ (beginning-of-line)
+ (kill-sexp))
+ (basic-save-buffer)))
+ #t)))
+ #:tests? #t
+ ;; Set BEMACS to prevent the test suite from loading straight.el.
+ #:test-command '("make" "test" "BEMACS=emacs -batch")))
+ (synopsis "Modal S-expression editing")
+ (description
+ "Due to the structure of Lisp syntax it's very rare for the programmer
to want to insert characters right before \"(\" or right after \")\". Thus
unprefixed printable characters can be used to call commands when the point is
at one of these special locations. Lispy provides unprefixed keybindings for
S-expression editing when point is at the beginning or end of an
S-expression.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-lispyville
(let ((commit "1bf38088c981f5ab4ef2e2684952ab6af96378db")
@@ -7629,7 +7666,7 @@ The purpose of this library is to wrap all the quirks and hassle of
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/fuxialexander/counsel-notmuch.git")
+ (url "https://github.com/fuxialexander/counsel-notmuch")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -8754,25 +8791,24 @@ that uses the standard completion function completing-read.")
(define-public emacs-yaml-mode
(package
(name "emacs-yaml-mode")
- (version "0.0.14")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/yoshiki/yaml-mode")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "18g064ardqi1f3xz7j6rs1x9fvv9sn0iq9vgid8c6qvxq7gwj00r"))))
+ (version "0.0.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yoshiki/yaml-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gsa153yp8lmwrvcc3nzpw5lj037y7q2nm23k5k404r5as4k355l"))))
(build-system emacs-build-system)
(home-page "https://github.com/yoshiki/yaml-mode")
(synopsis "Major mode for editing YAML files")
(description
- "Yaml-mode is an Emacs major mode for editing files in the YAML data
-serialization format. It was initially developed by Yoshiki Kurihara and many
-features were added by Marshall Vandegrift. As YAML and Python share the fact
-that indentation determines structure, this mode provides indentation and
-indentation command behavior very similar to that of python-mode.")
+ "Yaml mode is an Emacs major mode for editing files in the YAML data
+serialization format. As YAML and Python share the fact that indentation
+determines structure, this mode provides indentation and indentation command
+behavior very similar to that of Python mode.")
(license license:gpl3+)))
(define-public emacs-gitlab-ci-mode
@@ -8872,7 +8908,7 @@ ack, ag, helm and pt.")
(define-public emacs-helm
(package
(name "emacs-helm")
- (version "3.6.5")
+ (version "3.7.0")
(source
(origin
(method git-fetch)
@@ -8881,7 +8917,7 @@ ack, ag, helm and pt.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0yzpb84346v42ig4h0rsnvzmln58ilhc0gsq0ggc7038ypqkdw4d"))))
+ (base32 "0lxq13bsbh7xawgsq08kjm7s28x9yl8mid3538flv5kcc1rv2b9y"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-async" ,emacs-async)
@@ -9477,8 +9513,8 @@ extensions.")
(license license:gpl3+)))
(define-public emacs-evil-collection
- (let ((commit "910c1f4507d91a4790e26ddccf73ad1e5a12f68d")
- (revision "17"))
+ (let ((commit "8c256263ad100fecd6246c6c55cbb19dab717c39")
+ (revision "18"))
(package
(name "emacs-evil-collection")
(version (git-version "0.0.3" revision commit))
@@ -9490,7 +9526,7 @@ extensions.")
(file-name (git-file-name name version))
(sha256
(base32
- "0bkx1bwgw1n3fbd95z8i32i1yvv8w8bgzsxsybm1lcgv1v23qn8l"))))
+ "0hz1yfv5g016dm99bwnibbmyhbi21qlc39ckd7p3s82az89hgf2n"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-evil" ,emacs-evil)
@@ -10680,46 +10716,42 @@ Yasnippet.")
(license license:gpl2+))))
(define-public emacs-helm-system-packages
- ;; There won't be a new release after 1.10.1 until
- ;; https://github.com/emacs-helm/helm-system-packages/issues/25 is fixed,
- ;; and latest commits fix import issues with Guix.
- (let ((commit "6572340f41611ef1991e9612d34d59130957ee4a"))
- (package
- (name "emacs-helm-system-packages")
- (version (git-version "1.10.1" "1" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacs-helm/helm-system-packages")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0mcz6vkpk12vsyd37xv1rbg4v442sxc3lj8yxskqg294xbdaclz4"))))
- (build-system emacs-build-system)
- (inputs
- `(("recutils" ,recutils)))
- (propagated-inputs
- `(("emacs-helm" ,emacs-helm)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((recutils (assoc-ref inputs "recutils")))
- ;; Specify the absolute file names of the various
- ;; programs so that everything works out-of-the-box.
- (substitute* "helm-system-packages-guix.el"
- (("recsel") (string-append recutils "/bin/recsel")))))))))
- (home-page "https://github.com/emacs-helm/helm-system-packages")
- (synopsis "Helm System Packages is an interface to your package manager")
- (description "List all available packages in Helm (with installed
+ (package
+ (name "emacs-helm-system-packages")
+ (version "1.10.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-system-packages")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13a8jpj4wwm0yjv8hnsizgjf8wi3r2ap87lyvw7g4c7snp2dydwa"))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("recutils" ,recutils)))
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((recutils (assoc-ref inputs "recutils")))
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (substitute* "helm-system-packages-guix.el"
+ (("recsel") (string-append recutils "/bin/recsel")))))))))
+ (home-page "https://github.com/emacs-helm/helm-system-packages")
+ (synopsis "Helm System Packages is an interface to your package manager")
+ (description "List all available packages in Helm (with installed
packages displayed in their own respective face). Fuzzy-search, mark and
execute the desired action over any selections of packages: Install,
uninstall, display packages details (in Org Mode) or insert details at point,
find files owned by packages... And much more, including performing all the
above over the network.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-helm-org-rifle
(package
@@ -11104,7 +11136,7 @@ abbreviation of the mode line displays (lighters) of minor modes.")
(define-public emacs-use-package
(package
(name "emacs-use-package")
- (version "2.4")
+ (version "2.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -11113,7 +11145,7 @@ abbreviation of the mode line displays (lighters) of minor modes.")
(file-name (git-file-name name version))
(sha256
(base32
- "1b7mjjh0d6fmkkd9vyj64vca27xqhga0nvyrrcqxpqjn62zq046y"))))
+ "088kl3bml0rs5bkfymgzr15ram9qvy66h1kaisrbkynh0yxvf8g9"))))
(build-system emacs-build-system)
(native-inputs
`(("texinfo" ,texinfo)))
@@ -11147,14 +11179,14 @@ performance-oriented and tidy.")
(define-public emacs-leaf
(package
(name "emacs-leaf")
- (version "4.2.5")
+ (version "4.3.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"leaf-" version ".tar"))
(sha256
- (base32 "0y78mp4c2gcwp7dc87wlx3r4hfmap14vvx8gkjc9nkf99qavpnkw"))))
+ (base32 "190sfnnii9jnj8amjkdabd8w9k2xyalhg4h488a5gzjxdzz2s6zi"))))
(build-system emacs-build-system)
(home-page "https://github.com/conao3/leaf.el")
(synopsis "Simplify your init.el configuration, extended use-package")
@@ -11343,6 +11375,59 @@ constructs.")
configuration of Chinese fonts.")
(license license:gpl2+)))
+(define-public emacs-boon
+ (package
+ (name "emacs-boon")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/boon")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ss9bjs34q41pa0g0nbdzd8fwpjcbd2239rdlx5aykfv9v0b8j77"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-expand-region" ,emacs-expand-region)
+ ("emacs-multiple-cursors" ,emacs-multiple-cursors)
+ ("emacs-powerline" ,emacs-powerline)
+ ("emacs-spaceline" ,emacs-spaceline)))
+ (home-page "https://github.com/jyp/boon")
+ (synopsis "Ergonomic command mode for Emacs")
+ (description "Boon is a complete package for modal editing with a focus on
+ergonomics and modularity. Spacial allocation of keys comes first, mnemonics
+second. Most common operations are mapped to the home row, common editing
+commands are bound to keys reachable with the left hand and movement keys are
+reached with the right hand.")
+ (license license:gpl3+)))
+
+(define-public emacs-csharp-mode
+ (package
+ (name "emacs-csharp-mode")
+ (version "0.10.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/josteink/csharp-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vwkbla2gkfa9dzxfvrvr7hd2z16769iwbycl7k6l701dnwli1fw"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/josteink/csharp-mode")
+ (synopsis "Major mode for C# code")
+ (description
+ "This is a C# editing mode for Emacs, based on CC mode. It handles
+syntax coloring, indentation, insertion of matched pairs of curly braces and
+documentation generation. In addition, it provides menu-based navigation
+using Imenu, and Compilation mode support for MSBuild, devenv and xbuild.")
+ ;; XXX: Project switched to GPL3+ after 0.10.0 release.
+ (license license:gpl2+)))
+
(define-public emacs-php-mode
(package
(name "emacs-php-mode")
@@ -11442,14 +11527,14 @@ and cangjie.")
(define-public emacs-posframe
(package
(name "emacs-posframe")
- (version "0.8.2")
+ (version "0.8.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"posframe-" version ".el"))
(sha256
- (base32 "1yrk2bnlx5bpkjkzqialf0q4bdp9c5pipnvj3zsb5hbjni24x0yb"))))
+ (base32 "05m56aw2yxik0pgcvyr5c92j2mwfksxgq1syzvik6161gy8hdd0g"))))
(build-system emacs-build-system)
;; emacs-minimal does not include the function font-info.
(arguments
@@ -14957,6 +15042,34 @@ and @code{erc-send-modify-hook} to download and show images.")
(description "This package provides a list manipulation library for Emacs.")
(license license:gpl3+)))
+(define-public emacs-parsec
+ ;; Last release is too old (2016).
+ (let ((revision "0")
+ (commit "2cbbbc2254aa7bcaa4fb5e07c8c1bf2f381dba26"))
+ (package
+ (name "emacs-parsec")
+ (version (git-version "0.1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cute-jumper/parsec.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1g1s8s45g3kkbi3h7w0pmadmzdswb64mkdvdpg2lihg341kx37gm"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/cute-jumper/parsec.el")
+ (synopsis "Parser combinator library for Emacs Lisp")
+ (description
+ "Parsec is a parser combinator library for Emacs Lisp, similar to
+Haskell's Parsec library. It contains most of the parser combinators in
+Text.Parsec.Combinator, and more combinators can be added if necessary! Most
+of the parser combinators have the same behavior as their Haskell
+counterparts. Parsec also comes with a simple error handling mechanism so
+that it can display an error message showing how the parser fails.")
+ (license license:gpl3+))))
+
(define-public emacs-move-text
(package
(name "emacs-move-text")
@@ -17230,7 +17343,7 @@ Dumb Jump performs best with The Silver Searcher @command{ag} or ripgrep
(base32
"1k8lljdbc90nd29xrhdrsscxavzdq532wq2mg7ljc94krj7538b1"))))
(build-system emacs-build-system)
- (home-page "https://github.com/bgamari/dts-mode.git")
+ (home-page "https://github.com/bgamari/dts-mode")
(synopsis "Emacs minor mode for editing device tree files")
(description
"This package provides an Emacs minor mode for highlighting
@@ -18537,6 +18650,16 @@ files. It focuses on highlighting the document to improve readability.")
(lambda _
(substitute* "Makefile"
(("\\$\\{CASK\\} exec ") ""))
+ #t))
+ ;; Two tests are failing with Emacs 27, as reported here:
+ ;; <https://github.com/racer-rust/emacs-racer/issues/136>. Disable
+ ;; them.
+ (add-before 'check 'fix-failing-tests
+ (lambda _
+ (substitute* "test/racer-test.el"
+ (("`Write`") "Write")
+ (("^\\\\\\[`str\\]:.*") "")
+ ((" \\[`str`\\]") " str"))
#t)))))
(native-inputs
`(("emacs-ert-runner" ,emacs-ert-runner)
@@ -19172,7 +19295,7 @@ scratch, and you think the Spacemacs theme looks good.
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/TheBB/spaceline.git")
+ (url "https://github.com/TheBB/spaceline")
(commit commit)))
(sha256
(base32 "11lwckqcgzsahrkkm5wk1ph4kc7d4yz05r7251g8c9f0q6vdj9dp"))
@@ -19251,7 +19374,7 @@ correctly.")
(define-public emacs-helm-sly
(package
(name "emacs-helm-sly")
- (version "0.4.1")
+ (version "0.5.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -19260,7 +19383,7 @@ correctly.")
(file-name (git-file-name name version))
(sha256
(base32
- "0b2dx9nzh5233lkix3lz81c9cv626lk2hjpcjiikwvyp6y0q92ys"))))
+ "13s2dj09mcdwlibjlahyyq2dxjkjlpxs88dbdyvcd64249jmahsx"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-helm" ,emacs-helm)
@@ -19270,11 +19393,12 @@ correctly.")
(description "Helm-SLY defines a few new commands:
@itemize
-@item helm-sly-list-connections: Yet another Lisp connection list with Helm.
-@item: helm-sly-apropos: Yet another @command{apropos} with Helm.
-@item helm-sly-mini: Like @command{helm-sly-list-connections}, but include an
-extra source of Lisp-related buffers, like the events buffer or the scratch
-buffer.
+@item @code{helm-sly-list-connections}: Yet another Lisp connection list with
+Helm.
+@item @code{helm-sly-apropos}: Yet another @command{apropos} with Helm.
+@item @code{helm-sly-mini}: Like @command{helm-sly-list-connections}, but
+include an extra source of Lisp-related buffers, like the events buffer or the
+scratch buffer.
@end itemize\n")
(license license:gpl3+)))
@@ -19337,10 +19461,10 @@ Emacs.")
(license license:gpl3+)))
(define-public emacs-matrix-client
- (let ((commit "a0623667b07a4bf60980c97b078e9faed97ace79"))
+ (let ((commit "59c792423fd0503f1375f356bec56130e65d3b51"))
(package
(name "emacs-matrix-client")
- (version (git-version "0.0.0" "4" commit))
+ (version (git-version "0.0.0" "5" commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -19349,7 +19473,7 @@ Emacs.")
(file-name (git-file-name name version))
(sha256
(base32
- "1zya8id3y9wzjaj7nplq7br6nhm3lsskv0fkn1xr1y77fzcfgcdb"))))
+ "1gmpw14q9zkvviqpnmvh5vbyxk42038yilxm6b2zqw7mwxfc1xra"))))
(build-system emacs-build-system)
(arguments
`(#:phases
@@ -19765,7 +19889,7 @@ programs can use this table component for the application UI.")
(package
(name "emacs-leetcode")
(version (git-version "0" "1" commit))
- (home-page "https://github.com/ginqi7/leetcode-emacs.git")
+ (home-page "https://github.com/ginqi7/leetcode-emacs")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -20465,20 +20589,20 @@ processes for Emacs")
"0m083g3pg0n4ymi1w0jx34awr7cqbm4r561adij9kklblxsz7sc2"))))
(build-system emacs-build-system)
(propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-s" ,emacs-s)
- ("emacs-f" ,emacs-f)
- ("emacs-ace-window" ,emacs-ace-window)
- ("emacs-pfuture" ,emacs-pfuture)
- ("emacs-hydra" ,emacs-hydra)
- ("emacs-ht" ,emacs-ht)))
+ `(("emacs-ace-window" ,emacs-ace-window)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-ht" ,emacs-ht)
+ ("emacs-hydra" ,emacs-hydra)
+ ("emacs-pfuture" ,emacs-pfuture)
+ ("emacs-s" ,emacs-s)))
(native-inputs
`(("emacs-buttercup" ,emacs-buttercup)
("emacs-el-mock" ,emacs-el-mock)))
(inputs
`(("python" ,python)))
(arguments
- `(#:tests? #t ;TODO: Investigate ‘treemacs--parse-collapsed-dirs’ test failure.
+ `(#:tests? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-makefile
@@ -20493,12 +20617,14 @@ processes for Emacs")
(lambda _
(chdir "src/elisp")))
(replace 'check
+ ;; FIXME: Work around ‘treemacs--parse-collapsed-dirs’ and
+ ;; `treemacs-collect-child-nodes' test failures.
(lambda _
(with-directory-excursion "../.." ;treemacs root
(chmod "test/test-treemacs.el" #o644)
(emacs-substitute-sexps "test/test-treemacs.el"
- ("(describe \"treemacs--parse-collapsed-dirs\""
- ""))
+ ("(describe \"treemacs--parse-collapsed-dirs\"" "")
+ ("\"Finds only direct childre\"" ""))
(invoke "make" "test"))))
(add-before 'install 'patch-paths
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -20530,7 +20656,12 @@ processes for Emacs")
#t)))))))
(home-page "https://github.com/Alexander-Miller/treemacs")
(synopsis "Emacs tree style file explorer")
- (description "Powerful and flexible file tree project explorer.")
+ (description
+ "Treemacs is a file and project explorer similar to NeoTree or Vim's
+NerdTree, but largely inspired by the Project Explorer in Eclipse. It shows
+the file system outlines of your projects in a simple tree layout allowing
+quick navigation and exploration, while also possessing basic file management
+utilities.")
(license license:gpl3+)))
(define-public emacs-treemacs-extra
@@ -21593,8 +21724,8 @@ and searching through @code{Ctags} files.")
(license license:expat))))
(define-public emacs-org-download
- (let ((commit "10c9d7c8eed928c88a896310c882e3af4d8d0f61")
- (revision "2"))
+ (let ((commit "42ac361ef5502017e6fc1bceb00333eba90402f4")
+ (revision "3"))
(package
(name "emacs-org-download")
(version (git-version "0.1.0" revision commit))
@@ -21603,10 +21734,9 @@ and searching through @code{Ctags} files.")
(uri (git-reference
(url "https://github.com/abo-abo/org-download")
(commit commit)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0i8wlx1i7y1vn5lqwjifvymvszg28a07vwqcm4jslf1v2ajs1lsl"))
- (file-name (git-file-name name version))))
+ (base32 "0cg4y7hy7xbq4vrbdicfzgvyaf3cjbx2zkqd4yl0y2garz71j99l"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-org" ,emacs-org)
@@ -22025,7 +22155,7 @@ and article extracts for Wikipedia.")
(define-public emacs-webfeeder
(package
(name "emacs-webfeeder")
- (version "1.0.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -22035,7 +22165,7 @@ and article extracts for Wikipedia.")
".tar"))
(sha256
(base32
- "06y5vxw9m6pmbrzb8v2i3w9dnhgqxz06vyx1knmgi9cczlrj4a64"))))
+ "09wz6v58xc86hdnz6g54ckaxkm6844yyk2ffbxh4s5sdvgqrzdd8"))))
(build-system emacs-build-system)
(home-page "https://gitlab.com/Ambrevar/emacs-webfeeder")
(synopsis "Build RSS and Atom webfeeds from HTML files")
@@ -23441,6 +23571,29 @@ internal windowing system. This combines particularly well with tiling window
managers such as XMonad.")
(license license:gpl3+)))
+(define-public emacs-modalka
+ (package
+ (name "emacs-modalka")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrkkrp/modalka")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ggj8q92sb6wp3hs1vhpmy56id0p3i9zwnw24g2v7xa7w8ac9s7l"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mrkkrp/modalka")
+ (synopsis "Minor mode to easily define native custom modal editing")
+ (description
+ "This is a building kit to help switch to modal editing in Emacs. The
+main goal of the package is to make modal editing in Emacs as natural and
+native as possible. Modalka lets you define your own keys and does not come
+with a preconfigured set of keys.")
+ (license license:gpl3+)))
+
(define-public emacs-shrink-path
(package
(name "emacs-shrink-path")
@@ -24290,7 +24443,7 @@ launching other commands/applications from within Emacs, similar to the
(define-public emacs-no-littering
(package
(name "emacs-no-littering")
- (version "1.0.3")
+ (version "1.2.0")
(source
(origin
(method git-fetch)
@@ -24299,7 +24452,7 @@ launching other commands/applications from within Emacs, similar to the
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "17is06l0w6glppabv2kaclrnqi3dqb6p6alpslpg7lrjd8vd45ir"))))
+ (base32 "1hma9var0nmrmjlh16s49hbfc1s4jvfd2prqxf14lxfd51404niw"))))
(build-system emacs-build-system)
(home-page "https://github.com/emacscollective/no-littering")
(synopsis "Help keep ~/.emacs.d/ clean")
@@ -24766,7 +24919,7 @@ personal wiki.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/conao3/org-generate.el.git")
+ (url "https://github.com/conao3/org-generate.el")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -25281,3 +25434,100 @@ the TypeScript implementation.")
(description "This package provides an Emacs client for the Rocket.chat
service.")
(license license:expat))))
+
+(define-public emacs-monokai-theme
+ (package
+ (name "emacs-monokai-theme")
+ (version "3.5.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oneKelvinSmith/monokai-emacs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dy8c3349j7fmp8052hbgvk0b7ldlv5jqpg0paq1i0hlypivd30i"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/oneKelvinSmith/monokai-emacs")
+ (synopsis "High contrast color theme for Emacs")
+ (description
+ "Monokai theme is a port of the popular TextMate Monokai theme for
+Emacs.")
+ (license license:gpl3+)))
+
+(define-public emacs-nord-theme
+ (package
+ (name "emacs-nord-theme")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arcticicestudio/nord-emacs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "096f8cik4jz89bvkifwp3gm9iraqrd75ljy2q9js724v7yj88711"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.nordtheme.com/")
+ (synopsis "Low contrast arctic color theme for Emacs")
+ (description
+ "Nord is an arctic, north-bluish color scheme created for a clean and
+uncluttered design pattern to achieve optimal focus and readability for code
+syntax highlighting and UI components.")
+ (license license:expat)))
+
+(define-public emacs-janet-mode
+ (let ((commit "2f5bcabcb6953e1ed1926ba6a2328c453e8b4ac7"))
+ (package
+ (name "emacs-janet-mode")
+ (version (git-version "0.1.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ALSchwalm/janet-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qj0gpycv2f3z1dgz1a27bjn983hrr3ppvrp7csl34lagnmp89rz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ALSchwalm/janet-mode")
+ (synopsis "Emacs major mode for the Janet programming language")
+ (description
+ "This package provides an Emacs major mode for editing Janet files.")
+ (license license:gpl3))))
+
+(define-public emacs-inf-janet
+ (let ((commit "df46651d3aad32593b2195c80ca91fb64d571fb7"))
+ (package
+ (name "emacs-inf-janet")
+ (version (git-version "0.1.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/velkyel/inf-janet")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0g0y7q62667j0p32md1h6zb2cap9fga9qgdg7138xwjqnk0328v7"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("janet-mode" ,emacs-janet-mode)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-program-name
+ (lambda _
+ (make-file-writable "inf-janet.el")
+ (emacs-substitute-variables "inf-janet.el"
+ ("inf-janet-program" "janet"))
+ #t)))))
+ (home-page "https://github.com/velkyel/inf-janet")
+ (synopsis "Run an external Janet process in an Emacs buffer")
+ (description
+ "This Emacs package provides a Janet REPL to evaluate @code{janet-mode}
+s-expression.")
+ (license license:expat))))