summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm55
1 files changed, 37 insertions, 18 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index fd1784a7e9..7ff56892e7 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -2,13 +2,13 @@
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018, 2019, 2020, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
@@ -86,19 +86,38 @@
(define-public freetype
(package
(name "freetype")
- (version "2.10.4")
+ (version "2.13.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://savannah/freetype/freetype-"
version ".tar.xz"))
(sha256
- (base32 "112pyy215chg7f7fmp2l9374chhhpihbh8wgpj5nj6avj3c59a46"))))
+ (base32 "0k32jaaz4pfhw34xwr6a38fncrpwr9fn5ij35m5w4dkn0jykmqjy"))))
(build-system gnu-build-system)
(arguments
;; The use of "freetype-config" is deprecated, but other packages still
;; depend on it.
- `(#:configure-flags (list "--enable-freetype-config")))
+ `(#:configure-flags (list "--enable-freetype-config")
+ #:disallowed-references (,pkg-config)
+ #:phases
+ ;; TODO: Keep only the first variant on the next core rebuild cycle.
+ ,(if (%current-target-system)
+ '(modify-phases %standard-phases
+ (add-after 'install 'remove-reference-to-pkg-config
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/bin/freetype-config")
+ (("/([a-zA-Z0-9/\\._-]+)/bin/([a-zA-Z0-9_-]+)pkg-config"
+ _ store target)
+ "pkg-config"))))))
+ '(modify-phases %standard-phases
+ (add-after 'install 'remove-reference-to-pkg-config
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/bin/freetype-config")
+ (((search-input-file inputs "/bin/pkg-config"))
+ "pkg-config")))))))))
(native-inputs
(list pkg-config))
(propagated-inputs
@@ -113,7 +132,7 @@ It supports both bitmap and scalable formats, including TrueType, OpenType,
Type1, CID, CFF, Windows FON/FNT, X11 PCF, and others. It supports high-speed
anti-aliased glyph bitmap generation with 256 gray levels.")
(license license:freetype) ; some files have other licenses
- (home-page "https://www.freetype.org/")))
+ (home-page "https://freetype.org/")))
(define-public opentype-sanitizer
(package
@@ -259,7 +278,7 @@ them as it goes.")
python-booleanoperations
python-defcon
python-fontmath
- python-fonttools-next
+ python-fonttools
python-lxml
python-tqdm
python-ufonormalizer
@@ -453,7 +472,7 @@ converts any cubic curves to quadratic. The most useful function is probably
python-compreffor
python-cu2qu
python-defcon
- python-fonttools-next
+ python-fonttools
python-skia-pathops
python-ufolib2))
(home-page "https://github.com/googlefonts/ufo2ft")
@@ -599,7 +618,7 @@ process. FontParts is the successor of RoboFab.")
python-xmldiff))
(propagated-inputs
(list python-defcon
- python-fonttools-next
+ python-fonttools
python-openstep-plist
python-ufolib2
python-ufo2ft
@@ -756,7 +775,7 @@ suite of the @code{psautohint} package.")
"tests/integration/data")
(for-each make-file-writable
(find-files "tests/integration/data")))))))
- (propagated-inputs (list python-fonttools-next))
+ (inputs (list python-fonttools))
(native-inputs
(list psautohint-font-data
python-fs
@@ -1119,14 +1138,14 @@ Font Format (WOFF).")
(hidden-package
(package
(name "fontconfig-minimal")
- (version "2.13.94")
+ (version "2.14.0")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.freedesktop.org/software/"
"fontconfig/release/fontconfig-" version ".tar.xz"))
(sha256 (base32
- "0g004r0bkkqz00mpm3svnnxn7d83158q0yb9ggxryizxfg5m5w55"))
+ "1b4v1r94ri44p4a3kbwd38ig5jgdgcfgwdfm6fqzvfvlki6bignw"))
(patches (search-patches "fontconfig-cache-ignore-mtime.patch"))))
(build-system gnu-build-system)
;; In Requires or Requires.private of fontconfig.pc.
@@ -1439,14 +1458,14 @@ definitions.")
(define-public fontforge
(package
(name "fontforge")
- (version "20201107")
+ (version "20220308")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/fontforge/fontforge/releases/download/"
version "/fontforge-" version ".tar.xz"))
(sha256
- (base32 "0y3c8x1i6yf6ak9m5dhr1nldgfmg7zhnwdfd57ffs698c27vmg38"))))
+ (base32 "0ncfc4ajwy4ng6b6h79w52jh9z3lngvf3f3ldi1wzkhcg9zh3r01"))))
(build-system cmake-build-system)
(native-inputs
(list pkg-config))
@@ -1464,7 +1483,6 @@ definitions.")
("libspiro" ,libspiro)
("libtiff" ,libtiff)
("libungif" ,libungif)
- ("libuninameslist" ,libuninameslist)
("libxft" ,libxft)
("libxml2" ,libxml2)
("pango" ,pango)
@@ -1533,8 +1551,9 @@ generate bitmaps.")
`(modify-phases ,phases
(delete 'do-not-override-RPATH)))))
(inputs
- `(("python" ,python-2)
- ,@(alist-delete "python" (package-inputs fontforge))))))
+ (modify-inputs (package-inputs fontforge)
+ (prepend libuninameslist)
+ (replace "python" python-2)))))
(define-public python-statmake
(package
@@ -1578,7 +1597,7 @@ generate bitmaps.")
(propagated-inputs
(list python-attrs
python-cattrs
- python-fonttools-next))
+ python-fonttools))
(home-page "https://github.com/daltonmaag/statmake")
(synopsis "Apply OpenType STAT information to a variable font")
(description