summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index b2b3b63672..acce5f8f82 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -65,40 +65,39 @@
#:use-module (gnu packages libusb))
(define-public abc
- (let ((commit "5ae4b975c49c")
- (revision "1"))
+ (let ((commit "70cb339f869e")
+ (revision "2"))
(package
(name "abc")
(version (git-version "0.0" revision commit))
(source (origin
- (method url-fetch)
- (uri
- (string-append "https://bitbucket.org/alanmi/abc/get/" commit ".zip"))
- (file-name (string-append name "-" version "-checkout.zip"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/berkeley-abc/abc")
+ (commit commit)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1syygi1x40rdryih3galr4q8yg1w5bvdzl75hd27v1xq0l5bz3d0"))))
+ "1ngxg4jvz8vwm74sbidysgz3v5lrzjcabkqj4nhcksi6hnhyc9m8"))))
(build-system gnu-build-system)
- (native-inputs
- (list unzip))
(inputs
(list readline))
(arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (out-bin (string-append out "/bin")))
- (install-file "abc" out-bin)))))))
+ (list #:license-file-regexp "copyright.txt"
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "abc" (string-append #$output "/bin")))))))
(home-page "https://people.eecs.berkeley.edu/~alanmi/abc/")
(synopsis "Sequential logic synthesis and formal verification")
(description "ABC is a program for sequential logic synthesis and
formal verification.")
(license
- (license:non-copyleft "https://fedoraproject.org/wiki/Licensing:MIT#Modern_Variants")))))
+ (license:non-copyleft
+ "https://people.eecs.berkeley.edu/~alanmi/abc/copyright.htm")))))
(define-public iverilog
(package