summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm117
1 files changed, 88 insertions, 29 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 43b681d85d..f05aafa531 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2840,16 +2840,16 @@ database is translated at Transifex.")
(define-public system-config-printer
(package
(name "system-config-printer")
- (version "1.5.12")
+ (version "1.5.13")
(source
(origin
(method url-fetch)
(uri (string-append
"https://github.com/OpenPrinting/system-config-printer/releases/"
- "download/" version
+ "download/v" version
"/system-config-printer-" version ".tar.xz"))
(sha256
- (base32 "050yrx1vfh9f001qsn06y1jcidxq0ymxr64kxykasr0zzryp25kb"))))
+ (base32 "18dqvi1s971lggkw6pv1sqxixlpg5a8rppzc1pxbanxa91jg18zf"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:imported-modules ((guix build python-build-system)
@@ -4279,10 +4279,10 @@ requirements and without using a different ABI compared to applications and
libraries written in C.")
(license license:lgpl2.1+)))
-(define-public vala-0.48
+(define-public vala-0.50
(package
(inherit vala)
- (version "0.48.9")
+ (version "0.50.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/vala/"
@@ -4290,7 +4290,7 @@ libraries written in C.")
"vala-" version ".tar.xz"))
(sha256
(base32
- "1agyrvslv2yh9ikiw7k5nw6j6il1l2zrzfan0pzdpb9xpg9idslw"))))))
+ "0v4g2gvn7x7cl33h8sj1y2xyyskw5ayaj4jm2jrd3my3r439z3cm"))))))
(define-public vte
(package
@@ -6001,7 +6001,7 @@ discovery protocols.")
(define-public totem
(package
(name "totem")
- (version "3.34.1")
+ (version "3.38.0")
(source
(origin
(method url-fetch)
@@ -6010,14 +6010,14 @@ discovery protocols.")
"totem-" version ".tar.xz"))
(sha256
(base32
- "028sc6xbyi7rs884862d8f3di6zhcm0lhvlpc3r69ifzjsq9my3b"))))
+ "0bs33ijvxbr2prb9yj4dxglsszslsn9k258n311sld84masz4ad8"))))
(build-system meson-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
("gobject-introspection" ,gobject-introspection)
("glib:bin" ,glib "bin") ;for 'glib-mkenums'
- ("intltool" ,intltool)
("itstool" ,itstool)
("xmllint" ,libxml2)
("xorg-server" ,xorg-server-for-tests)))
@@ -6835,7 +6835,7 @@ metadata in photo and video files of various formats.")
(define-public shotwell
(package
(name "shotwell")
- (version "0.30.9")
+ (version "0.30.11")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/shotwell/"
@@ -6843,7 +6843,7 @@ metadata in photo and video files of various formats.")
"shotwell-" version ".tar.xz"))
(sha256
(base32
- "1y556yyzfya0310v5wqjkf17hy5lhf028iminvvgi2pdfva344id"))))
+ "12d26y40kjlv5x8f5g04wff33vh7mdjb8c41ydqbrwdip0jwy2n2"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -9538,19 +9538,21 @@ functionality and behavior.")
(define-public arc-theme
(package
(name "arc-theme")
- (version "20190917")
+ (version "20201013")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/NicoHood/arc-theme")
+ (url "https://github.com/jnsh/arc-theme")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "1qgpk4p2hi5hd4yy0hj93kq1vs0b32wb8qkaj1wi90c8gwddq5wa"))))
+ "1x2l1mwjx68dwf3jb1i90c1q8nqsl1wf2zggcn8im6590k5yv39s"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ '(#:configure-flags
+ (list "--disable-cinnamon")
+ #:phases
(modify-phases %standard-phases
;; autogen.sh calls configure at the end of the script.
(replace 'bootstrap
@@ -9967,14 +9969,14 @@ only know by its Unicode name or code point.")
(define-public bluefish
(package
(name "bluefish")
- (version "2.2.11")
+ (version "2.2.12")
(source
(origin
(method url-fetch)
- (uri (string-append "http://www.bennewitz.com/bluefish/stable/source/"
+ (uri (string-append "https://www.bennewitz.com/bluefish/stable/source/"
"bluefish-" version ".tar.gz"))
(sha256
- (base32 "0a7kf78q4cj2ap4igjks9kbmmr74brsrl4y2f9wbxpl0b0v2ck2x"))))
+ (base32 "09hgxq139kbkjda5y073lqhq1z1x7cx0j80jh77afrqa3y9c53wl"))))
(build-system gnu-build-system)
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)
@@ -9989,7 +9991,7 @@ only know by its Unicode name or code point.")
(home-page "http://bluefish.openoffice.nl")
(synopsis "Web development studio")
(description
- "Bluefish is an editor targeted towards programmers and web developers,
+ "Bluefish is an editor aimed at programmers and web developers,
with many options to write web sites, scripts and other code.
Bluefish supports many programming and markup languages.")
(license license:gpl3+)))
@@ -10875,7 +10877,7 @@ advanced image management tool")
(define-public libhandy
(package
(name "libhandy")
- (version "1.0.0")
+ (version "1.0.2")
(source
(origin
(method git-fetch)
@@ -10884,7 +10886,7 @@ advanced image management tool")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "193y09yy0302x8fkyrnq591m805xp68bkd93fl5qggxi52k8pj0v"))))
+ (base32 "1bmmkahshvlvpsnb7zp8bddv7i1h5k4p967n6kxh71g1vnj8x20m"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -10913,7 +10915,7 @@ advanced image management tool")
;; Test suite dependencies.
("xorg-server" ,xorg-server-for-tests)
("hicolor-icon-theme" ,hicolor-icon-theme)))
- (home-page "https://source.puri.sm/Librem5/libhandy")
+ (home-page "https://gitlab.gnome.org/GNOME/libhandy/")
(synopsis "Library full of GTK+ widgets for mobile phones")
(description "The aim of the handy library is to help with developing user
interfaces for mobile devices using GTK+. It provides responsive GTK+ widgets
@@ -11465,6 +11467,62 @@ symbol tables, document templates, project management, spell-checking, menus
and toolbars.")
(license license:gpl3+)))
+(define-public setzer
+ (package
+ (name "setzer")
+ (version "0.3.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cvfosammmm/Setzer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "118gip6bv4mcsq4nrai7kl0vmqqbyzpsd4ky9vhxb1x2cvg048s8"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/setzer"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")))
+ (inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell)
+ ("gtk+" ,gtk+)
+ ("gtksourceview" ,gtksourceview)
+ ("pango" ,pango)
+ ("poppler" ,poppler)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pygobject" ,python-pygobject)
+ ("python-pyxdg" ,python-pyxdg)
+ ("webkitgtk" ,webkitgtk)
+ ("xdg-utils" ,xdg-utils)))
+ (home-page "https://www.cvfosammmm.org/setzer/")
+ (synopsis "LaTeX editor written in Python with GTK+")
+ (description
+ "Setzer is a simple yet full-featured LaTeX editor written in Python with
+GTK+. It integrates well with the GNOME desktop environment.")
+ (license license:gpl3+)))
+
(define-public libratbag
(package
(name "libratbag")
@@ -11604,7 +11662,7 @@ provided there is a DBus service present:
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/gkarsay/parlatype.git")
+ (url "https://github.com/gkarsay/parlatype")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -11843,7 +11901,7 @@ integrated profiler via Sysprof, debugging support, and more.")
(define-public komikku
(package
(name "komikku")
- (version "0.21.1")
+ (version "0.23.0")
(source
(origin
(method git-fetch)
@@ -11853,7 +11911,7 @@ integrated profiler via Sysprof, debugging support, and more.")
(file-name (git-file-name name version))
(sha256
(base32
- "17ss5k2hnymk6xyx1dy3q0y2pwcld78cw7d0cs9c0hnhskh5dirh"))))
+ "1xh3qmf2pk80qxj528lajjcwg7mps72s1zz8cj388av58p8l3hyw"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -11910,17 +11968,17 @@ developed with the aim of being used with the Librem 5 phone.")
(define-public libgda
(package
(name "libgda")
- (version "5.2.9")
+ (version "5.2.10")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.gnome.org/GNOME/libgda.git/")
- (commit "LIBGDA_5_2_9")))
+ (commit (string-append "LIBGDA_" (string-replace-substring
+ version "." "_")))))
(file-name (git-file-name name version))
(sha256
- (base32
- "122anbk15vj2dfxrw7s48b6zwlpp7cyppshxizynvf3zmc0ygw3j"))))
+ (base32 "18rg773gq9v3cdywpmrp12c5xyp97ir9yqjinccpi22sksb1kl8a"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--enable-vala")
@@ -11965,6 +12023,7 @@ developed with the aim of being used with the Librem 5 phone.")
("vala" ,vala)))
(native-inputs
`(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
("automake" ,automake)
("glib:bin" ,glib "bin")
("gnome-common" ,gnome-common)