summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 9 insertions, 18 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 55fbe583ef..2456434d62 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4769,8 +4769,7 @@ indicators etc).")
(search-patch
"glib-networking-32-bit-time.patch")))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("gettext" ,gettext-minimal)))
+ (list pkg-config gettext-minimal))
(inputs
(list glib gnutls gsettings-desktop-schemas libproxy))
(home-page "https://wiki.gnome.org/Projects/GLib")
@@ -4802,14 +4801,10 @@ from the GSettings schemas in gsettings-desktop-schemas.")
#:configure-flags
'("--with-ca-certificates=/etc/ssl/certs/ca-certificates.crt")))
(native-inputs
- `(("glib-mkenums" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)))
+ (list `(,glib "bin") gobject-introspection pkg-config))
(propagated-inputs
;; rest-0.7.pc refers to all these.
- `(("glib" ,glib)
- ("libsoup" ,libsoup-minimal-2)
- ("libxml2" ,libxml2)))
+ (list glib libsoup-minimal-2 libxml2))
(home-page "https://www.gtk.org/")
(synopsis "RESTful web api query library")
(description
@@ -4855,7 +4850,6 @@ libxml to ease remote use of the RESTful API.")
(native-inputs
(list `(,glib "bin") ;for glib-mkenums
gobject-introspection
- intltool
pkg-config
python-wrapper
vala
@@ -6863,16 +6857,13 @@ of running programs and invoke methods on those interfaces.")
(base32 "19d46rkajvr0f04560vlrzwvac88x5j8ilvzwkawbn5vjg069kf8"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- (list
- "--enable-doc")))
+ '(#:configure-flags '("--enable-doc")))
(native-inputs
- `(("ducktype" ,mallard-ducktype)
- ("gettext" ,gettext-minimal)
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("xmllint" ,libxml2)
- ("xsltproc" ,libxslt)))
+ (list mallard-ducktype
+ gettext-minimal
+ itstool
+ libxml2
+ libxslt))
(synopsis "XSL stylesheets for Yelp")
(description "Yelp-XSL is a collection of programs and data files to help
you build, maintain, and distribute documentation. It provides XSLT stylesheets