summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm457
1 files changed, 182 insertions, 275 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fbb0dc1206..d163b68035 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -370,9 +370,7 @@ features to enable users to create their discs easily and quickly.")
"-Denable-gtk-doc=false"
"-Dvapigen=false")))
(native-inputs
- `(("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)))
+ (list `(,glib "bin") pkg-config vala))
(inputs
(list glib glib-networking))
(synopsis "Cloudproviders Integration API")
@@ -1057,7 +1055,7 @@ between different kinds of computer systems.")
(list amtk
glib
gtk+
- gtksourceview
+ gtksourceview-4
libxml2
uchardet))
(synopsis "Text editor product line")
@@ -1143,7 +1141,10 @@ freedesktop.org desktop notification specification.")
"mm-common-" version ".tar.xz"))
(sha256
(base32
- "1x8yvjy0yg17qyhmqws8xh2k8dvzrhpwqz7j1cfwzalrb1i9c5g8"))))
+ "1x8yvjy0yg17qyhmqws8xh2k8dvzrhpwqz7j1cfwzalrb1i9c5g8"))
+ (patches
+ (search-patches
+ "mm-common-reproducible-tarball.patch"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -1623,7 +1624,7 @@ sharing to the masses.")
gjs
gst-plugins-base
gstreamer
- gtksourceview
+ gtksourceview-4
harfbuzz
libepoxy
libmusicbrainz
@@ -2387,7 +2388,7 @@ GNOME Desktop.")
(define-public gdl
(package
(name "gdl")
- (version "3.34.0")
+ (version "3.40.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2399,7 +2400,7 @@ GNOME Desktop.")
(file-name (git-file-name name version))
(sha256
(base32
- "154qcr0x6f68f4q526y87imv0rscmp34n47nk1pp82rsq52h2zna"))))
+ "11hp93gqk7m64h84q5hndzlwj4w6hl0cbmzrk2pkdn04ikm2zj4v"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
@@ -2601,7 +2602,7 @@ on the GNOME Desktop with a single simple application.")
(define-public gsettings-desktop-schemas
(package
(name "gsettings-desktop-schemas")
- (version "41.0")
+ (version "42.0")
(source
(origin
(method url-fetch)
@@ -2610,7 +2611,7 @@ on the GNOME Desktop with a single simple application.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1v9jagk679m01nji0acirynxinziv036618c7xc49l4nwmr9ja3p"))))
+ "1li3fcqwnw20f4j0i21i88fygm0hli8gmzkn4apgf8ynkrd371k6"))))
(build-system meson-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -3410,7 +3411,7 @@ for dealing with different structured file formats.")
(define-public librsvg
(package
(name "librsvg")
- (version "2.50.7")
+ (version "2.54.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/librsvg/"
@@ -3418,7 +3419,7 @@ for dealing with different structured file formats.")
"librsvg-" version ".tar.xz"))
(sha256
(base32
- "1g3f8byg5w08fx1bka12mmpl59v6a4q2p827w6m2la6mijq63yzz"))
+ "0cs8qbn2khibb5w1r0f6cibfmkfb7zg713526vhc0hva7wj2l5ga"))
(modules '((guix build utils)))
(snippet
'(begin (delete-file-recursively "vendor")))))
@@ -3431,61 +3432,57 @@ for dealing with different structured file formats.")
(guix build utils)
((guix build gnu-build-system) #:prefix gnu:))
#:cargo-inputs
- (("rust-bitflags" ,rust-bitflags-1)
- ("rust-cairo-rs" ,rust-cairo-rs-0.8)
- ("rust-cairo-sys-rs" ,rust-cairo-sys-rs-0.9)
- ("rust-cast" ,rust-cast-0.2)
- ("rust-cssparser" ,rust-cssparser-0.27)
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-cairo-rs" ,rust-cairo-rs-0.15)
+ ("rust-cast" ,rust-cast-0.3)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-cssparser" ,rust-cssparser-0.28)
("rust-data-url" ,rust-data-url-0.1)
("rust-encoding" ,rust-encoding-0.2)
- ("rust-float-cmp" ,rust-float-cmp-0.8)
- ("rust-gdk-pixbuf" ,rust-gdk-pixbuf-0.8)
- ("rust-gdk-pixbuf-sys" ,rust-gdk-pixbuf-sys-0.9)
- ("rust-gio" ,rust-gio-0.8)
- ("rust-gio-sys" ,rust-gio-sys-0.9)
- ("rust-glib" ,rust-glib-0.9)
- ("rust-glib-sys" ,rust-glib-sys-0.9)
- ("rust-gobject-sys" ,rust-gobject-sys-0.9)
- ("rust-itertools" ,rust-itertools-0.9)
- ("rust-language-tags" ,rust-language-tags-0.2)
+ ("rust-float-cmp" ,rust-float-cmp-0.9)
+ ("rust-gdk-pixbuf" ,rust-gdk-pixbuf-0.15)
+ ("rust-gio" ,rust-gio-0.15)
+ ("rust-glib" ,rust-glib-0.15)
+ ("rust-itertools" ,rust-itertools-0.10)
+ ("rust-language-tags" ,rust-language-tags-0.3)
("rust-libc" ,rust-libc-0.2)
("rust-locale-config" ,rust-locale-config-0.3)
("rust-markup5ever" ,rust-markup5ever-0.10)
- ("rust-nalgebra" ,rust-nalgebra-0.21)
+ ("rust-nalgebra" ,rust-nalgebra-0.29)
("rust-num-traits" ,rust-num-traits-0.2)
("rust-once-cell" ,rust-once-cell-1)
- ("rust-pkg-config" ,rust-pkg-config-0.3)
- ("rust-pango" ,rust-pango-0.8)
- ("rust-pango-sys" ,rust-pango-sys-0.9)
- ("rust-pangocairo" ,rust-pangocairo-0.9)
+ ("rust-pango" ,rust-pango-0.15)
+ ("rust-pangocairo" ,rust-pangocairo-0.15)
("rust-rayon" ,rust-rayon-1)
- ("rust-rctree" ,rust-rctree-0.3)
+ ("rust-rctree" ,rust-rctree-0.4)
("rust-rgb" ,rust-rgb-0.8)
("rust-regex" ,rust-regex-1)
- ("rust-selectors" ,rust-selectors-0.22)
+ ("rust-selectors" ,rust-selectors-0.23)
("rust-string-cache" ,rust-string-cache-0.8)
- ("rust-tinyvec" ,rust-tinyvec-0.3)
+ ("rust-tinyvec" ,rust-tinyvec-1)
("rust-url" ,rust-url-2)
("rust-xml5ever" ,rust-xml5ever-0.16))
#:cargo-development-inputs
- (("rust-assert-cmd" ,rust-assert-cmd-1)
- ("rust-cairo-rs" ,rust-cairo-rs-0.8)
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-assert-cmd" ,rust-assert-cmd-2)
+ ("rust-cairo-rs" ,rust-cairo-rs-0.15)
("rust-chrono" ,rust-chrono-0.4)
("rust-criterion" ,rust-criterion-0.3)
- ("rust-float-cmp" ,rust-float-cmp-0.8)
+ ("rust-glib" ,rust-glib-0.15)
+ ("rust-libc" ,rust-libc-0.2)
("rust-lopdf" ,rust-lopdf-0.26)
- ("rust-png" ,rust-png-0.16)
- ("rust-predicates" ,rust-predicates-1)
- ("rust-tempfile" ,rust-tempfile-3))
+ ("rust-matches" ,rust-matches-0.1)
+ ("rust-png" ,rust-png-0.17)
+ ("rust-predicates" ,rust-predicates-2)
+ ("rust-proptest" ,rust-proptest-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-test-generator" ,rust-test-generator-0.3)
+ ("rust-yeslogic-fontconfig-sys" ,rust-yeslogic-fontconfig-sys-2))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-docbook-xml
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "doc"
- (substitute* "rsvg-docs.xml"
- (("http://www.oasis-open.org/docbook/xml/4.3/")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/"))))))
(add-after 'unpack 'prepare-for-build
(lambda _
;; In lieu of #:make-flags
@@ -3526,30 +3523,6 @@ for dealing with different structured file formats.")
(string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))))
(replace 'build
(assoc-ref gnu:%standard-phases 'build))
- (add-before 'check 'ignore-failing-tests
- ;; stderr=```/tmp/guix-build-.../librsvg-2.50.1/rsvg-convert: line 150: ls: command not found
- (lambda _
- (substitute* "tests/src/cmdline/rsvg_convert.rs"
- (("fn background_color_option_invalid_color_yields_error" all)
- (string-append "#[ignore] " all))
- (("fn empty_input_yields_error" all)
- (string-append "#[ignore] " all))
- (("fn empty_svg_yields_error" all)
- (string-append "#[ignore] " all))
- (("fn env_source_data_epoch_empty" all)
- (string-append "#[ignore] " all))
- (("fn env_source_data_epoch_no_digits" all)
- (string-append "#[ignore] " all))
- (("fn env_source_data_epoch_trailing_garbage" all)
- (string-append "#[ignore] " all))
- (("fn export_id_option_error" all)
- (string-append "#[ignore] " all))
- (("fn huge_zoom_factor_yields_error" all)
- (string-append "#[ignore] " all))
- (("fn multiple_input_files_not_allowed_for_png_output" all)
- (string-append "#[ignore] " all))
- (("fn stylesheet_option_error" all)
- (string-append "#[ignore] " all)))))
(replace 'check
(lambda* args
((assoc-ref gnu:%standard-phases 'check)
@@ -3557,8 +3530,7 @@ for dealing with different structured file formats.")
(replace 'install
(assoc-ref gnu:%standard-phases 'install)))))
(native-inputs
- (list docbook-xml-4.3
- `(,glib "bin")
+ (list `(,glib "bin")
gobject-introspection
pkg-config
vala))
@@ -3574,34 +3546,6 @@ diagrams.")
(home-page "https://wiki.gnome.org/LibRsvg")
(license license:lgpl2.1+)))
-;; This copy of librsvg uses the bundled rust libraries. It is useful for
-;; packages which have too many dependencies to be rebuilt as frequently
-;; as the rust inputs are updated.
-;; TODO: Remove this package and use packaged rust libraries!
-(define-public librsvg-bootstrap
- (package
- (inherit librsvg)
- (name "librsvg")
- (version "2.50.7")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/librsvg/"
- (version-major+minor version) "/"
- "librsvg-" version ".tar.xz"))
- (sha256
- (base32
- "1g3f8byg5w08fx1bka12mmpl59v6a4q2p827w6m2la6mijq63yzz"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each delete-file (find-files "vendor" "\\.a$"))))))
- (arguments
- (substitute-keyword-arguments (package-arguments librsvg)
- ((#:vendor-dir _ "vendor") "vendor")
- ((#:cargo-inputs _) '())
- ((#:cargo-development-inputs _) '())))
- (properties '((hidden? . #t)))))
-
(define-public librsvg-2.40
;; This is the last version implemented in C.
(package
@@ -4391,60 +4335,6 @@ passwords in the GNOME keyring.")
(define-public vala
(package
(name "vala")
- (version "0.54.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/vala/"
- (version-major+minor version) "/"
- "vala-" version ".tar.xz"))
- (sha256
- (base32
- "048k5c6c6y7jyb961krnrb7m0kghr0yrkpnfx3j5ckbx652yfkc8"))))
- (build-system glib-or-gtk-build-system)
- (arguments
- '(#:configure-flags '("--enable-coverage")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-docbook-xml
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "doc/manual"
- (substitute* '("manual.xml" "version.xml.in")
- (("http://www.oasis-open.org/docbook/xml/4.4/")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/"))))))
- (add-before 'check 'pre-check
- (lambda _
- (setenv "CC" "gcc")
- (substitute* "valadoc/tests/libvaladoc\
-/tests-extra-environment.sh"
- (("export PKG_CONFIG_PATH=" m)
- (string-append m "$PKG_CONFIG_PATH:"))))))))
- (native-inputs
- `(("bison" ,bison)
- ("dbus" ,dbus) ; for dbus tests
- ("docbook-xml" ,docbook-xml-4.4)
- ("docbook-xsl" ,docbook-xsl)
- ("flex" ,flex)
- ("gobject-introspection" ,gobject-introspection) ; for gir tests
- ("help2man" ,help2man)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("xsltproc" ,libxslt)))
- (propagated-inputs
- `(("glib" ,glib) ; required by libvala-0.40.pc
- ("libgvc" ,graphviz)))
- (home-page "https://wiki.gnome.org/Projects/Vala/")
- (synopsis "Compiler using the GObject type system")
- (description "Vala is a programming language using modern high level
-abstractions without imposing additional runtime requirements and without using
-a different ABI compared to applications and libraries written in C. Vala uses
-the GObject type system and has additional code generation routines that make
-targeting the GNOME stack simple.")
- (license license:lgpl2.1+)))
-
-(define-public vala-next
- (package
- (inherit vala)
(version "0.56.2")
(source (origin
(method url-fetch)
@@ -4454,6 +4344,7 @@ targeting the GNOME stack simple.")
(sha256
(base32
"0k0jj3xwjq222x0hbqqy5bykhgk1f1wsb85bqcdgsnbqn6dn3jb6"))))
+ (build-system glib-or-gtk-build-system)
(arguments
(list
#:configure-flags #~(list "CC=gcc" "--enable-coverage")
@@ -4478,7 +4369,29 @@ targeting the GNOME stack simple.")
;; Wrapping the binaries breaks vala's behavior adaptations based on
;; the file name of the program executed (vala: compile and execute,
;; valac: compile into a binary).
- (delete 'glib-or-gtk-wrap))))))
+ (delete 'glib-or-gtk-wrap))))
+ (native-inputs
+ (list bison
+ dbus ; for dbus tests
+ docbook-xml-4.4
+ docbook-xsl
+ flex
+ gobject-introspection ; for gir tests
+ help2man
+ perl
+ pkg-config
+ libxslt))
+ (propagated-inputs
+ (list glib ; required by libvala-0.40.pc
+ graphviz))
+ (home-page "https://wiki.gnome.org/Projects/Vala/")
+ (synopsis "Compiler using the GObject type system")
+ (description "Vala is a programming language using modern high level
+abstractions without imposing additional runtime requirements and without using
+a different ABI compared to applications and libraries written in C. Vala uses
+the GObject type system and has additional code generation routines that make
+targeting the GNOME stack simple.")
+ (license license:lgpl2.1+)))
;;; An older variant kept to build libsoup-minimal-2.
(define-public vala-0.52
@@ -4653,16 +4566,16 @@ and RDP protocols.")
(inputs
(list gtk+ dbus))
(native-inputs
- `(("bash-completion" ,bash-completion)
- ("libxslt" ,libxslt) ;for xsltproc
- ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
- ("docbook-xml" ,docbook-xml-4.2)
- ("docbook-xsl" ,docbook-xsl)
- ("glib:bin" ,glib "bin")
- ("gtk-doc" ,gtk-doc/stable)
- ("pkg-config" ,pkg-config)
- ("python" ,python)
- ("vala" ,vala)))
+ (list bash-completion
+ libxslt ;for xsltproc
+ libxml2 ;for XML_CATALOG_FILES
+ docbook-xml-4.2
+ docbook-xsl
+ `(,glib "bin")
+ gtk-doc/stable
+ pkg-config
+ python
+ vala))
(arguments
`(#:glib-or-gtk? #t
#:configure-flags '("-Dgtk_doc=true")
@@ -4814,7 +4727,7 @@ indicators etc).")
(define-public glib-networking
(package
(name "glib-networking")
- (version "2.70.0")
+ (version "2.72.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/glib-networking/"
@@ -4822,7 +4735,7 @@ indicators etc).")
"glib-networking-" version ".tar.xz"))
(sha256
(base32
- "0dbg1na239mbavn4hknkax5sns9q2dbdnqw9wcpmhv58mzkhid36"))
+ "0s42l6dkajciqc99zp6dc9l8yv9g8w7d8mgv97l7h7drgd60hand"))
(patches
(search-patches "glib-networking-gnutls-binding.patch"))))
(build-system meson-build-system)
@@ -4838,8 +4751,7 @@ indicators etc).")
(search-patch
"glib-networking-32-bit-time.patch")))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("gettext" ,gettext-minimal)))
+ (list pkg-config gettext-minimal))
(inputs
(list glib gnutls gsettings-desktop-schemas libproxy))
(home-page "https://wiki.gnome.org/Projects/GLib")
@@ -4871,14 +4783,10 @@ from the GSettings schemas in gsettings-desktop-schemas.")
#:configure-flags
'("--with-ca-certificates=/etc/ssl/certs/ca-certificates.crt")))
(native-inputs
- `(("glib-mkenums" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)))
+ (list `(,glib "bin") gobject-introspection pkg-config))
(propagated-inputs
;; rest-0.7.pc refers to all these.
- `(("glib" ,glib)
- ("libsoup" ,libsoup-minimal-2)
- ("libxml2" ,libxml2)))
+ (list glib libsoup-minimal-2 libxml2))
(home-page "https://www.gtk.org/")
(synopsis "RESTful web api query library")
(description
@@ -4891,7 +4799,7 @@ libxml to ease remote use of the RESTful API.")
(define-public libsoup-minimal
(package
(name "libsoup-minimal")
- (version "3.0.4")
+ (version "3.0.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsoup/"
@@ -4899,7 +4807,7 @@ libxml to ease remote use of the RESTful API.")
"libsoup-" version ".tar.xz"))
(sha256
(base32
- "0ysnvvfd2f6w2z6g31spqqb8wgyamixc7mryzbbpyw0z15g8plsv"))))
+ "1j7p3cz6hwi9js9rp0pbas7cdln97yg9v2l1nv5imhcr6p7r1pzb"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dgtk_doc=false")
@@ -4924,7 +4832,6 @@ libxml to ease remote use of the RESTful API.")
(native-inputs
(list `(,glib "bin") ;for glib-mkenums
gobject-introspection
- intltool
pkg-config
python-wrapper
vala
@@ -4953,8 +4860,9 @@ and the GLib main loop, to integrate well with GNOME applications.")
;;; An older variant kept to build the 'rest' package.
(define-public libsoup-minimal-2
- (package/inherit libsoup-minimal
- (version "2.72.0")
+ (package
+ (inherit libsoup-minimal)
+ (version "2.74.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsoup/"
@@ -4962,7 +4870,7 @@ and the GLib main loop, to integrate well with GNOME applications.")
"libsoup-" version ".tar.xz"))
(sha256
(base32
- "11skbyw2pw32178q3h8pi7xqa41b2x4k6q4k9f75zxmh8s23y30p"))))
+ "0n8is108n0dn4dw7nm2wq9rydcm1vy47w40wywfrxqazdrjjg97h"))))
(arguments
(substitute-keyword-arguments (package-arguments libsoup-minimal)
((#:phases phases)
@@ -5283,65 +5191,68 @@ keyboard shortcuts.")
(define-public colord-minimal
(package
(name "colord-minimal")
- (version "1.4.5")
+ (version "1.4.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.freedesktop.org/software/colord/releases/"
"colord-" version ".tar.xz"))
(sha256
- (base32 "05sydi6qqqx1rrqwnga1vbg9srkf89wdcfw5w4p4m7r37m2flx5p"))))
+ (base32 "0vwfx06k1in8hci3kdxpc3c0bh81f1vl5bp7favd3rdz4wd661vl"))))
(build-system meson-build-system)
(arguments
- '( ;; FIXME: One test fails:
- ;; /colord/icc-store (in lib/colord/colord-self-test-private):
- ;; Incorrect content type for /tmp/colord-vkve/already-exists.icc, got
- ;; application/x-zerosize
- #:tests? #f
- #:glib-or-gtk? #t
- #:configure-flags (list "-Dargyllcms_sensor=false" ;requires spotread
- "-Dbash_completion=false"
- "-Ddaemon_user=colord"
- "-Ddocs=false"
- "-Dlocalstatedir=/var"
- "-Dman=false"
- "-Dsane=true"
- "-Dsystemd=false") ;no systemd
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-build-system
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "rules/meson.build"
- (("udev.get_pkgconfig_variable\\('udevdir'\\)")
- (string-append "'" (assoc-ref outputs "out") "/lib/udev'")))))
- (add-before 'configure 'set-sqlite3-file-name
- (lambda* (#:key inputs #:allow-other-keys)
- ;; "colormgr dump" works by invoking the "sqlite3" command.
- ;; Record its absolute file name.
- (let ((sqlite (assoc-ref inputs "sqlite")))
- (substitute* "client/cd-util.c"
- (("\"sqlite3\"")
- (string-append "\"" sqlite "/bin/sqlite3\"")))))))))
- (native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-compile-resources, etc.
- ("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)))
+ (list
+ #:glib-or-gtk? #t
+ #:configure-flags #~(list "-Dargyllcms_sensor=false" ;requires spotread
+ "-Dbash_completion=false"
+ "-Ddaemon_user=colord"
+ "-Ddocs=false"
+ "-Dlocalstatedir=/var"
+ "-Dman=false"
+ "-Dsane=true"
+ "-Dsystemd=false") ;no systemd
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-problematic-tests
+ (lambda _
+ ;; Skip the colord-test-private, which requires a *system* D-Bus
+ ;; session, which wants to run as root, among other requirements
+ ;; (see: https://github.com/hughsie/colord/issues/97).
+ (substitute* "lib/colord/meson.build"
+ ((".*test\\('colord-test-private'.*") ""))))
+ (add-before 'configure 'patch-build-system
+ (lambda _
+ (substitute* "rules/meson.build"
+ (("udev.get_pkgconfig_variable\\('udevdir'\\)")
+ (string-append "'" #$output "/lib/udev'")))))
+ (add-before 'configure 'set-sqlite3-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; "colormgr dump" works by invoking the "sqlite3" command.
+ ;; Record its absolute file name.
+ (substitute* "client/cd-util.c"
+ (("\"sqlite3\"")
+ (format #f "~s" (search-input-file inputs
+ "bin/sqlite3")))))))))
+ (native-inputs
+ (list `(,glib "bin") ; for glib-compile-resources, etc.
+ gettext-minimal
+ pkg-config
+ vala))
(propagated-inputs
;; colord.pc refers to all these.
- `(("glib" ,glib)
- ("lcms" ,lcms)
- ("udev" ,eudev)))
+ (list glib
+ lcms
+ eudev))
(inputs
- `(("dbus-glib" ,dbus-glib)
- ("gobject-introspection" ,gobject-introspection)
- ("gusb" ,gusb-minimal)
- ("libgudev" ,libgudev)
- ("libusb" ,libusb)
- ("polkit" ,polkit)
- ("python" ,python-wrapper)
- ("sqlite" ,sqlite)
- ("sane-backends" ,sane-backends)))
+ (list dbus-glib
+ gobject-introspection
+ gusb-minimal
+ libgudev
+ libusb
+ polkit
+ python-wrapper
+ sqlite
+ sane-backends))
(home-page "https://www.freedesktop.org/software/colord/")
(synopsis "Color management service")
(description "Colord is a system service that makes it easy to manage,
@@ -5356,33 +5267,32 @@ output devices.")
(substitute-keyword-arguments
(package-arguments colord-minimal)
((#:configure-flags flags)
- `(begin
- (use-modules (srfi srfi-1))
- (append '("-Dbash_completion=true"
- "-Ddocs=true"
- "-Dman=true"
- "-Dvapi=true")
- (fold delete ,flags '("-Dbash_completion=false"
- "-Ddocs=false"
- "-Dman=false")))))
+ #~(begin
+ (use-modules (srfi srfi-1))
+ (append '("-Dbash_completion=true"
+ "-Ddocs=true"
+ "-Dman=true"
+ "-Dvapi=true")
+ (fold delete #$flags '("-Dbash_completion=false"
+ "-Ddocs=false"
+ "-Dman=false")))))
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'fix-bash-completion-dir
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "data/meson.build"
- (("bash_completion.get_pkgconfig_variable\
+ #~(modify-phases #$phases
+ (add-after 'unpack 'fix-bash-completion-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "data/meson.build"
+ (("bash_completion.get_pkgconfig_variable\
\\('completionsdir'\\)")
- (string-append "'" (assoc-ref outputs "out")
- "/etc/bash_completion.d'")))))))))
+ (string-append "'" #$output
+ "/etc/bash_completion.d'")))))))))
(native-inputs
- (append
- `(("bash-completion" ,bash-completion)
- ("docbook-xsl-ns" ,docbook-xsl-ns)
- ("gtk-doc" ,gtk-doc/stable)
- ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
- ("libxslt" ,libxslt)
- ("vala" ,vala)) ;for VAPI, needed by simple-scan
- (package-native-inputs colord-minimal)))))
+ (modify-inputs (package-native-inputs colord-minimal)
+ (append bash-completion
+ docbook-xsl-ns
+ gtk-doc/stable
+ libxml2 ;for XML_CATALOG_FILES
+ libxslt
+ vala))))) ;for VAPI, needed by simple-scan
(define-public geoclue
(package
@@ -6997,16 +6907,13 @@ of running programs and invoke methods on those interfaces.")
(base32 "19d46rkajvr0f04560vlrzwvac88x5j8ilvzwkawbn5vjg069kf8"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- (list
- "--enable-doc")))
+ '(#:configure-flags '("--enable-doc")))
(native-inputs
- `(("ducktype" ,mallard-ducktype)
- ("gettext" ,gettext-minimal)
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("xmllint" ,libxml2)
- ("xsltproc" ,libxslt)))
+ (list mallard-ducktype
+ gettext-minimal
+ itstool
+ libxml2
+ libxslt))
(synopsis "XSL stylesheets for Yelp")
(description "Yelp-XSL is a collection of programs and data files to help
you build, maintain, and distribute documentation. It provides XSLT stylesheets
@@ -7430,7 +7337,7 @@ javascript engine and the GObject introspection framework.")
glib
gspell
gtk+
- gtksourceview
+ gtksourceview-4
libpeas
libxml2
iso-codes
@@ -9602,7 +9509,7 @@ world.")
;; XXX: Find out exactly which ones are needed and why.
("font-abattis-cantarell" ,font-abattis-cantarell)
("font-dejavu" ,font-dejavu)
- ("at-spi2-core" ,at-spi2-core-minimal)
+ ("at-spi2-core" ,at-spi2-core)
("dbus" ,dbus)
("dconf" ,dconf)
("desktop-file-utils" ,desktop-file-utils)
@@ -10257,7 +10164,7 @@ handling the startup notification side.")
python))
(inputs
(list `(,glib "bin")
- gtksourceview
+ gtksourceview-4
libgee
libhandy
libsoup-minimal-2
@@ -10289,7 +10196,7 @@ is suitable as a default application in a Desktop environment.")
(list autoconf automake
`(,gtk+ "bin") intltool pkg-config))
(inputs
- (list gtksourceview libsm))
+ (list gtksourceview-4 libsm))
(home-page "https://wiki.gnome.org/Apps/Xpad")
(synopsis "Virtual sticky note")
(description
@@ -10549,7 +10456,7 @@ accessibility infrastructure.")
pkg-config
libxml2))
(inputs
- (list at-spi2-atk
+ (list at-spi2-core
gsettings-desktop-schemas
gstreamer
gst-plugins-base
@@ -11441,7 +11348,7 @@ higher level porcelain stuff.")
gsettings-desktop-schemas
gspell
gtk+
- gtksourceview
+ gtksourceview-4
json-glib
libdazzle
libgee
@@ -11753,7 +11660,7 @@ integrate seamlessly with the GNOME desktop.")
gsettings-desktop-schemas
gtk+
gtk-vnc
- gtksourceview
+ gtksourceview-4
json-glib
libhandy
libosinfo
@@ -11950,7 +11857,7 @@ card sheets that you’ll find at most office supply stores.")
gsettings-desktop-schemas
gspell
gtk+
- gtksourceview
+ gtksourceview-4
libgee
tepl-5
uchardet))
@@ -12005,7 +11912,7 @@ and toolbars.")
`(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gspell" ,gspell)
("gtk+" ,gtk+)
- ("gtksourceview" ,gtksourceview)
+ ("gtksourceview" ,gtksourceview-4)
("pango" ,pango)
("poppler" ,poppler)
("python-pdfminer" ,python-pdfminer-six)
@@ -12451,7 +12358,7 @@ libraries. Applications do not need to be recompiled--or even restarted.")
template-glib
vte
webkitgtk-with-libsoup2))
- (propagated-inputs (list gtksourceview)) ; needed for settings
+ (propagated-inputs (list gtksourceview-4)) ; needed for settings
(native-inputs (list desktop-file-utils ; for desktop-file-validate
`(,glib "bin")
gettext-minimal
@@ -12656,7 +12563,7 @@ your data.")
("itstool" ,itstool)
("pkg-config" ,pkg-config)))
(propagated-inputs
- (list gtksourceview)) ; required for source view
+ (list gtksourceview-4)) ; required for source view
(arguments
`(#:build-type "release"
#:glib-or-gtk? #t