summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm60
1 files changed, 31 insertions, 29 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 6c0eda99c8..6e43dc9918 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
@@ -64,14 +64,14 @@
(define-public orc
(package
(name "orc")
- (version "0.4.26")
+ (version "0.4.27")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
"orc/orc-" version ".tar.xz"))
(sha256
(base32
- "0jd69ynvr3k70mlxxgbsk047l1rd63m1wkj3qdcq7644xy0gllkx"))))
+ "14vbwdydwarcvswzf744jdjb3ibhv6k4j6hzdacfan41zic3xrai"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -98,7 +98,7 @@ arrays of data.")
(define-public gstreamer
(package
(name "gstreamer")
- (version "1.12.1")
+ (version "1.12.2")
(source
(origin
(method url-fetch)
@@ -107,7 +107,7 @@ arrays of data.")
version ".tar.xz"))
(sha256
(base32
- "1lm6lcr0rv0mzsdl9vjdnf3vb136qmcslvz3m5zlai7zngcbji4h"))))
+ "1fllz7n58lavyy4nh64xc7izd4ffhl12a2ff0yg4z67al8wkzplz"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments
@@ -146,7 +146,7 @@ This package provides the core library and elements.")
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
- (version "1.12.1")
+ (version "1.12.2")
(source
(origin
(method url-fetch)
@@ -154,7 +154,7 @@ This package provides the core library and elements.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0r84krn8dpimp6kk9cf38danrbbsypx6j6ykr6rl1a3lnnnrzkhc"))))
+ "0x86a7aph0y6gyq178plvwvbbyhkfb3hf0gadx9sk5z1mzixqrsh"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
@@ -201,7 +201,7 @@ for the GStreamer multimedia library.")
(define-public gst-plugins-good
(package
(name "gst-plugins-good")
- (version "1.12.1")
+ (version "1.12.2")
(source
(origin
(method url-fetch)
@@ -210,7 +210,7 @@ for the GStreamer multimedia library.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0jzm5jp22238y3rb0j1dsxyp77dq0wk03gn9kvq25rphlx38w7hj"))))
+ "15pfw54fsh9s9xwrnbap4z4njwgqdfvq52k562d2hc5b11rfx4am"))))
(build-system gnu-build-system)
(inputs
`(("aalib" ,aalib)
@@ -244,15 +244,9 @@ for the GStreamer multimedia library.")
'unpack 'disable-failing-tests
(lambda _
;; Disable tests that fail non-deterministically.
- ;; XXX FIXME: Try removing this for version > 1.8.0.
- (substitute* "tests/check/elements/rtprtx.c"
- (("tcase_add_test \\(tc_chain, test_push_forward_seq\\);" all)
- (string-append "/* " all " */"))
- (("tcase_add_test \
-\\(tc_chain, test_rtxreceive_data_reconstruction\\);" all)
- (string-append "/* " all " */")))
- (substitute* "tests/check/elements/splitmux.c"
- (("tcase_add_test \\(tc_chain, test_splitmuxsink\\);" all)
+ ;; This test fails on aarch64 on 1.12.x.
+ (substitute* "tests/check/elements/alpha.c"
+ (("tcase_add_test \\(tc_chain, test_chromakeying\\);" all)
(string-append "/* " all " */")))
#t)))))
(home-page "https://gstreamer.freedesktop.org/")
@@ -266,14 +260,14 @@ developers consider to have good quality code and correct functionality.")
(define-public gst-plugins-bad
(package
(name "gst-plugins-bad")
- (version "1.12.1")
+ (version "1.12.2")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/src/"
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "15svf3d4n13r1c18mx9ya3ymibv0vbx9s593j0cm0kn4s54q1vvx"))))
+ "0dwyq03g2m0p16dwx8q5qvjn5x9ia72h21sf87mp97gmwkfpwb4w"))))
(outputs '("out" "doc"))
(build-system gnu-build-system)
(arguments
@@ -281,7 +275,16 @@ developers consider to have good quality code and correct functionality.")
#:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ "/share/gtk-doc/html"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-openjpeg-reference
+ (lambda _
+ ;; Remove hard-coded openjpeg-2.1 path. 2.2 is API- and
+ ;; ABI-compatible.
+ (substitute* "ext/openjpeg/gstopenjpeg.h"
+ (("<openjpeg-2\\.1/") "<openjpeg-2.2/"))
+ #t)))))
(propagated-inputs
`(("gst-plugins-base" ,gst-plugins-base)))
(native-inputs
@@ -331,8 +334,7 @@ developers consider to have good quality code and correct functionality.")
;("qtx11extras" ,qtx11extras)
("soundtouch" ,soundtouch)
("x265" ,x265)
- ;("wayland" ,wayland) ; needs gtk+ built with wayland support
- ))
+ ("wayland" ,wayland)))
(home-page "https://gstreamer.freedesktop.org/")
(synopsis "Plugins for the GStreamer multimedia library")
(description
@@ -343,7 +345,7 @@ par compared to the rest.")
(define-public gst-plugins-ugly
(package
(name "gst-plugins-ugly")
- (version "1.12.1")
+ (version "1.12.2")
(source
(origin
(method url-fetch)
@@ -351,7 +353,7 @@ par compared to the rest.")
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "0s8hiv4asqd6nwnksqv6cwpzan41zd0nd8nhlm7s64wp0lyi5hlg"))))
+ "0rplyp1qk359c97ig9i2vc1v34g92khd8dslwfipva1ypwmr9hqw"))))
(build-system gnu-build-system)
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
@@ -382,7 +384,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
(define-public gst-libav
(package
(name "gst-libav")
- (version "1.12.1")
+ (version "1.12.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -390,7 +392,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0xshib0hsn8yjmd12ipsrbrvxa5qnhnz7zmdj7lms6b3vwzq5msm"))))
+ "1crdahkjm23byg1awcrjkmgfbalfpvvac7h7whm6b2r1pfwkbdsv"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-system-libav")
@@ -420,7 +422,7 @@ compression formats through the use of the libav library.")
(define-public python-gst
(package
(name "python-gst")
- (version "1.12.1")
+ (version "1.12.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -428,7 +430,7 @@ compression formats through the use of the libav library.")
"gst-python-" version ".tar.xz"))
(sha256
(base32
- "18bq03xdc0jgrza4114lrcj82yai4azkjzfxflqagc0y417vw88p"))))
+ "0iwy0v2k27wd3957ich6j5f0f04b0wb2mb175ypf2lx68snk5k7l"))))
(build-system gnu-build-system)
(arguments
;; XXX: Factorize python-sitedir with python-build-system.